aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Dietze <mdietze@gmail.com>2014-01-03 18:41:29 +0100
committerMartin Dietze <mdietze@gmail.com>2014-01-03 18:41:29 +0100
commitb7a871238d9afa79ee6741d496ed23031bb3c6ab (patch)
treeabf6cd7bedca9e9bc5073dd88b4f95fcad4b250e
parente2c6cadfa26868cab88af89acab4071b94e30153 (diff)
downloadopenembedded-b7a871238d9afa79ee6741d496ed23031bb3c6ab.tar.gz
Fixed wpa supplicant: madwifi was not activated.
-rw-r--r--conf/distro/nylon.conf2
-rw-r--r--conf/machine/mtx-1.conf1
-rw-r--r--conf/machine/mtx-2.conf1
-rw-r--r--conf/machine/mtx-3.conf1
-rw-r--r--conf/machine/mtx-3a.conf1
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant-0.5.10/driver-madwifi.patch23
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant_0.5.10.bb5
7 files changed, 34 insertions, 0 deletions
diff --git a/conf/distro/nylon.conf b/conf/distro/nylon.conf
index 7b053ca003..531db3bc0a 100644
--- a/conf/distro/nylon.conf
+++ b/conf/distro/nylon.conf
@@ -19,6 +19,8 @@ INHERIT += "linux-kernel-base"
require conf/distro/include/sane-srcdates.inc
require conf/distro/include/sane-srcrevs.inc
+DISTRO_FEATURES = "nfs wifi ppp pcmcia usbgadget usbhost pci"
+
LIBC = "glibc"
require conf/distro/include/${LIBC}.inc
PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}gcc-initial:gcc-cross-initial"
diff --git a/conf/machine/mtx-1.conf b/conf/machine/mtx-1.conf
index 33a69f45b3..3b61d72d4e 100644
--- a/conf/machine/mtx-1.conf
+++ b/conf/machine/mtx-1.conf
@@ -3,6 +3,7 @@
#@DESCRIPTION: Machine configuration for the mtx-1 (aka MeshCube)
TARGET_ARCH = "mipsel"
+MACHINE_FEATURES = "pci usbhost usbgadget ethernet serial"
PACKAGE_ARCHS = "all mipsel ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-1"
diff --git a/conf/machine/mtx-2.conf b/conf/machine/mtx-2.conf
index 438c1fed79..a56f3dbd9c 100644
--- a/conf/machine/mtx-2.conf
+++ b/conf/machine/mtx-2.conf
@@ -3,6 +3,7 @@
#@DESCRIPTION: Machine configuration for the mtx-2 (aka SurfBox 2nd generation)
TARGET_ARCH = "mipsel"
+MACHINE_FEATURES = "pci usbhost usbgadget ethernet serial"
PACKAGE_ARCHS = "all mipsel ${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-2"
diff --git a/conf/machine/mtx-3.conf b/conf/machine/mtx-3.conf
index d6d14d86df..5deaddb83a 100644
--- a/conf/machine/mtx-3.conf
+++ b/conf/machine/mtx-3.conf
@@ -8,6 +8,7 @@
# TARGET_ARCH should be set here in the machine configuration.
# For compiling the kernel, ARCH will be derived form it by kernel-arch.bbclass
TARGET_ARCH = "arm"
+MACHINE_FEATURES = "pci usbhost usbgadget ethernet serial"
require conf/machine/include/tune-arm926ejs.inc
diff --git a/conf/machine/mtx-3a.conf b/conf/machine/mtx-3a.conf
index cb1b129660..8d8107a691 100644
--- a/conf/machine/mtx-3a.conf
+++ b/conf/machine/mtx-3a.conf
@@ -5,6 +5,7 @@
include conf/machine/mtx-3.conf
TARGET_ARCH = "arm"
+MACHINE_FEATURES = "pci usbhost usbgadget ethernet serial"
PREFERRED_PROVIDER_virtual/kernel = "linux-mtx-3a"
EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 -n"
USE_VT = "0"
diff --git a/recipes/wpa-supplicant/wpa-supplicant-0.5.10/driver-madwifi.patch b/recipes/wpa-supplicant/wpa-supplicant-0.5.10/driver-madwifi.patch
new file mode 100644
index 0000000000..c378f82dd3
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-supplicant-0.5.10/driver-madwifi.patch
@@ -0,0 +1,23 @@
+--- wpa_supplicant-0.5.10/driver_madwifi.c.orig 2014-01-03 18:29:14.000000000 +0100
++++ wpa_supplicant-0.5.10/driver_madwifi.c 2014-01-03 18:29:36.000000000 +0100
+@@ -24,15 +24,15 @@
+ #include "wpa.h"
+ #include "wireless_copy.h"
+
+-#include <include/compat.h>
+-#include <net80211/ieee80211.h>
++#include <madwifi/include/compat.h>
++#include <madwifi/net80211/ieee80211.h>
+ #ifdef WME_NUM_AC
+ /* Assume this is built against BSD branch of madwifi driver. */
+ #define MADWIFI_BSD
+-#include <net80211/_ieee80211.h>
++#include <madwifi/net80211/_ieee80211.h>
+ #endif /* WME_NUM_AC */
+-#include <net80211/ieee80211_crypto.h>
+-#include <net80211/ieee80211_ioctl.h>
++#include <madwifi/net80211/ieee80211_crypto.h>
++#include <madwifi/net80211/ieee80211_ioctl.h>
+
+ #ifdef IEEE80211_IOCTL_SETWMMPARAMS
+ /* Assume this is built against madwifi-ng */
diff --git a/recipes/wpa-supplicant/wpa-supplicant_0.5.10.bb b/recipes/wpa-supplicant/wpa-supplicant_0.5.10.bb
index 14186db40c..aadc3cb2b7 100644
--- a/recipes/wpa-supplicant/wpa-supplicant_0.5.10.bb
+++ b/recipes/wpa-supplicant/wpa-supplicant_0.5.10.bb
@@ -14,6 +14,11 @@ SRC_URI = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \
file://defconfig-gnutls \
file://ifupdown.sh \
file://functions.sh"
+SRC_URI_nylon = "http://hostap.epitest.fi/releases/wpa_supplicant-${PV}.tar.gz \
+ file://driver-madwifi.patch;patch=1\
+ file://defconfig-gnutls \
+ file://ifupdown.sh \
+ file://functions.sh"
S = "${WORKDIR}/wpa_supplicant-${PV}"