aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Lapin <slapinid@gmail.com>2007-07-27 21:54:23 +0000
committerSergey Lapin <slapinid@gmail.com>2007-07-27 21:54:23 +0000
commit04fe30d27b55b62feb752d11646c44c42ccc6e64 (patch)
tree0f720e71331ebaea415fbe7d10dc7ec6933ae9c9
parent1a78c97ede586276544211916b44d8467e60c3bf (diff)
parent9e59a4d34711a3c8e1f673ccb10dea0445e1a74b (diff)
downloadopenembedded-04fe30d27b55b62feb752d11646c44c42ccc6e64.tar.gz
merge of '80e11d2d53016f865ea2a634c725c9e643e7606b'
and '96140c2b284f4cb67311bf2ca1e0926bd7fb5cdd'
-rw-r--r--packages/gnuradio/gnuradio/no-trellis-doc.patch11
-rw-r--r--packages/gnuradio/gnuradio_svn.bb26
-rw-r--r--packages/guile/guile-native_1.8.2.bb133
3 files changed, 163 insertions, 7 deletions
diff --git a/packages/gnuradio/gnuradio/no-trellis-doc.patch b/packages/gnuradio/gnuradio/no-trellis-doc.patch
index 1e5148d3f9..039aed9c8e 100644
--- a/packages/gnuradio/gnuradio/no-trellis-doc.patch
+++ b/packages/gnuradio/gnuradio/no-trellis-doc.patch
@@ -7,3 +7,14 @@
-SUBDIRS = src doc
+SUBDIRS = src
+--- /tmp/Makefile.am 2007-07-27 19:18:00.000000000 +0200
++++ trunk/usrp/Makefile.am 2007-07-27 19:18:20.995215000 +0200
+@@ -20,7 +20,7 @@
+ #
+
+ EXTRA_DIST = usrp.pc.in usrp.iss.in usrp.inf
+-SUBDIRS = host firmware fpga doc
++SUBDIRS = host firmware fpga
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = usrp.pc
diff --git a/packages/gnuradio/gnuradio_svn.bb b/packages/gnuradio/gnuradio_svn.bb
index 30fe6ba916..a773a36321 100644
--- a/packages/gnuradio/gnuradio_svn.bb
+++ b/packages/gnuradio/gnuradio_svn.bb
@@ -2,13 +2,12 @@ DESCRIPTION = "GNU Radio"
SECTION = "apps"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = "fftwf python boost cppunit sdcc-native swig swig-native"
+DEPENDS = " guile-native fftwf python libusb virtual/libsdl alsa-lib jack boost cppunit sdcc-native swig-native"
-RDEPENDS_${PN} = "python-core python-audio python-codecs python-lang python-textutils swig"
+RDEPENDS_${PN} = "python-core python-audio python-codecs python-lang python-textutils"
PV = "3.0.4+svn${SRCDATE}"
-PR = "r1"
-
+PR = "r2"
SRC_URI = "svn://gnuradio.org/svn/gnuradio;module=trunk;proto=http \
file://no-trellis-doc.patch;patch=1 \
@@ -23,9 +22,22 @@ CXXFLAGS_powerpc += "-lstdc++"
export BUILD_SYS := "${BUILD_SYS}"
export HOST_SYS := "${HOST_SYS}"
-EXTRA_OECONF = "--disable-gr-atsc --disable-gr-video-sdl"
-
-PACKAGES =+ "libgromnithread libgnuradio-core libgnuradio-core-qa"
+EXTRA_OECONF = " \
+ --disable-gr-atsc \
+ --enable-gr-video-sdl \
+ --enable-gr-audio-alsa \
+ --enable-gr-audio-jack \
+ --enable-gr-audio-oss \
+ --enable-mblock \
+ "
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+PACKAGES =+ "libusrp libusrp-inband libgromnithread libgnuradio-core libgnuradio-core-qa"
+FILES_libusrp = "${libdir}/libusrp.so.*"
+FILES_libusrp-inband = "${libdir}/libusrp_inband.so.*"
FILES_libgnuradio-core = "${libdir}/libgnuradio-core.so.*"
FILES_libgnuradio-core-qa = "${libdir}/libgnuradio-core-qa.so.*"
FILES_libgromnithread = "${libdir}/libgromnithread.so*"
diff --git a/packages/guile/guile-native_1.8.2.bb b/packages/guile/guile-native_1.8.2.bb
new file mode 100644
index 0000000000..99d77b0da0
--- /dev/null
+++ b/packages/guile/guile-native_1.8.2.bb
@@ -0,0 +1,133 @@
+SECTION = "unknown"
+LICENSE = "GPL"
+SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
+ "
+
+inherit autotools native
+
+S="${WORKDIR}/guile-${PV}"
+
+OE_LT_RPATH_ALLOW = "any"
+LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+ # no autoreconf, thanks
+ oe_runconf
+}
+
+LIBGUILE_HEADERS = "\
+__scm.h \
+alist.h \
+arbiters.h \
+async.h \
+backtrace.h \
+boolean.h \
+chars.h \
+continuations.h \
+debug-malloc.h \
+debug.h \
+deprecation.h \
+dynl.h \
+dynwind.h \
+environments.h \
+eq.h \
+error.h \
+eval.h \
+evalext.h \
+extensions.h \
+feature.h \
+filesys.h \
+fluids.h \
+fports.h \
+gc.h \
+gdb_interface.h \
+gdbint.h \
+goops.h \
+gsubr.h \
+guardians.h \
+hash.h \
+hashtab.h \
+hooks.h \
+init.h \
+ioext.h \
+iselect.h \
+keywords.h \
+lang.h \
+list.h \
+load.h \
+macros.h \
+mallocs.h \
+modules.h \
+net_db.h \
+numbers.h \
+objects.h \
+objprop.h \
+options.h \
+pairs.h \
+ports.h \
+posix.h \
+print.h \
+procprop.h \
+procs.h \
+properties.h \
+ramap.h \
+random.h \
+rdelim.h \
+read.h \
+regex-posix.h \
+root.h \
+rw.h \
+scmconfig.h \
+scmsigs.h \
+script.h \
+simpos.h \
+smob.h \
+snarf.h \
+socket.h \
+sort.h \
+srcprop.h \
+stackchk.h \
+stacks.h \
+stime.h \
+strings.h \
+strorder.h \
+strports.h \
+struct.h \
+symbols.h \
+tags.h \
+threads.h \
+throw.h \
+unif.h \
+validate.h \
+values.h \
+variable.h \
+vectors.h \
+version.h \
+vports.h \
+weaks.h \
+"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/libguile
+ for i in ${LIBGUILE_HEADERS}; do
+ install -m 0644 libguile/$i ${STAGING_INCDIR}/libguile/$i
+ done
+
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 ${S}/libguile/.libs/guile ${STAGING_BINDIR_NATIVE}/
+
+ install -m 0644 libguile.h ${STAGING_INCDIR}/libguile.h
+ install -d ${STAGING_INCDIR}/guile
+ install -m 0644 libguile/gh.h ${STAGING_INCDIR}/guile/
+ install -d ${STAGING_INCDIR}/guile/srfi
+ install -d ${STAGING_INCDIR}/guile-readline
+ install -m 0644 guile-readline/readline.h ${STAGING_INCDIR}/guile-readline/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 guile-config/guile.m4 ${STAGING_DATADIR}/aclocal
+
+ install -d ${STAGING_DATADIR}/guile/1.8
+ cp -pPr ${S}/ice-9 ${STAGING_DATADIR}/guile/1.8/
+
+ oe_libinstall -C guile-readline -so -a libguilereadline-v-17 ${STAGING_LIBDIR}
+ oe_libinstall -C libguile -so -a libguile ${STAGING_LIBDIR}
+}