aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Cavallini <m.cavallini@koansoftware.com>2012-02-02 10:18:56 +0100
committerMarco Cavallini <m.cavallini@koansoftware.com>2012-02-02 10:18:56 +0100
commit3e454402452998cac95a0f02de78ad6c51949ac8 (patch)
tree9deca6f59f793c9acfc6b60642b1af5e3ba0db76
parentf4aa503f06896ac32c91e586480188ebd95d8835 (diff)
downloadopenembedded-3e454402452998cac95a0f02de78ad6c51949ac8.tar.gz
fakeroot_1.18.2: Upgrade to latest version.
* Earlier fakeroot recipes are not longer available * at the download source. * http://patches.openembedded.org/patch/20365/ * From: Ulf Samuelsson <ulf@emagii.com>
-rw-r--r--recipes/fakeroot/fakeroot-1.18.2/0001-quiet-getopt-check.patch30
-rw-r--r--recipes/fakeroot/fakeroot-1.18.2/0002-fix-prefix.patch30
-rw-r--r--recipes/fakeroot/fakeroot-native_1.18.2.bb33
-rw-r--r--recipes/fakeroot/fakeroot_1.18.2.bb20
4 files changed, 113 insertions, 0 deletions
diff --git a/recipes/fakeroot/fakeroot-1.18.2/0001-quiet-getopt-check.patch b/recipes/fakeroot/fakeroot-1.18.2/0001-quiet-getopt-check.patch
new file mode 100644
index 0000000000..d0e00f75ae
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-1.18.2/0001-quiet-getopt-check.patch
@@ -0,0 +1,30 @@
+From 1470e989b3136d1baef7e0e852849e6cf0638deb Mon Sep 17 00:00:00 2001
+From: Ulf Samuelsson <ulf@emagii.com>
+Date: Mon, 30 Jan 2012 22:43:53 +0100
+Subject: [PATCH 1/2] quiet getopt check
+
+busybox provided getopt prints the help-text on stderr
+
+Imported from an earlier version of fakeroot in openembedded
+
+Signed-off-by: Ulf Samuelsson <ulf@emagii.com>
+---
+ scripts/fakeroot.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/scripts/fakeroot.in b/scripts/fakeroot.in
+index 324a9dc..7e501bd 100755
+--- a/scripts/fakeroot.in
++++ b/scripts/fakeroot.in
+@@ -43,7 +43,7 @@ export FAKED_MODE
+
+ libfound=no
+
+-GETOPTEST=`getopt --version`
++GETOPTEST=`getopt --version 2> /dev/null`
+ case $GETOPTEST in
+ getopt*) # GNU getopt
+ FAKE_TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`
+--
+1.7.5.4
+
diff --git a/recipes/fakeroot/fakeroot-1.18.2/0002-fix-prefix.patch b/recipes/fakeroot/fakeroot-1.18.2/0002-fix-prefix.patch
new file mode 100644
index 0000000000..7aae9c8654
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-1.18.2/0002-fix-prefix.patch
@@ -0,0 +1,30 @@
+From 6bc2fc6d3907df936ed476591d09d9fe029e22ed Mon Sep 17 00:00:00 2001
+From: Ulf Samuelsson <ulf@emagii.com>
+Date: Mon, 30 Jan 2012 22:42:08 +0100
+Subject: [PATCH 2/2] fix prefix
+
+Ported from an earlier recipe in openembedded
+
+Signed-off-by: Ulf Samuelsson <ulf@emagii.com>
+---
+ scripts/fakeroot.in | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/scripts/fakeroot.in b/scripts/fakeroot.in
+index 7e501bd..9a0e750 100755
+--- a/scripts/fakeroot.in
++++ b/scripts/fakeroot.in
+@@ -30,8 +30,8 @@ fatal ()
+ }
+
+ # strip /bin/fakeroot to find install prefix
+-FAKEROOT_PREFIX=@prefix@
+-FAKEROOT_BINDIR=@bindir@
++FAKEROOT_BINDIR=`dirname $0`
++FAKEROOT_PREFIX=`dirname ${FAKEROOT_BINDIR}`
+
+ USEABSLIBPATH=@LDPRELOADABS@
+ LIB=lib@fakeroot_transformed@@DLSUFFIX@
+--
+1.7.5.4
+
diff --git a/recipes/fakeroot/fakeroot-native_1.18.2.bb b/recipes/fakeroot/fakeroot-native_1.18.2.bb
new file mode 100644
index 0000000000..d308f815c3
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-native_1.18.2.bb
@@ -0,0 +1,33 @@
+#From: Ulf Samuelsson <ulf@emagii.com>
+#Date: Mon, 30 Jan 2012 22:42:08 +0100
+
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPL"
+
+require fakeroot_${PV}.bb
+
+RDEPENDS_${PN} = "util-linux-native"
+
+SRC_URI += "file://0002-fix-prefix.patch "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+
+SRC_URI[md5sum] = "79f32331358ad58499704ea5e19fd0ae"
+SRC_URI[sha256sum] = "9dc942e3ef2ec83c6e6fe59de05da6ab54f39948be64803f37721adab4c6aed8"
+
+inherit native
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
diff --git a/recipes/fakeroot/fakeroot_1.18.2.bb b/recipes/fakeroot/fakeroot_1.18.2.bb
new file mode 100644
index 0000000000..83192b5c95
--- /dev/null
+++ b/recipes/fakeroot/fakeroot_1.18.2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS_${PN} = "util-linux"
+
+require fakeroot.inc
+
+PR = "${INC_PR}.0"
+
+inherit autotools
+
+SRC_URI =+ "\
+ ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
+ file://0001-quiet-getopt-check.patch \
+ "
+
+SRC_URI[md5sum] = "79f32331358ad58499704ea5e19fd0ae"
+SRC_URI[sha256sum] = "9dc942e3ef2ec83c6e6fe59de05da6ab54f39948be64803f37721adab4c6aed8"