aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Cavallini <m.cavallini@koansoftware.com>2011-10-14 17:05:28 +0200
committerMarco Cavallini <m.cavallini@koansoftware.com>2011-10-14 17:05:28 +0200
commit1831408cf1949576f5fd1526b8e4fd6a535f9e89 (patch)
tree05275e74546990af57f7d1f28163d717521f2e4a
parentc07e5f62b26f7a7008be04508bd3606974a70188 (diff)
downloadopenembedded-1831408cf1949576f5fd1526b8e4fd6a535f9e89.tar.gz
python-numpy: copied missing files from arm directory
* this is a temporary patch that allow build to complete * python-numpy mantainer should verify and reorganize files in this recipe
-rw-r--r--recipes/python/python-numpy/config.h21
-rw-r--r--recipes/python/python-numpy/numpyconfig.h17
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes/python/python-numpy/config.h b/recipes/python/python-numpy/config.h
new file mode 100644
index 0000000000..17ef186d56
--- /dev/null
+++ b/recipes/python/python-numpy/config.h
@@ -0,0 +1,21 @@
+/* ./src.linux-i686-2.5/numpy/core/include/numpy/config.h */
+/* #define SIZEOF_SHORT 2 */
+/* #define SIZEOF_INT 4 */
+/* #define SIZEOF_LONG 4 */
+/* #define SIZEOF_FLOAT 4 */
+/* #define SIZEOF_DOUBLE 8 */
+#define SIZEOF_LONG_DOUBLE 12
+#define SIZEOF_PY_INTPTR_T 4
+/* #define SIZEOF_LONG_LONG 8 */
+#define SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+#define MATHLIB m
+#define HAVE_FLOAT_FUNCS
+#define HAVE_LOG1P
+#define HAVE_EXPM1
+#define HAVE_INVERSE_HYPERBOLIC
+#define HAVE_INVERSE_HYPERBOLIC_FLOAT
+#define HAVE_ISNAN
+#define HAVE_ISINF
+#define HAVE_RINT
+
diff --git a/recipes/python/python-numpy/numpyconfig.h b/recipes/python/python-numpy/numpyconfig.h
new file mode 100644
index 0000000000..c4bf6547f0
--- /dev/null
+++ b/recipes/python/python-numpy/numpyconfig.h
@@ -0,0 +1,17 @@
+/* cat ./src.linux-i686-2.5/numpy/core/include/numpy/numpyconfig.h */
+/*
+ * * This file is generated by numpy/core/setup.pyc. DO NOT EDIT
+ * */
+#define NPY_SIZEOF_SHORT 2
+#define NPY_SIZEOF_INT 4
+#define NPY_SIZEOF_LONG 4
+#define NPY_SIZEOF_FLOAT 4
+#define NPY_SIZEOF_DOUBLE 8
+#define NPY_SIZEOF_LONGDOUBLE 12
+#define NPY_SIZEOF_PY_INTPTR_T 4
+#define NPY_NO_SMP 0
+
+#define NPY_SIZEOF_LONGLONG 8
+#define NPY_SIZEOF_PY_LONG_LONG 8
+/* #define CHAR_BIT 8 */
+