aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora-build.xora.org.uk>2011-03-04 11:30:56 +0000
committerGraeme Gregory <dp@xora-build.xora.org.uk>2011-03-04 11:30:56 +0000
commitfcb12f3a4448621ccc75d37dcad4a01820fdf89d (patch)
tree2da61b8f2f92e4cd688874b7fc2952fe3cd9b201
parenta3277c6f36996e199777f486e8d40aabbd4ea78f (diff)
downloadopenembedded-fcb12f3a4448621ccc75d37dcad4a01820fdf89d.tar.gz
pulseaudio_git : fix packaging
pulse uses a magic version file hidden in tarbal in order to determine its version so set that to out ${PV} from OE. Also git pulse has changed the default location of modules so set it to be same as old location for compatability. Signed-off-by: Graeme Gregory <dp@xora-build.xora.org.uk>
-rw-r--r--recipes/pulseaudio/pulseaudio_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/pulseaudio/pulseaudio_git.bb b/recipes/pulseaudio/pulseaudio_git.bb
index 28c581421a..057ded80b7 100644
--- a/recipes/pulseaudio/pulseaudio_git.bb
+++ b/recipes/pulseaudio/pulseaudio_git.bb
@@ -2,7 +2,7 @@ require pulseaudio.inc
SRCREV = "f834150aceccd753e3ac5bab9f7d64bed9993624"
PV = "0.9.22+git"
-PR = "${INC_PR}.0-r${SRCPV}"
+PR = "${INC_PR}.1-r${SRCPV}"
DEPENDS += "orc gdbm speex"
@@ -21,8 +21,12 @@ SRC_URI = "git://git.0pointer.de/pulseaudio.git;protocol=git \
S = "${WORKDIR}/git"
+EXTRA_OECONF += " --with-module-dir=${libdir}/pulse-${PV}/modules"
+
do_configure_prepend() {
touch config.rpath
+ echo "${PV}" >.tarball-version
+ echo "${PV}" >.version
}
# orc.m4 calls pkg-config ----variable=orcc orc-0.4 to get the path to orcc,