aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-03-09 14:52:58 +0100
committerKoen Kooi <koen@openembedded.org>2011-03-10 11:15:22 +0100
commit40a850649a6365426b45ccdb4a2e3bf8f07d60c1 (patch)
treee8a7e24fd4ac8f7fa04555073cf92567992c67e1
parentadfc8b48962b5944908d41d8095f6c5601e95481 (diff)
downloadopenembedded-40a850649a6365426b45ccdb4a2e3bf8f07d60c1.tar.gz
xmms: bandaid some more host path leakage
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/xmms/xmms_1.2.10.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes/xmms/xmms_1.2.10.bb b/recipes/xmms/xmms_1.2.10.bb
index 34b1e07a8e..aed1833bbc 100644
--- a/recipes/xmms/xmms_1.2.10.bb
+++ b/recipes/xmms/xmms_1.2.10.bb
@@ -10,7 +10,7 @@ SRC_URI = "http://www.xmms.org/files/1.2.x/xmms-${PV}.tar.bz2 \
file://xmms-config-dequote.patch \
file://acinclude.m4 \
file://xmms.sh"
-PR = "r6"
+PR = "r7"
RRECOMMENDS_${PN} = "xmms-plugin-output-oss xmms-plugin-output-alsa \
xmms-mad xmms-tremor"
@@ -33,6 +33,13 @@ do_configure_prepend() {
done
}
+do_configure_append() {
+ for i in $(find . -name "Makefile"); do
+ sed -i -e 's:L/usr/lib:L${STAGING_LIBDIR}:g' \
+ $i
+ done
+}
+
do_install_append() {
install -m 0755 ${WORKDIR}/xmms.sh ${D}${bindir}
install -d ${D}${datadir}/applications