aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-03-09 09:44:48 -0700
committerTom Rini <tom_rini@mentor.com>2011-03-09 12:17:15 -0700
commit0f61c69281b74c434540cf57364720f0bb5d7566 (patch)
tree3cff58d9de90c327da05dbec8c5175b7a90564dd
parenta2ac727a6f32616d0049c4f7b074f1c3d9bec8d6 (diff)
downloadopenembedded-0f61c69281b74c434540cf57364720f0bb5d7566.tar.gz
glib-2.0: Update to use 'inherit gettext'
This means never spelling out gettext-native, virtual/libiconv and virtual/libintl. We only need to add pkgconfig-native to DEPENDS for virtclass-native. Finally, move EXTRA_OECONF_virtclass-native to be with the rest of the EXTRA_OECONF's. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/glib-2.0/glib-2.0_2.22.4.bb8
-rw-r--r--recipes/glib-2.0/glib-2.0_2.23.6.bb8
-rw-r--r--recipes/glib-2.0/glib-2.0_2.24.0.bb6
-rw-r--r--recipes/glib-2.0/glib-2.0_2.24.1.bb6
-rw-r--r--recipes/glib-2.0/glib-2.0_2.26.1.bb6
-rw-r--r--recipes/glib-2.0/glib-2.0_2.28.0.bb6
6 files changed, 14 insertions, 26 deletions
diff --git a/recipes/glib-2.0/glib-2.0_2.22.4.bb b/recipes/glib-2.0/glib-2.0_2.22.4.bb
index 54a19f7096..37cc1463e8 100644
--- a/recipes/glib-2.0/glib-2.0_2.22.4.bb
+++ b/recipes/glib-2.0/glib-2.0_2.22.4.bb
@@ -6,7 +6,8 @@ UNIX-like platforms, Windows, OS/2 and BeOS."
LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "glib-2.0-native gtk-doc virtual/libiconv virtual/libintl"
+DEPENDS = "glib-2.0-native gtk-doc"
+DEPENDS_virtclass-native += "pkgconfig-native"
SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.22/glib-${PV}.tar.bz2;name=archive \
@@ -30,6 +31,7 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
+EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -42,10 +44,6 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
-DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
- pkgconfig-native"
-EXTRA_OECONF_virtclass-native = ""
-
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.23.6.bb b/recipes/glib-2.0/glib-2.0_2.23.6.bb
index 550e9752e7..b24e53bdc9 100644
--- a/recipes/glib-2.0/glib-2.0_2.23.6.bb
+++ b/recipes/glib-2.0/glib-2.0_2.23.6.bb
@@ -6,7 +6,8 @@ UNIX-like platforms, Windows, OS/2 and BeOS."
LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
-DEPENDS = "glib-2.0-native gtk-doc virtual/libiconv virtual/libintl zlib"
+DEPENDS = "glib-2.0-native gtk-doc zlib"
+DEPENDS_virtclass-native += "pkgconfig-native"
PR = "r3"
SRC_URI = "\
@@ -29,6 +30,7 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
+EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -41,10 +43,6 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
-DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
- pkgconfig-native"
-EXTRA_OECONF_virtclass-native = ""
-
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.24.0.bb b/recipes/glib-2.0/glib-2.0_2.24.0.bb
index 5bb79015e2..0230feb024 100644
--- a/recipes/glib-2.0/glib-2.0_2.24.0.bb
+++ b/recipes/glib-2.0/glib-2.0_2.24.0.bb
@@ -7,6 +7,7 @@ LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0-native gtk-doc zlib"
+DEPENDS_virtclass-native += "pkgconfig-native"
PR = "r6"
@@ -35,6 +36,7 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
+EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -47,10 +49,6 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
-DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
- pkgconfig-native"
-EXTRA_OECONF_virtclass-native = ""
-
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.24.1.bb b/recipes/glib-2.0/glib-2.0_2.24.1.bb
index b150a3fd24..34d505f3cc 100644
--- a/recipes/glib-2.0/glib-2.0_2.24.1.bb
+++ b/recipes/glib-2.0/glib-2.0_2.24.1.bb
@@ -7,8 +7,7 @@ LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0-native gtk-doc zlib"
-DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
- pkgconfig-native"
+DEPENDS_virtclass-native += "pkgconfig-native"
PR = "r2"
@@ -39,6 +38,7 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
+EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -51,8 +51,6 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
-EXTRA_OECONF_virtclass-native = ""
-
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.26.1.bb b/recipes/glib-2.0/glib-2.0_2.26.1.bb
index caccfde8c8..c1a41e24d6 100644
--- a/recipes/glib-2.0/glib-2.0_2.26.1.bb
+++ b/recipes/glib-2.0/glib-2.0_2.26.1.bb
@@ -7,8 +7,7 @@ LICENSE = "LGPLv2+"
SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "glib-2.0-native gtk-doc zlib"
-DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
- pkgconfig-native"
+DEPENDS_virtclass-native += "pkgconfig-native"
PR = "r3"
@@ -32,6 +31,7 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
+EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -45,8 +45,6 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
-EXTRA_OECONF_virtclass-native = ""
-
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"
diff --git a/recipes/glib-2.0/glib-2.0_2.28.0.bb b/recipes/glib-2.0/glib-2.0_2.28.0.bb
index 07e72d3a80..4e36b645b1 100644
--- a/recipes/glib-2.0/glib-2.0_2.28.0.bb
+++ b/recipes/glib-2.0/glib-2.0_2.28.0.bb
@@ -8,8 +8,7 @@ SECTION = "libs"
PRIORITY = "optional"
PR = "r1"
DEPENDS = "glib-2.0-native gtk-doc zlib"
-DEPENDS_virtclass-native = "gettext-native gtk-doc-native \
- pkgconfig-native"
+DEPENDS_virtclass-native += "pkgconfig-native"
SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.28/glib-${PV}.tar.bz2;name=archive \
@@ -31,6 +30,7 @@ inherit autotools gettext
S = "${WORKDIR}/glib-${PV}"
EXTRA_OECONF = "--disable-debug "
+EXTRA_OECONF_virtclass-native = ""
# Add and entry for your favourite arch if your (g)libc has a sane printf
EXTRA_OECONF_append_glibc_arm = " --enable-included-printf=no "
@@ -44,8 +44,6 @@ do_install_append() {
sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
}
-EXTRA_OECONF_virtclass-native = ""
-
do_configure_prepend_virtclass-native() {
if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
echo "${TARGET_SYS}-libtool already present"