aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-02-12 05:57:24 +0000
committerRod Whitby <rod@whitby.id.au>2007-02-12 05:57:24 +0000
commit613606be24cae0a114b2d1aa81ddca0d44b61a10 (patch)
tree7d6f42059bd62291026686cc842223f5a8d2400d
parent7edfef39a97bf8b6922f7fb4bfe50bd911ce76cb (diff)
downloadopenembedded-613606be24cae0a114b2d1aa81ddca0d44b61a10.tar.gz
slugos: Major build structure change - subsumed openslug and debianslug into a single slugos distribution which works with either nslu2be or nslu2le machines. Kept the openslug and debianslug conf files around to enable people to migrate smoothly, but eventually they will disappear.
-rw-r--r--conf/distro/debianslug.conf8
-rw-r--r--conf/distro/include/slugos.inc12
-rw-r--r--conf/distro/openslug-native.conf4
-rw-r--r--conf/distro/openslug.conf8
-rw-r--r--conf/distro/slugos.conf (renamed from conf/distro/slugosbe.conf)39
-rw-r--r--conf/distro/slugosle.conf115
-rw-r--r--conf/distro/ucslugc.conf6
-rw-r--r--packages/images/slugos-image.bb3
-rw-r--r--packages/meta/slugos-native-packages.bb1
-rw-r--r--packages/meta/slugos-native.bb1
-rw-r--r--packages/meta/slugos-packages.bb4
11 files changed, 38 insertions, 163 deletions
diff --git a/conf/distro/debianslug.conf b/conf/distro/debianslug.conf
index 925096813d..59123fd6b5 100644
--- a/conf/distro/debianslug.conf
+++ b/conf/distro/debianslug.conf
@@ -2,6 +2,10 @@
#@NAME: DebianSlug
#@DESCRIPTION: DebianSlug Linux Distribution for the NSLU2
-SLUGOS_DISTRO = "debianslug"
+DISTRO_NAME = "DebianSlug"
+IMAGE_BASENAME = "debianslug"
+TARGET_ARCH = "arm"
+ARM_INSTRUCTION_SET = "arm"
+TARGET_OS = "linux"
-require conf/distro/slugosle.conf
+require conf/distro/slugos.conf
diff --git a/conf/distro/include/slugos.inc b/conf/distro/include/slugos.inc
index 52b9e5bef5..a26a069fa0 100644
--- a/conf/distro/include/slugos.inc
+++ b/conf/distro/include/slugos.inc
@@ -23,9 +23,7 @@ DISTRO_VERSION ?= "${SLUGOS_VERSION}${DISTRO_REVISION}-${DISTRO_TYPE}"
# DISTRO_FEED ?= "${SLUGOS_VERSION}-${DISTRO_TYPE}"
DISTRO_FEED ?= "unstable"
-SLUGOS_DISTRO ?= "slugos"
-
-IMAGE_BASENAME = "${SLUGOS_DISTRO}"
+IMAGE_BASENAME = "${@['slugos${SITEINFO_ENDIANESS}', 'ucslugc'][bb.data.getVar('TARGET_OS', d, 1) == 'linux-uclibc']}"
# The following need not be set, the defaults should be adequate
#USE_NLS = "no" or "yes"
@@ -41,9 +39,7 @@ TARGET_FPU = "soft"
# glib-2.0 builds require USE_NLS to be overridden
USE_NLS_glib-2.0 = "yes"
-INHERIT += "package_ipk debian"
-
-DISTRO_BASE = ":slugos"
+INHERIT += "package_ipk debian multimachine"
# FULL_OPTIMIZATION
# Optimization settings. Os works fine and is significantly better than O2.
@@ -64,8 +60,8 @@ FULL_OPTIMIZATION = "-Os -fomit-frame-pointer -frename-registers \
# (such as a local feed) can be defined in local.conf
#----------------------------------------------------------------------------------
#
-FEED_URIS_append += "cross##http://ipkg.nslu2-linux.org/feeds/${SLUGOS_DISTRO}/cross/${DISTRO_FEED}"
-FEED_URIS_append += "native##http://ipkg.nslu2-linux.org/feeds/${SLUGOS_DISTRO}/native/${DISTRO_FEED}"
+FEED_URIS_append += "cross##http://ipkg.nslu2-linux.org/feeds/${IMAGE_BASENAME}/cross/${DISTRO_FEED}"
+FEED_URIS_append += "native##http://ipkg.nslu2-linux.org/feeds/${IMAGE_BASENAME}/native/${DISTRO_FEED}"
#----------------------------------------------------------------------------------
# FIRMWARE CONFIGURATION
diff --git a/conf/distro/openslug-native.conf b/conf/distro/openslug-native.conf
index 2bcf6dd980..ac77532697 100644
--- a/conf/distro/openslug-native.conf
+++ b/conf/distro/openslug-native.conf
@@ -1,9 +1,7 @@
-SLUGOS_DISTRO = "openslug"
-
# Our build host is armeb, not armv5eb that the kernel reports
BUILD_ARCH = "armeb"
-require conf/distro/slugosbe.conf
+require conf/distro/openslug.conf
# Corresponding packages should be in openslug-native.bb,
# currently missing: ipkg-utils libtool quilt pkgconfig
diff --git a/conf/distro/openslug.conf b/conf/distro/openslug.conf
index 943ce1a985..f03c4f653e 100644
--- a/conf/distro/openslug.conf
+++ b/conf/distro/openslug.conf
@@ -2,6 +2,10 @@
#@NAME: OpenSlug
#@DESCRIPTION: OpenSlug Linux Distribution for the NSLU2
-SLUGOS_DISTRO = "openslug"
+DISTRO_NAME = "OpenSlug"
+IMAGE_BASENAME = "openslug"
+TARGET_ARCH = "armeb"
+ARM_INSTRUCTION_SET = "arm"
+TARGET_OS = "linux"
-require conf/distro/slugosbe.conf
+require conf/distro/slugos.conf
diff --git a/conf/distro/slugosbe.conf b/conf/distro/slugos.conf
index 4f664c58c3..32b047aeae 100644
--- a/conf/distro/slugosbe.conf
+++ b/conf/distro/slugos.conf
@@ -1,17 +1,15 @@
#@TYPE: Distribution
-#@NAME: SlugOS/BE
-#@DESCRIPTION: SlugOS/BE Linux Distribution for the NSLU2
+#@NAME: SlugOS
+#@DESCRIPTION: SlugOS Linux Distribution for the NSLU2
#----------------------------------------------------------------------------------
# STANDARD SlugOS/BE DEFINITIONS
#----------------------------------------------------------------------------------
-DISTRO_NAME = "SlugOS/BE"
+DISTRO_NAME = "SlugOS"
# DISTRO_VERSION = "${SLUGOS_VERSION}${DISTRO_REVISION}-${DISTRO_TYPE}"
# DISTRO_FEED = "unstable"
DISTRO_TYPE = "beta"
-SLUGOS_DISTRO ?= "slugosbe"
-
-TARGET_ARCH = "armeb"
+TARGET_ARCH ?= "armeb"
ARM_INSTRUCTION_SET = "arm"
TARGET_OS = "linux"
@@ -25,14 +23,13 @@ TARGET_OS = "linux"
# not absolutely required for boot.
# NOTE: only jffs2 support is an absolute requirement of boot, even
# the ext2/ext3 support is optional!
-SLUGOSBE_EXT2_PROGS = "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck e2fsprogs-badblocks"
+SLUGOS_EXT2_PROGS = "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck e2fsprogs-badblocks"
# The standard firmware contents and additional packages built as requirements
-# of the firmware are defined here in SLUGOSBE_STANDARD_RDEPENDS and
-# SLUGOSBE_STANDARD_DEPENDS respectively.
-SLUGOSBE_STANDARD_RDEPENDS = ""
+# of the firmware are defined here in SLUGOS_STANDARD_RDEPENDS.
+SLUGOS_STANDARD_RDEPENDS = ""
-# Support for a variety of file systems is built in to the slugosbe
+# Support for a variety of file systems is built in to the slugos
# image, programs to format disks with these file systems may be
# added or removed. By default ext2 and ext3 support
# is included by the following lines.
@@ -40,12 +37,12 @@ SLUGOSBE_STANDARD_RDEPENDS = ""
# These lines add support for formatting ext2 and ext3 file systems
# on a hard disk attached to the NSLU2. ext3 is the standard Linux
# file system.
-SLUGOSBE_STANDARD_RDEPENDS += "${SLUGOSBE_EXT2_PROGS}"
+SLUGOS_STANDARD_RDEPENDS += "${SLUGOS_EXT2_PROGS}"
# These lines add support for an X/Y/ZModem package called lrzsz
# (this is of use for people with modified NSLU2 hardware which
# supports a serial port.)
-SLUGOSBE_STANDARD_RDEPENDS += "lrzsz"
+SLUGOS_STANDARD_RDEPENDS += "lrzsz"
# Filesystem selection. Adding entries here adds the module to the
# image. The module must be built as part of nslu2-kernel (i.e. it
@@ -63,7 +60,7 @@ SLUGOSBE_STANDARD_RDEPENDS += "lrzsz"
# NOTE: removing kernel-module-nfs from this list will prevent NFS
# boot (however you can do a simple flash file system boot - no
# attached disk - and install the nfs modules from ssh.)
-SLUGOSBE_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RDEPENDS += "\
kernel-module-ext2 \
kernel-module-jbd \
kernel-module-ext3 \
@@ -76,24 +73,24 @@ kernel-module-nls-utf8 \
"
# Add daemon required for HW RNG support
-SLUGOSBE_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RDEPENDS += "\
rng-tools \
"
# Add modules required for usb support
-SLUGOSBE_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RDEPENDS += "\
kernel-module-ohci-hcd \
kernel-module-uhci-hcd \
"
# Add modules required for IDE support
-SLUGOSBE_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RDEPENDS += "\
kernel-module-libata \
kernel-module-pata-artop \
"
# Add modules required for Network support
-SLUGOSBE_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RDEPENDS += "\
kernel-module-via-velocity \
"
@@ -107,9 +104,7 @@ kernel-module-via-velocity \
# The 'standard' values are the defaults for the 'extra' packages added
# to the firmware image. None of these things are requirements to have
# a bootable, useable, system however they *are* expected to be present
-# in SlugOS/BE - see nslu2-bag for a more minimal configuration and some
-# more instructions about how to make a non-slugosbe image.
-SLUGOSBE_EXTRA_RDEPENDS ?= ""
-SLUGOS_EXTRA_RDEPENDS = "${SLUGOSBE_STANDARD_RDEPENDS} ${SLUGOSBE_EXTRA_RDEPENDS}"
+# in SlugOS.
+SLUGOS_EXTRA_RDEPENDS = "${SLUGOS_STANDARD_RDEPENDS}"
require conf/distro/include/slugos.inc
diff --git a/conf/distro/slugosle.conf b/conf/distro/slugosle.conf
deleted file mode 100644
index e703fe4553..0000000000
--- a/conf/distro/slugosle.conf
+++ /dev/null
@@ -1,115 +0,0 @@
-#@TYPE: Distribution
-#@NAME: SlugOS/LE
-#@DESCRIPTION: SlugOS/LE Linux Distribution for the NSLU2
-
-#----------------------------------------------------------------------------------
-# STANDARD SlugOS/LE DEFINITIONS
-#----------------------------------------------------------------------------------
-DISTRO_NAME = "SlugOS/LE"
-# DISTRO_VERSION = "${SLUGOS_VERSION}${DISTRO_REVISION}-${DISTRO_TYPE}"
-# DISTRO_FEED = "unstable"
-DISTRO_TYPE = "beta"
-SLUGOS_DISTRO ?= "slugosle"
-
-TARGET_ARCH = "arm"
-ARM_INSTRUCTION_SET = "arm"
-TARGET_OS = "linux"
-
-#----------------------------------------------------------------------------------
-# FIRMWARE CONFIGURATION
-#----------------------------------------------------------------------------------
-# EXTRA PACKAGES
-# --------------
-# Filesystem support modules are listed in here for easy removal,
-# as is the lrzsz serial package and other kernel modules which are
-# not absolutely required for boot.
-# NOTE: only jffs2 support is an absolute requirement of boot, even
-# the ext2/ext3 support is optional!
-SLUGOSLE_EXT2_PROGS = "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck e2fsprogs-badblocks"
-
-# The standard firmware contents and additional packages built as requirements
-# of the firmware are defined here in SLUGOSLE_STANDARD_RDEPENDS and
-# SLUGOSLE_STANDARD_DEPENDS respectively.
-SLUGOSLE_STANDARD_RDEPENDS = ""
-
-# Support for a variety of file systems is built in to the slugosle
-# image, programs to format disks with these file systems may be
-# added or removed. By default ext2 and ext3 support
-# is included by the following lines.
-#
-# These lines add support for formatting ext2 and ext3 file systems
-# on a hard disk attached to the NSLU2. ext3 is the standard Linux
-# file system.
-SLUGOSLE_STANDARD_RDEPENDS += "${SLUGOSLE_EXT2_PROGS}"
-
-# These lines add support for an X/Y/ZModem package called lrzsz
-# (this is of use for people with modified NSLU2 hardware which
-# supports a serial port.)
-SLUGOSLE_STANDARD_RDEPENDS += "lrzsz"
-
-# Filesystem selection. Adding entries here adds the module to the
-# image. The module must be built as part of nslu2-kernel (i.e. it
-# must be specified as a module in the defconfig file). The NLS
-# support charset modules must be given explicitly and must match
-# the codepage/iocharset and NLS handling for the file systems which
-# require them. The installed lanugage set is minimal but sufficient
-# for any file system (since it uses utf8). See
-# http://www.nslu2-linux.orgwiki/HowTo/MountFATFileSystems
-# for more information on the language behaviour of the DOS file
-# systems.
-#
-# KERNEL LEVEL FILE SYSTEM SUPPORT
-# --------------------------------
-# NOTE: removing kernel-module-nfs from this list will prevent NFS
-# boot (however you can do a simple flash file system boot - no
-# attached disk - and install the nfs modules from ssh.)
-SLUGOSLE_STANDARD_RDEPENDS += "\
-kernel-module-ext2 \
-kernel-module-jbd \
-kernel-module-ext3 \
-kernel-module-vfat \
-kernel-module-ntfs \
-kernel-module-isofs \
-kernel-module-udf \
-kernel-module-nls-cp437 \
-kernel-module-nls-utf8 \
-"
-
-# Add daemon required for HW RNG support
-SLUGOSLE_STANDARD_RDEPENDS += "\
-rng-tools \
-"
-
-# Add modules required for usb support
-SLUGOSLE_STANDARD_RDEPENDS += "\
-kernel-module-ohci-hcd \
-kernel-module-uhci-hcd \
-"
-
-# Add modules required for IDE support
-SLUGOSLE_STANDARD_RDEPENDS += "\
-kernel-module-libata \
-kernel-module-pata-artop \
-"
-
-# Add modules required for Network support
-OPENSLUG_STANDARD_RDEPENDS += "\
-kernel-module-via-velocity \
-"
-
-# This documents other file systems which are built but not installed
-# by default in the flash image.
-#
-# kernel-module-msdos - mounts a FAT file system without long file names
-# (use kernel-module-vfat, it shows the long names
-# if present.)
-
-# The 'standard' values are the defaults for the 'extra' packages added
-# to the firmware image. None of these things are requirements to have
-# a bootable, useable, system however they *are* expected to be present
-# in Slugosle - see slugos-lag for a more minimal configuration and some
-# more instructions about how to make a non-slugosle image.
-SLUGOSLE_EXTRA_RDEPENDS ?= ""
-SLUGOS_EXTRA_RDEPENDS = "${SLUGOSLE_STANDARD_RDEPENDS} ${SLUGOSLE_EXTRA_RDEPENDS}"
-
-require conf/distro/include/slugos.inc
diff --git a/conf/distro/ucslugc.conf b/conf/distro/ucslugc.conf
index 526b8f11b4..8b64746fe3 100644
--- a/conf/distro/ucslugc.conf
+++ b/conf/distro/ucslugc.conf
@@ -3,11 +3,7 @@
#@DESCRIPTION: UcSlugC Linux Distribution for the NSLU2
DISTRO_NAME = "UcSlugC"
-# DISTRO_VERSION = "${SLUGOS_VERSION}${DISTRO_REVISION}-${DISTRO_TYPE}"
-# DISTRO_FEED = "unstable"
-DISTRO_TYPE = "beta"
-SLUGOS_DISTRO = "ucslugc"
-
+IMAGE_BASENAME = "ucslugc"
TARGET_ARCH = "armeb"
ARM_INSTRUCTION_SET = "thumb"
TARGET_OS = "linux-uclibc"
diff --git a/packages/images/slugos-image.bb b/packages/images/slugos-image.bb
index 1ca30f9d9d..ce591f7e4e 100644
--- a/packages/images/slugos-image.bb
+++ b/packages/images/slugos-image.bb
@@ -7,11 +7,10 @@ DESCRIPTION = "Generic SlugOS image"
HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
PR = "r45"
-PROVIDES += "${SLUGOS_DISTRO}-image"
COMPATIBLE_MACHINE = "nslu2"
-IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}-${DISTRO_VERSION}"
+IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
IMAGE_FSTYPES = "jffs2"
EXTRA_IMAGECMD_jffs2 += " -D ${SLUGOS_DEVICE_TABLE}"
IMAGE_LINGUAS = ""
diff --git a/packages/meta/slugos-native-packages.bb b/packages/meta/slugos-native-packages.bb
index db2ab46a3c..4505c9979c 100644
--- a/packages/meta/slugos-native-packages.bb
+++ b/packages/meta/slugos-native-packages.bb
@@ -2,7 +2,6 @@
DESCRIPTION = "Packages that are to be compiled natively for the SlugOS firmware"
LICENSE = "MIT"
PR = "r1"
-PROVIDES += "${SLUGOS_DISTRO}-native-packages"
INHIBIT_DEFAULT_DEPS = "1"
EXCLUDE_FROM_WORLD = "1"
diff --git a/packages/meta/slugos-native.bb b/packages/meta/slugos-native.bb
index 9a4e17d56a..3b4023ba45 100644
--- a/packages/meta/slugos-native.bb
+++ b/packages/meta/slugos-native.bb
@@ -11,7 +11,6 @@ INHIBIT_DEFAULT_DEPS = "1"
EXCLUDE_FROM_WORLD = "1"
ALLOW_EMPTY = "1"
PACKAGES = "${PN}"
-PROVIDES += "${SLUGOS_DISTRO}-native"
# Run-time only (RDEPENDS) stuff - no package explicitly provides
# these targets.
diff --git a/packages/meta/slugos-packages.bb b/packages/meta/slugos-packages.bb
index 507600df32..064adaf03e 100644
--- a/packages/meta/slugos-packages.bb
+++ b/packages/meta/slugos-packages.bb
@@ -5,9 +5,8 @@
DESCRIPTION = "Packages that are compatible with the SlugOS firmware"
HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
-PR = "r17"
+PR = "r18"
CONFLICTS = "db3"
-PROVIDES += "${SLUGOS_DISTRO}-packages"
COMPATIBLE_MACHINE = "nslu2"
EXCLUDE_FROM_WORLD = "1"
@@ -106,6 +105,7 @@ SLUGOS_PACKAGES = "\
make \
masqmail \
mdadm \
+ mediatomb \
memtester \
mgetty \
miau \