aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-06-09 15:20:41 +0200
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2009-06-09 16:02:20 +0200
commit9819c4c798ef82ee515a88fd900924ce768e75a7 (patch)
tree7672c35b411f17d79c372de15616772e9a0690c3
parente91abf92fe3b55ed7a1bed4d75004a5df0b164be (diff)
downloadopenembedded-9819c4c798ef82ee515a88fd900924ce768e75a7.tar.gz
guile: added guile and guile-native 1.8.6 using .inc files
*not bumping PR of 1.8.5 becuase the result of the recipe doesn't change *guile 1.8.6 works with libtool 2.x: http://git.savannah.gnu.org/gitweb/?p=guile.git;a=blob;f=NEWS;h=d5c6771d09f5a181122cf16c0723f02182314704;hb=43ec70085aad9fa368e7f64080427d40fa68c47b) while guile 1.8.5 doesn't: http://www.mail-archive.com/bug-guile@gnu.org/msg04579.html
-rw-r--r--recipes/guile/guile-native.inc132
-rw-r--r--recipes/guile/guile-native_1.8.5.bb134
-rw-r--r--recipes/guile/guile-native_1.8.6.bb4
-rw-r--r--recipes/guile/guile.inc45
-rw-r--r--recipes/guile/guile_1.8.5.bb50
-rw-r--r--recipes/guile/guile_1.8.6.bb6
6 files changed, 193 insertions, 178 deletions
diff --git a/recipes/guile/guile-native.inc b/recipes/guile/guile-native.inc
new file mode 100644
index 0000000000..28cb2e0f15
--- /dev/null
+++ b/recipes/guile/guile-native.inc
@@ -0,0 +1,132 @@
+SECTION = "unknown"
+LICENSE = "GPL"
+DEPENDS = "gettext-native gmp-native"
+
+inherit autotools native
+
+S="${WORKDIR}/guile-${PV}"
+
+OE_LT_RPATH_ALLOW = "any"
+LDFLAGS += " -L${STAGING_LIBDIR} "
+
+LIBGUILE_HEADERS = "\
+__scm.h \
+alist.h \
+arbiters.h \
+async.h \
+backtrace.h \
+boolean.h \
+chars.h \
+continuations.h \
+debug-malloc.h \
+debug.h \
+deprecation.h \
+dynl.h \
+dynwind.h \
+environments.h \
+eq.h \
+error.h \
+eval.h \
+evalext.h \
+extensions.h \
+feature.h \
+filesys.h \
+fluids.h \
+fports.h \
+gc.h \
+gdb_interface.h \
+gdbint.h \
+goops.h \
+gsubr.h \
+guardians.h \
+hash.h \
+hashtab.h \
+hooks.h \
+init.h \
+ioext.h \
+iselect.h \
+keywords.h \
+lang.h \
+list.h \
+load.h \
+macros.h \
+mallocs.h \
+modules.h \
+net_db.h \
+numbers.h \
+objects.h \
+objprop.h \
+options.h \
+pairs.h \
+ports.h \
+posix.h \
+print.h \
+procprop.h \
+procs.h \
+properties.h \
+ramap.h \
+random.h \
+rdelim.h \
+read.h \
+regex-posix.h \
+root.h \
+rw.h \
+scmconfig.h \
+scmsigs.h \
+script.h \
+simpos.h \
+smob.h \
+snarf.h \
+socket.h \
+sort.h \
+srcprop.h \
+stackchk.h \
+stacks.h \
+stime.h \
+strings.h \
+strorder.h \
+strports.h \
+struct.h \
+symbols.h \
+tags.h \
+threads.h \
+throw.h \
+unif.h \
+validate.h \
+values.h \
+variable.h \
+vectors.h \
+version.h \
+vports.h \
+weaks.h \
+"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/libguile
+ for i in ${LIBGUILE_HEADERS}; do
+ install -m 0644 libguile/$i ${STAGING_INCDIR}/libguile/$i
+ done
+
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 ${S}/libguile/.libs/guile ${STAGING_BINDIR_NATIVE}/
+
+ install -m 0644 libguile.h ${STAGING_INCDIR}/libguile.h
+ install -d ${STAGING_INCDIR}/guile
+ install -m 0644 libguile/gh.h ${STAGING_INCDIR}/guile/
+ install -d ${STAGING_INCDIR}/guile/srfi
+ install -d ${STAGING_INCDIR}/guile-readline
+ install -m 0644 guile-readline/readline.h ${STAGING_INCDIR}/guile-readline/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 guile-config/guile.m4 ${STAGING_DATADIR}/aclocal
+
+ install -d ${STAGING_DATADIR}/guile/1.8
+ cp -pPr ${S}/ice-9 ${STAGING_DATADIR}/guile/1.8/
+
+ oe_libinstall -C guile-readline -so -a libguilereadline-v-17 ${STAGING_LIBDIR}
+ oe_libinstall -C libguile -so -a libguile ${STAGING_LIBDIR}
+}
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-Werror':'':g
+}
+
diff --git a/recipes/guile/guile-native_1.8.5.bb b/recipes/guile/guile-native_1.8.5.bb
index 1b6a4f51bc..a1137c7ce1 100644
--- a/recipes/guile/guile-native_1.8.5.bb
+++ b/recipes/guile/guile-native_1.8.5.bb
@@ -1,137 +1,7 @@
-SECTION = "unknown"
-LICENSE = "GPL"
-DEPENDS = "gettext-native gmp-native"
+require guile-native.inc
SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
file://configure-fix.patch;patch=1 \
-"
+ "
PR = "r1"
-inherit autotools native
-
-S="${WORKDIR}/guile-${PV}"
-
-OE_LT_RPATH_ALLOW = "any"
-LDFLAGS += " -L${STAGING_LIBDIR} "
-
-LIBGUILE_HEADERS = "\
-__scm.h \
-alist.h \
-arbiters.h \
-async.h \
-backtrace.h \
-boolean.h \
-chars.h \
-continuations.h \
-debug-malloc.h \
-debug.h \
-deprecation.h \
-dynl.h \
-dynwind.h \
-environments.h \
-eq.h \
-error.h \
-eval.h \
-evalext.h \
-extensions.h \
-feature.h \
-filesys.h \
-fluids.h \
-fports.h \
-gc.h \
-gdb_interface.h \
-gdbint.h \
-goops.h \
-gsubr.h \
-guardians.h \
-hash.h \
-hashtab.h \
-hooks.h \
-init.h \
-ioext.h \
-iselect.h \
-keywords.h \
-lang.h \
-list.h \
-load.h \
-macros.h \
-mallocs.h \
-modules.h \
-net_db.h \
-numbers.h \
-objects.h \
-objprop.h \
-options.h \
-pairs.h \
-ports.h \
-posix.h \
-print.h \
-procprop.h \
-procs.h \
-properties.h \
-ramap.h \
-random.h \
-rdelim.h \
-read.h \
-regex-posix.h \
-root.h \
-rw.h \
-scmconfig.h \
-scmsigs.h \
-script.h \
-simpos.h \
-smob.h \
-snarf.h \
-socket.h \
-sort.h \
-srcprop.h \
-stackchk.h \
-stacks.h \
-stime.h \
-strings.h \
-strorder.h \
-strports.h \
-struct.h \
-symbols.h \
-tags.h \
-threads.h \
-throw.h \
-unif.h \
-validate.h \
-values.h \
-variable.h \
-vectors.h \
-version.h \
-vports.h \
-weaks.h \
-"
-
-do_stage() {
- install -d ${STAGING_INCDIR}/libguile
- for i in ${LIBGUILE_HEADERS}; do
- install -m 0644 libguile/$i ${STAGING_INCDIR}/libguile/$i
- done
-
- install -d ${STAGING_BINDIR_NATIVE}
- install -m 0755 ${S}/libguile/.libs/guile ${STAGING_BINDIR_NATIVE}/
-
- install -m 0644 libguile.h ${STAGING_INCDIR}/libguile.h
- install -d ${STAGING_INCDIR}/guile
- install -m 0644 libguile/gh.h ${STAGING_INCDIR}/guile/
- install -d ${STAGING_INCDIR}/guile/srfi
- install -d ${STAGING_INCDIR}/guile-readline
- install -m 0644 guile-readline/readline.h ${STAGING_INCDIR}/guile-readline/
- install -d ${STAGING_DATADIR}/aclocal
- install -m 0644 guile-config/guile.m4 ${STAGING_DATADIR}/aclocal
-
- install -d ${STAGING_DATADIR}/guile/1.8
- cp -pPr ${S}/ice-9 ${STAGING_DATADIR}/guile/1.8/
-
- oe_libinstall -C guile-readline -so -a libguilereadline-v-17 ${STAGING_LIBDIR}
- oe_libinstall -C libguile -so -a libguile ${STAGING_LIBDIR}
-}
-
-do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-Werror':'':g
-}
-
diff --git a/recipes/guile/guile-native_1.8.6.bb b/recipes/guile/guile-native_1.8.6.bb
new file mode 100644
index 0000000000..d511807e09
--- /dev/null
+++ b/recipes/guile/guile-native_1.8.6.bb
@@ -0,0 +1,4 @@
+require guile-native.inc
+SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
+ file://configure-fix.patch;patch=1 \
+ "
diff --git a/recipes/guile/guile.inc b/recipes/guile/guile.inc
new file mode 100644
index 0000000000..b2d6833c94
--- /dev/null
+++ b/recipes/guile/guile.inc
@@ -0,0 +1,45 @@
+DESCRIPTION = "Guile is an interpreter for the Scheme programming language, \
+packaged as a library which can be incorporated into your programs."
+HOMEPAGE = "http://www.gnu.org/software/guile/guile.html"
+SECTION = "devel/scheme"
+DEPENDS = "guile-native gmp libtool"
+LICENSE = "GPL"
+PACKAGES =+ "${PN}-el"
+FILES_${PN}-el = "${datadir}/emacs"
+DESCRIPTION_${PN}-el = "Emacs lisp files for Guile"
+
+inherit autotools
+
+acpaths = "-I ${S}/guile-config"
+
+EXTRA_OECONF = " \
+ --without-threads \
+ --without-included-ltdl \
+ "
+
+do_compile() {
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:-Werror::g $i
+ done
+
+ (cd libguile; oe_runmake CC="${BUILD_CC}" CFLAGS="${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}" guile_filter_doc_snarfage)
+ oe_runmake preinstguile="`which guile`"
+
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ -e s:-L/usr/lib::g \
+ -e s:-isystem/usr/include::g \
+ -e s:,/usr/lib:,\$\{libdir\}:g \
+ guile-1.8.pc
+}
+
+do_stage() {
+ autotools_stage_all
+ # Create guile-config returning target values instead of native values
+ install -d ${STAGING_BINDIR_CROSS}
+ echo '#!'`which guile`$' \\\n-e main -s\n!#\n(define %guile-build-info '\'\( >guile-config.cross
+ sed -n $'s:-isystem[^ ]* ::;s:-Wl,-rpath-link,[^ ]* ::;s:^[ \t]*{[ \t]*": (:;s:",[ \t]*": . ":;s:" *}, *\\\\:"):;/^ (/p' <libguile/libpath.h >>guile-config.cross
+ echo '))' >>guile-config.cross
+ cat guile-config/guile-config >>guile-config.cross
+ install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
+}
diff --git a/recipes/guile/guile_1.8.5.bb b/recipes/guile/guile_1.8.5.bb
index 86eefa04c6..0a6ddce165 100644
--- a/recipes/guile/guile_1.8.5.bb
+++ b/recipes/guile/guile_1.8.5.bb
@@ -1,50 +1,8 @@
-DESCRIPTION = "Guile is an interpreter for the Scheme programming language, \
-packaged as a library which can be incorporated into your programs."
-HOMEPAGE = "http://www.gnu.org/software/guile/guile.html"
-SECTION = "devel/scheme"
-DEPENDS = "guile-native gmp libtool"
-LICENSE = "GPL"
-PACKAGES =+ "${PN}-el"
-FILES_${PN}-el = "${datadir}/emacs"
-DESCRIPTION_${PN}-el = "Emacs lisp files for Guile"
-
-PR = "r4"
+require guile.inc
SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
- file://configure-fix.patch;patch=1 "
-
-inherit autotools
-
-acpaths = "-I ${S}/guile-config"
+ file://configure-fix.patch;patch=1 \
+ "
-EXTRA_OECONF = " \
- --without-threads \
- --without-included-ltdl \
- "
-
-do_compile() {
- for i in $(find ${S} -name "Makefile") ; do
- sed -i -e s:-Werror::g $i
- done
-
- (cd libguile; oe_runmake CC="${BUILD_CC}" CFLAGS="${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}" guile_filter_doc_snarfage)
- oe_runmake preinstguile="`which guile`"
-
- sed -i -e s:${STAGING_DIR_TARGET}::g \
- -e s:/${TARGET_SYS}::g \
- -e s:-L/usr/lib::g \
- -e s:-isystem/usr/include::g \
- -e s:,/usr/lib:,\$\{libdir\}:g \
- guile-1.8.pc
-}
+PR = "r4"
-do_stage() {
- autotools_stage_all
- # Create guile-config returning target values instead of native values
- install -d ${STAGING_BINDIR_CROSS}
- echo '#!'`which guile`$' \\\n-e main -s\n!#\n(define %guile-build-info '\'\( >guile-config.cross
- sed -n $'s:-isystem[^ ]* ::;s:-Wl,-rpath-link,[^ ]* ::;s:^[ \t]*{[ \t]*": (:;s:",[ \t]*": . ":;s:" *}, *\\\\:"):;/^ (/p' <libguile/libpath.h >>guile-config.cross
- echo '))' >>guile-config.cross
- cat guile-config/guile-config >>guile-config.cross
- install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
-}
diff --git a/recipes/guile/guile_1.8.6.bb b/recipes/guile/guile_1.8.6.bb
new file mode 100644
index 0000000000..6889f33042
--- /dev/null
+++ b/recipes/guile/guile_1.8.6.bb
@@ -0,0 +1,6 @@
+require guile.inc
+
+SRC_URI = "http://ftp.gnu.org/pub/gnu/guile/guile-${PV}.tar.gz \
+ file://configure-fix.patch;patch=1 \
+ "
+