aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-09 17:28:44 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-09 18:07:11 +0200
commit8b0ed3ad71efeb1153073e06fbf64e69a5365aef (patch)
treed660d0c130cbca24c66bb228511ce683a635c1e6
parente91abf92fe3b55ed7a1bed4d75004a5df0b164be (diff)
downloadopenembedded-8b0ed3ad71efeb1153073e06fbf64e69a5365aef.tar.gz
tftp-hpa: fix name of /etc/default/tftp(d)-hpa
-rw-r--r--recipes/tftp-hpa/files/init6
-rw-r--r--recipes/tftp-hpa/tftp-hpa_5.0.bb5
2 files changed, 6 insertions, 5 deletions
diff --git a/recipes/tftp-hpa/files/init b/recipes/tftp-hpa/files/init
index 2a24884550..5ad8c52cb8 100644
--- a/recipes/tftp-hpa/files/init
+++ b/recipes/tftp-hpa/files/init
@@ -60,12 +60,12 @@ d_reload() {
case "$1" in
start)
- echo -n "Starting $DESC: $NAME"
+ echo "Starting $DESC: $NAME"
d_start
echo "."
;;
stop)
- echo -n "Stopping $DESC: $NAME"
+ echo "Stopping $DESC: $NAME"
d_stop
echo "."
;;
@@ -88,7 +88,7 @@ case "$1" in
# option to the "reload" entry above. If not, "force-reload" is
# just the same as "restart".
#
- echo -n "Restarting $DESC: $NAME"
+ echo "Restarting $DESC: $NAME"
d_stop
sleep 1
d_start
diff --git a/recipes/tftp-hpa/tftp-hpa_5.0.bb b/recipes/tftp-hpa/tftp-hpa_5.0.bb
index 4137bf0bab..9533e01670 100644
--- a/recipes/tftp-hpa/tftp-hpa_5.0.bb
+++ b/recipes/tftp-hpa/tftp-hpa_5.0.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "HPA's tftp server"
DEPENDS = "tcp-wrappers readline"
SECTION = "network"
LICENSE = "BSD"
+PR = "r1"
SRC_URI = "${KERNELORG_MIRROR}/pub/software/network/tftp/tftp-hpa-${PV}.tar.bz2 \
file://default \
@@ -22,7 +23,7 @@ do_install() {
install -d ${D}${sysconfdir}/default
install -d ${D}${sysconfdir}/init.d
- install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/tftp-hpa
+ install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/tftpd-hpa
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/tftp-hpa
}
@@ -34,7 +35,7 @@ PACKAGES += "tftpd-hpa"
FILES_${PN} = "${bindir}"
FILES_tftpd-hpa = "${sbindir} ${sysconfdir}"
-CONFFILES_tftpd-hpa = "${sysconfdir}/default/${PN}"
+CONFFILES_tftpd-hpa = "${sysconfdir}/default/tftpd-hpa"
ALTERNATIVE_NAME = "tftp"
ALTERNATIVE_LINK = "${bindir}/tftp"