aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Lapin <slapin@ossfans.org>2009-05-14 17:09:00 +0400
committerSergey Lapin <slapin@ossfans.org>2009-05-14 18:33:28 +0400
commit3fd24860b796db3baf0af24eed91f86220fc9bff (patch)
tree2766df9d97df01b66c68af803472dd2c45a725a0
parent5abc720bf33bf0311a5c5b6fae294c99a2ca7623 (diff)
downloadopenembedded-3fd24860b796db3baf0af24eed91f86220fc9bff.tar.gz
u-boot_git: updated for latest version for afeb9260
-rw-r--r--recipes/u-boot/u-boot-git/afeb9260/AFEB9260-network-fix.patch40
-rw-r--r--recipes/u-boot/u-boot_git.bb7
2 files changed, 45 insertions, 2 deletions
diff --git a/recipes/u-boot/u-boot-git/afeb9260/AFEB9260-network-fix.patch b/recipes/u-boot/u-boot-git/afeb9260/AFEB9260-network-fix.patch
new file mode 100644
index 0000000000..ffd2f02a3c
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/afeb9260/AFEB9260-network-fix.patch
@@ -0,0 +1,40 @@
+From d0a09ac9587fbfc19970456e17f0ecc957a5549b Mon Sep 17 00:00:00 2001
+From: Sergey Lapin <slapin@ossfans.org>
+Date: Tue, 12 May 2009 01:12:50 +0400
+Subject: [PATCH] AFEB9260 network fix
+
+Signed-off-by: Sergey Lapin <slapin@ossfans.org>
+---
+ board/afeb9260/afeb9260.c | 2 +-
+ cpu/arm926ejs/at91/at91sam9260_macb.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/board/afeb9260/afeb9260.c b/board/afeb9260/afeb9260.c
+index 024db2b..a247663 100644
+--- a/board/afeb9260/afeb9260.c
++++ b/board/afeb9260/afeb9260.c
+@@ -177,7 +177,7 @@ int board_eth_init(bd_t *bis)
+ {
+ int rc = 0;
+ #ifdef CONFIG_MACB
+- rc = macb_eth_initialize(0, (void *)AT91SAM9260_BASE_EMAC, 0x00);
++ rc = macb_eth_initialize(0, (void *)AT91SAM9260_BASE_EMAC, 0x01);
+ #endif
+ return rc;
+ }
+diff --git a/cpu/arm926ejs/at91/at91sam9260_macb.c b/cpu/arm926ejs/at91/at91sam9260_macb.c
+index ab60fb7..ea5e767 100644
+--- a/cpu/arm926ejs/at91/at91sam9260_macb.c
++++ b/cpu/arm926ejs/at91/at91sam9260_macb.c
+@@ -47,7 +47,7 @@ void at91_macb_hw_init(void)
+ at91_set_B_periph(AT91_PIN_PA25, 0); /* ERX2 */
+ at91_set_B_periph(AT91_PIN_PA26, 0); /* ERX3 */
+ at91_set_B_periph(AT91_PIN_PA27, 0); /* ERXCK */
+-#if defined(CONFIG_AT91SAM9260EK)
++#if defined(CONFIG_AT91SAM9260EK) || defined(CONFIG_AFEB9260)
+ /*
+ * use PA10, PA11 for ETX2, ETX3.
+ * PA23 and PA24 are for TWI EEPROM
+--
+1.5.6.5
+
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 3d99067813..8e0eb2e6e9 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r23"
+PR ="r24"
FILESPATHPKG =. "u-boot-git:"
@@ -9,7 +9,10 @@ SRCREV_davinci-dvevm = "4b50cd12a3b3c644153c4cf393f4a4c12289e5aa"
SRCREV_akita = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
SRCREV_spitz = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
SRCREV_c7x0 = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
-SRCREV_afeb9260 = "2077e348c2a84901022ad95311b47b70361e6daa"
+SRCREV_afeb9260 = "6b8edfde22acc574b5532e9f086e6a7287a9bc78"
+SRCREV_afeb9260-180 = "6b8edfde22acc574b5532e9f086e6a7287a9bc78"
+SRC_URI_append_afeb9260 = " file://AFEB9260-network-fix.patch;patch=1"
+SRC_URI_append_afeb9260-180 = " file://AFEB9260-network-fix.patch;patch=1"
SRC_URI_beagleboard = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev-usb;protocol=git \
file://fw-env.patch;patch=1 \