aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Lapin <slapin@ossfans.org>2009-05-17 02:47:27 +0400
committerSergey Lapin <slapin@ossfans.org>2009-05-17 02:47:27 +0400
commit0f1b411ed82919e0d7adab458f48be53ef14fd6b (patch)
tree6b2c120a46f2a91b5d381116d800ffcd55ff5d65
parente49fd68b702de6546cc18b61ea20ff8c34599834 (diff)
parent793e489438f1eb09720d69804b211eca5004e7fe (diff)
downloadopenembedded-0f1b411ed82919e0d7adab458f48be53ef14fd6b.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
-rw-r--r--conf/checksums.ini4
-rw-r--r--conf/distro/include/sane-srcrevs.inc2
-rw-r--r--conf/machine/include/kirkwood.inc2
-rw-r--r--recipes/hdparm/hdparm_9.15.bb21
-rw-r--r--recipes/kexec/files/kexec2-klibc.patch104
-rw-r--r--recipes/linux/linux-kirkwood/defconfig52
-rw-r--r--recipes/linux/linux-kirkwood/mvsdio.patch46
-rw-r--r--recipes/linux/linux-kirkwood_2.6.29.2.bb1
-rw-r--r--recipes/mpeg-encode/files/fixup.patch14
-rw-r--r--recipes/mpeg-encode/mpeg-encode_1.5b.bb2
-rw-r--r--recipes/mysql/mysql_4.1.22.bb7
-rw-r--r--recipes/netpbm/netpbm-10.28/libgnuhash.patch12
-rw-r--r--recipes/netpbm/netpbm_10.28.bb3
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac23
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb2
15 files changed, 243 insertions, 52 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 2d66999d3a..aa5b5beaec 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -10182,6 +10182,10 @@ sha256=cae6ed86296d01be98ee3be0c224c4323eee508941a7f162a0366d56655afe06
md5=62749c6cdf28ce31aae335092fa107df
sha256=cae6ed86296d01be98ee3be0c224c4323eee508941a7f162a0366d56655afe06
+[http://downloads.sourceforge.net/hdparm/hdparm-9.15.tar.gz]
+md5=0524dd10ad986285ff4eeb3507f7471c
+sha256=689a413119c4d670ed95b9ac24511655c4805db678ad93866ab1036a0ba4d6bf
+
[http://handhelds.org/~zecke/oe_packages/hexatrolic-103beta3-zecke1.tar.bz2]
md5=1d9420e8b5a6d5fa491c458ffafd4adb
sha256=b60a5358e56e676529e7d3d655d5107a76b9a2434e38952711fea794f65721ce
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 60d53abc71..1f97381738 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -249,7 +249,7 @@ SRCREV_pn-usbpath-native ?= "3172"
SRCREV-pn-vala-dbus-binding-tool-native ?= "55a6bc5dd032731d89c238d274b2898ef02d12f8"
SRCREV_pn-vala-terminal ?= "94117f453ce884e9c30b611fae6fc19f85f98f2b"
SRCREV_pn-vala-native ?= "6cf030120cd7f6a76a5d766d7420aea847e02cfd"
-SRCREV_pn-webkit-gtk ?= "43434"
+SRCREV_pn-webkit-gtk ?= "43635"
SRCREV_pn-wlan-ng-modules ?= "1859"
SRCREV_pn-wlan-ng-utils ?= "1859"
SRCREV_pn-wmiconfig ?= "4522"
diff --git a/conf/machine/include/kirkwood.inc b/conf/machine/include/kirkwood.inc
index 8f995899c9..3f0b8003f5 100644
--- a/conf/machine/include/kirkwood.inc
+++ b/conf/machine/include/kirkwood.inc
@@ -11,7 +11,7 @@ USE_DEVFS = "0"
PREFERRED_PROVIDER_virtual/bootloader = ""
PREFERRED_PROVIDER_virtual/kernel = "linux-kirkwood"
-MACHINE_KERNEL_PR = "r2"
+MACHINE_KERNEL_PR = "r4"
IMAGE_FSTYPES += "tar.gz ubi"
SERIAL_CONSOLE = "ttyS0 115200"
diff --git a/recipes/hdparm/hdparm_9.15.bb b/recipes/hdparm/hdparm_9.15.bb
new file mode 100644
index 0000000000..d351e8dc85
--- /dev/null
+++ b/recipes/hdparm/hdparm_9.15.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "hdparm is a Linux shell utility for viewing \
+and manipulating various IDE drive and driver parameters."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz "
+
+do_install () {
+ install -d ${D}/${base_sbindir} ${D}/${mandir}/man8
+ oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
+ mv ${D}${base_sbindir}/hdparm ${D}${base_sbindir}/hdparm.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_sbindir}/hdparm hdparm hdparm.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove hdparm hdparm.${PN}
+}
diff --git a/recipes/kexec/files/kexec2-klibc.patch b/recipes/kexec/files/kexec2-klibc.patch
index c52262bb5f..b80848d291 100644
--- a/recipes/kexec/files/kexec2-klibc.patch
+++ b/recipes/kexec/files/kexec2-klibc.patch
@@ -57,14 +57,39 @@ Index: kexec-tools-2.0.0/purgatory/Makefile
===================================================================
--- kexec-tools-2.0.0.orig/purgatory/Makefile 2009-04-24 14:15:34.037827479 +0100
+++ kexec-tools-2.0.0/purgatory/Makefile 2009-04-24 14:15:47.022825503 +0100
-@@ -47,6 +47,7 @@
- $(PURGATORY): CC=$(TARGET_CC)
- $(PURGATORY): CFLAGS+=$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
- -Os -fno-builtin -ffreestanding \
-+ -nostdinc \
- -fno-zero-initialized-in-bss
+@@ -55,9 +54,7 @@
+ -I$(srcdir)/purgatory/arch/$(ARCH)/include \
+ -I$(srcdir)/util_lib/include \
+ -I$(shell $(CC) -print-file-name=include)
+-$(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\
+- --no-undefined -nostartfiles -nostdlib -nodefaultlibs \
+- -e purgatory_start -r
++$(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)
- $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
+ $(PURGATORY): $(PURGATORY_OBJS)
+ $(MKDIR) -p $(@D)
+Index: kexec-tools-2.0.0/purgatory/purgatory.c
+===================================================================
+--- kexec-tools-2.0.0.orig/purgatory/purgatory.old 2009-05-16 13:28:19.000000000 +0200
++++ kexec-tools-2.0.0/purgatory/purgatory.c 2009-05-16 14:15:21.000000000 +0200
+@@ -1,4 +1,4 @@
+-
++//#include <stdarg.h>
+ #include <limits.h>
+ #include <stdint.h>
+ #include <purgatory.h>
+@@ -3,7 +3,7 @@
+ #include <stdint.h>
+ #include <purgatory.h>
+ #include <sha256.h>
+-#include <string.h>
++/* #include <string.h> */
+ #include "../kexec/kexec-sha256.h"
+
+ struct sha256_region sha256_regions[SHA256_REGIONS] = {};
+ }
+ sha256_finish(&ctx, digest);
+ if (memcmp(digest, sha256_digest, sizeof(digest)) != 0) {
Index: kexec-tools-2.0.0/kexec/kexec-elf-rel.c
===================================================================
--- kexec-tools-2.0.0.orig/kexec/kexec-elf-rel.c 2009-04-24 14:15:34.025828340 +0100
@@ -165,3 +190,68 @@ Index: kexec-tools-2.0.0/kexec/crashdump-xen.c
#include <errno.h>
#include <limits.h>
#include <sys/types.h>
+Index: kexec-tools-2.0.0/kexec/crashdump-elf.c
+===================================================================
+--- kexec-tools-2.0.0.orig/kexec/crashdump-elf.c.old 2009-05-16 13:28:19.000000000 +0200
++++ kexec-tools-2.0.0/kexec/crashdump-elf.c 2009-05-16 11:12:15.000000000 +0200
+@@ -43,8 +43,8 @@
+ if (xen_present())
+ nr_cpus = xen_get_nr_phys_cpus();
+ else
+- nr_cpus = sysconf(_SC_NPROCESSORS_CONF);
+-
++/* nr_cpus = sysconf(_SC_NPROCESSORS_CONF); */
++ nr_cpus = 1;
+ if (nr_cpus < 0) {
+ return -1;
+ }
+Index: kexec-tools-2.0.0/kexec/kexec-elf-boot.c
+===================================================================
+--- kexec-tools-2.0.0.orig/kexec/kexec-elf-boot.c.old 2009-05-16 13:28:19.000000000 +0200
++++ kexec-tools-2.0.0/kexec/kexec-elf-boot.c 2009-05-16 11:13:28.000000000 +0200
+@@ -22,7 +22,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <errno.h>
+-#include <elf.h>
++#include "../include/elf.h"
+ #include <boot/elf_boot.h>
+ #include <ip_checksum.h>
+ #include <x86/x86-linux.h>
+Index: kexec-tools-2.0.0/kdump/kdump.c
+===================================================================
+--- kexec-tools-2.0.0.orig/kdump/kdump.c.old 2009-05-16 13:28:19.000000000 +0200
++++ kexec-tools-2.0.0/kdump/kdump.c 2009-05-16 11:13:08.000000000 +0200
+@@ -8,7 +8,7 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <endian.h>
+-#include <elf.h>
++#include "../include/elf.h"
+
+ #if !defined(__BYTE_ORDER) || !defined(__LITTLE_ENDIAN) || !defined(__BIG_ENDIAN)
+ #error Endian defines missing
+Index: kexec-tools-2.0.0/kexec/kexec.h
+===================================================================
+--- kexec-tools-2.0.0.orig/kexec/kexec.h.old 2008-05-16 13:28:19.000000000 +0200
++++ kexec-tools-2.0.0/kexec/kexec.h 2009-05-16 17:32:15.000000000 +0200
+@@ -197,7 +197,7 @@
+ extern char *slurp_file(const char *filename, off_t *r_size);
+ extern char *slurp_file_len(const char *filename, off_t size);
+ extern char *slurp_decompress_file(const char *filename, off_t *r_size);
+-extern unsigned long virt_to_phys(unsigned long addr);
++/* extern unsigned long virt_to_phys(unsigned long addr); */
+ extern void add_segment(struct kexec_info *info,
+ const void *buf, size_t bufsz, unsigned long base, size_t memsz);
+ extern void add_segment_phys_virt(struct kexec_info *info,
+Index: kexec-tools-2.0.0/purgatory/string.c
+===================================================================
+--- kexec-tools-2.0.0.orig/purgatory/string.c.old 2008-05-16 13:28:19.000000000 +0200
++++ kexec-tools-2.0.0/purgatory/string.c 2009-05-16 17:49:04.000000000 +0200
+@@ -1,5 +1,5 @@
+ #include <stddef.h>
+-#include <string.h>
++/* #include <string.h> */
+
+ size_t strnlen(const char *s, size_t max)
+ {
diff --git a/recipes/linux/linux-kirkwood/defconfig b/recipes/linux/linux-kirkwood/defconfig
index 078f7efac3..23bf5d9820 100644
--- a/recipes/linux/linux-kirkwood/defconfig
+++ b/recipes/linux/linux-kirkwood/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.29.1
-# Mon Apr 27 14:13:52 2009
+# Linux kernel version: 2.6.29.2
+# Sat May 16 20:08:52 2009
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1237,30 +1237,30 @@ CONFIG_V4L_USB_DRIVERS=y
CONFIG_USB_VIDEO_CLASS=m
CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
CONFIG_USB_GSPCA=m
-# CONFIG_USB_M5602 is not set
-# CONFIG_USB_STV06XX is not set
-# CONFIG_USB_GSPCA_CONEX is not set
-# CONFIG_USB_GSPCA_ETOMS is not set
-# CONFIG_USB_GSPCA_FINEPIX is not set
-# CONFIG_USB_GSPCA_MARS is not set
-# CONFIG_USB_GSPCA_OV519 is not set
-# CONFIG_USB_GSPCA_OV534 is not set
-# CONFIG_USB_GSPCA_PAC207 is not set
-# CONFIG_USB_GSPCA_PAC7311 is not set
-# CONFIG_USB_GSPCA_SONIXB is not set
-# CONFIG_USB_GSPCA_SONIXJ is not set
-# CONFIG_USB_GSPCA_SPCA500 is not set
-# CONFIG_USB_GSPCA_SPCA501 is not set
-# CONFIG_USB_GSPCA_SPCA505 is not set
-# CONFIG_USB_GSPCA_SPCA506 is not set
-# CONFIG_USB_GSPCA_SPCA508 is not set
-# CONFIG_USB_GSPCA_SPCA561 is not set
-# CONFIG_USB_GSPCA_STK014 is not set
-# CONFIG_USB_GSPCA_SUNPLUS is not set
-# CONFIG_USB_GSPCA_T613 is not set
-# CONFIG_USB_GSPCA_TV8532 is not set
-# CONFIG_USB_GSPCA_VC032X is not set
-# CONFIG_USB_GSPCA_ZC3XX is not set
+CONFIG_USB_M5602=m
+CONFIG_USB_STV06XX=m
+CONFIG_USB_GSPCA_CONEX=m
+CONFIG_USB_GSPCA_ETOMS=m
+CONFIG_USB_GSPCA_FINEPIX=m
+CONFIG_USB_GSPCA_MARS=m
+CONFIG_USB_GSPCA_OV519=m
+CONFIG_USB_GSPCA_OV534=m
+CONFIG_USB_GSPCA_PAC207=m
+CONFIG_USB_GSPCA_PAC7311=m
+CONFIG_USB_GSPCA_SONIXB=m
+CONFIG_USB_GSPCA_SONIXJ=m
+CONFIG_USB_GSPCA_SPCA500=m
+CONFIG_USB_GSPCA_SPCA501=m
+CONFIG_USB_GSPCA_SPCA505=m
+CONFIG_USB_GSPCA_SPCA506=m
+CONFIG_USB_GSPCA_SPCA508=m
+CONFIG_USB_GSPCA_SPCA561=m
+CONFIG_USB_GSPCA_STK014=m
+CONFIG_USB_GSPCA_SUNPLUS=m
+CONFIG_USB_GSPCA_T613=m
+CONFIG_USB_GSPCA_TV8532=m
+CONFIG_USB_GSPCA_VC032X=m
+CONFIG_USB_GSPCA_ZC3XX=m
CONFIG_VIDEO_PVRUSB2=m
CONFIG_VIDEO_PVRUSB2_SYSFS=y
# CONFIG_VIDEO_PVRUSB2_DEBUGIFC is not set
diff --git a/recipes/linux/linux-kirkwood/mvsdio.patch b/recipes/linux/linux-kirkwood/mvsdio.patch
new file mode 100644
index 0000000000..e4ba675428
--- /dev/null
+++ b/recipes/linux/linux-kirkwood/mvsdio.patch
@@ -0,0 +1,46 @@
+Patch obtained from http://www.computingplugs.com/index.php/Fixing_SDHC_access_in_the_Orion/Mainline_kernel
+
+--- a/drivers/mmc/host/mvsdio.c.orig 2009-04-14 20:51:48.000000000 +0000
++++ b/drivers/mmc/host/mvsdio.c 2009-04-19 15:58:42.261724324 +0000
+@@ -21,6 +21,7 @@
+ #include <linux/irq.h>
+ #include <linux/gpio.h>
+ #include <linux/mmc/host.h>
++#include <linux/mmc/sd.h>
+
+ #include <asm/sizes.h>
+ #include <asm/unaligned.h>
+@@ -123,6 +124,7 @@
+
+ dev_dbg(host->dev, "cmd %d (hw state 0x%04x)\n",
+ cmd->opcode, mvsd_read(MVSD_HW_STATE));
++ if (cmd->opcode == SD_SWITCH) mdelay(1); /* Voodoo */
+
+ cmdreg = MVSD_CMD_INDEX(cmd->opcode);
+
+@@ -620,9 +622,11 @@
+ if (ios->bus_width == MMC_BUS_WIDTH_4)
+ ctrl_reg |= MVSD_HOST_CTRL_DATA_WIDTH_4_BITS;
+
++#if 0
+ if (ios->timing == MMC_TIMING_MMC_HS ||
+ ios->timing == MMC_TIMING_SD_HS)
+ ctrl_reg |= MVSD_HOST_CTRL_HI_SPEED_EN;
++#endif
+
+ host->ctrl = ctrl_reg;
+ mvsd_write(MVSD_HOST_CTRL, ctrl_reg);
+--- kernel/drivers/mmc/core/core.c.orig 2009-04-14 20:51:48.000000000 +0000
++++ kernel/drivers/mmc/core/core.c 2009-04-19 17:36:35.985746917 +0000
+@@ -286,9 +286,9 @@
+ * The limit is really 250 ms, but that is
+ * insufficient for some crappy cards.
+ */
+- limit_us = 300000;
++ limit_us = 500000;
+ else
+- limit_us = 100000;
++ limit_us = 200000;
+
+ /*
+ * SDHC cards always use these fixed values.
diff --git a/recipes/linux/linux-kirkwood_2.6.29.2.bb b/recipes/linux/linux-kirkwood_2.6.29.2.bb
index 0e349362db..4dceb7601b 100644
--- a/recipes/linux/linux-kirkwood_2.6.29.2.bb
+++ b/recipes/linux/linux-kirkwood_2.6.29.2.bb
@@ -13,6 +13,7 @@ PR_append = "+gitr${SRCREV}"
SRCREV = "10a12868405319fbf114af2bde9789aa64c34144"
SRC_URI = "git://git.marvell.com/orion.git;protocol=git;branch=stable-2.6.29 \
file://fw.patch;patch=1 \
+ file://mvsdio.patch;patch=1 \
file://defconfig \
"
diff --git a/recipes/mpeg-encode/files/fixup.patch b/recipes/mpeg-encode/files/fixup.patch
index eda092058e..a40c1bf120 100644
--- a/recipes/mpeg-encode/files/fixup.patch
+++ b/recipes/mpeg-encode/files/fixup.patch
@@ -1,6 +1,6 @@
diff -urN mpeg_encode.old/headers/libpnmrw.h mpeg_encode/headers/libpnmrw.h
--- mpeg_encode.old/headers/libpnmrw.h 1995-08-09 16:17:41.000000000 +0100
-+++ mpeg_encode/headers/libpnmrw.h 2009-03-24 23:24:25.000000000 +0000
++++ mpeg_encode/headers/libpnmrw.h 2009-05-16 17:38:24.000000000 +0100
@@ -13,18 +13,7 @@
#ifndef _PNMRW_H_
#define _PNMRW_H_
@@ -22,7 +22,7 @@ diff -urN mpeg_encode.old/headers/libpnmrw.h mpeg_encode/headers/libpnmrw.h
diff -urN mpeg_encode.old/jpeg/Makefile mpeg_encode/jpeg/Makefile
--- mpeg_encode.old/jpeg/Makefile 1995-08-05 00:27:00.000000000 +0100
-+++ mpeg_encode/jpeg/Makefile 2009-03-24 23:24:25.000000000 +0000
++++ mpeg_encode/jpeg/Makefile 2009-05-16 17:38:24.000000000 +0100
@@ -20,9 +20,6 @@
manprefix =
manext = 1
@@ -56,7 +56,7 @@ diff -urN mpeg_encode.old/jpeg/Makefile mpeg_encode/jpeg/Makefile
cjpeg: $(COBJECTS) libjpeg.a
diff -urN mpeg_encode.old/libpnmrw.c mpeg_encode/libpnmrw.c
--- mpeg_encode.old/libpnmrw.c 1995-08-16 23:24:26.000000000 +0100
-+++ mpeg_encode/libpnmrw.c 2009-03-24 23:24:25.000000000 +0000
++++ mpeg_encode/libpnmrw.c 2009-05-16 17:38:24.000000000 +0100
@@ -28,6 +28,7 @@
#endif
@@ -76,12 +76,14 @@ diff -urN mpeg_encode.old/libpnmrw.c mpeg_encode/libpnmrw.c
e = sys_errlist[errno];
diff -urN mpeg_encode.old/Makefile mpeg_encode/Makefile
--- mpeg_encode.old/Makefile 1995-08-16 23:16:56.000000000 +0100
-+++ mpeg_encode/Makefile 2009-03-24 23:24:47.000000000 +0000
-@@ -204,7 +204,7 @@
++++ mpeg_encode/Makefile 2009-05-16 18:56:22.000000000 +0100
+@@ -203,8 +203,8 @@
+ ############
mpeg_encode: $(MP_ALL_OBJS) $(JPEG_LIB)
- $(PURIFY) $(CC) $(CFLAGS) -o $@ $(MP_ALL_OBJS) $(LIBDIRS) $(LIBS)
+- $(PURIFY) $(CC) $(CFLAGS) -o $@ $(MP_ALL_OBJS) $(LIBDIRS) $(LIBS)
- strip mpeg_encode
++ $(PURIFY) $(CC) $(CFLAGS) -o $@ $(MP_ALL_OBJS) $(LIBDIRS) $(LIBS) $(LDFLAGS)
+ $(STRIP) mpeg_encode
profile: $(MP_ALL_OBJS)
diff --git a/recipes/mpeg-encode/mpeg-encode_1.5b.bb b/recipes/mpeg-encode/mpeg-encode_1.5b.bb
index d32322a504..0f851b1f36 100644
--- a/recipes/mpeg-encode/mpeg-encode_1.5b.bb
+++ b/recipes/mpeg-encode/mpeg-encode_1.5b.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "The Berkeley MPEG Encoder."
HOMEPAGE = "http://bmrc.berkeley.edu/frame/research/mpeg/mpeg_encode.html"
SECTION = "multimedia"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://bmrc.berkeley.edu/ftp/pub/multimedia/mpeg/encode/mpeg_encode-${PV}-src.tar.gz \
file://fixup.patch;patch=1"
diff --git a/recipes/mysql/mysql_4.1.22.bb b/recipes/mysql/mysql_4.1.22.bb
index 5d5900c6d2..7f32b4ddee 100644
--- a/recipes/mysql/mysql_4.1.22.bb
+++ b/recipes/mysql/mysql_4.1.22.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.mysql.com/"
SECTION = "libs"
LICENSE = "GPL"
DEPENDS = "ncurses"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://downloads.mysql.com/archives/mysql-4.1/mysql-${PV}.tar.gz \
file://autofoo.patch;patch=1 \
@@ -40,6 +40,11 @@ do_stage() {
oe_libinstall -a -C libmysqld libmysqld ${STAGING_LIBDIR}
}
+do_stage_append() {
+ sed -i -es,^pkgincludedir=\'/usr/include/mysql\',pkgincludedir=\'\', ${STAGING_BINDIR_CROSS}/mysql_config
+ sed -i -es,^pkglibdir=\'/usr/lib/mysql\',pkglibdir=\'\', ${STAGING_BINDIR_CROSS}/mysql_config
+}
+
do_install() {
oe_runmake 'DESTDIR=${D}' install
mv -f ${D}${libdir}/mysql/* ${D}${libdir}
diff --git a/recipes/netpbm/netpbm-10.28/libgnuhash.patch b/recipes/netpbm/netpbm-10.28/libgnuhash.patch
new file mode 100644
index 0000000000..3df92ca668
--- /dev/null
+++ b/recipes/netpbm/netpbm-10.28/libgnuhash.patch
@@ -0,0 +1,12 @@
+diff -urN netpbm-10.28.old/lib/Makefile netpbm-10.28/lib/Makefile
+--- netpbm-10.28.old/lib/Makefile 2005-02-05 18:47:27.000000000 +0000
++++ netpbm-10.28/lib/Makefile 2009-05-12 13:33:10.000000000 +0100
+@@ -111,7 +111,7 @@
+ rm -f $@
+ $(SYMLINK) $< $@
+ libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN): $(LIBOBJECTS) $(LIBOBJECTS_X)
+- $(LD) $(LDSHLIB) -o $@ $(LIBOBJECTS) $(LIBOBJECTS_X) \
++ $(LD) $(LDFLAGS) $(LDSHLIB) -o $@ $(LIBOBJECTS) $(LIBOBJECTS_X) \
+ $(SHLIB_CLIB) $(LADD)
+ endif
+
diff --git a/recipes/netpbm/netpbm_10.28.bb b/recipes/netpbm/netpbm_10.28.bb
index 8469074fbd..2672e4a904 100644
--- a/recipes/netpbm/netpbm_10.28.bb
+++ b/recipes/netpbm/netpbm_10.28.bb
@@ -25,10 +25,11 @@ RDEPENDS = "perl\
RDEPENDS += "perl-module-exporter-heavy"
RDEPENDS += "perl-module-file-spec-unix"
-PR = "r6"
+PR = "r7"
SRC_URI = "${SOURCEFORGE_MIRROR}/netpbm/netpbm-${PV}.tgz \
file://ppmtojpeg.patch;patch=42 \
+ file://libgnuhash.patch;patch=1 \
file://Makefile.config \
file://oeendiangen"
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index be6d8521dc..ffd36afd0d 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -2,7 +2,7 @@ AC_PREREQ(2.59)
m4_define([webkit_major_version], [1])
m4_define([webkit_minor_version], [1])
-m4_define([webkit_micro_version], [6])
+m4_define([webkit_micro_version], [7])
AC_INIT([WebKit],[webkit_major_version.webkit_minor_version.webkit_micro_version],[http://bugs.webkit.org/])
@@ -24,7 +24,7 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
dnl # Libtool library version, not to confuse with API version
dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
-LIBWEBKITGTK_VERSION=6:0:4
+LIBWEBKITGTK_VERSION=7:0:5
AC_SUBST([LIBWEBKITGTK_VERSION])
AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
@@ -216,6 +216,10 @@ PKG_CHECK_MODULES(PANGO,
AC_SUBST(PANGO_CFLAGS)
AC_SUBST(PANGO_LIBS)
+PKG_CHECK_MODULES(ENCHANT, enchant >= $ENCHANT_REQUIRED_VERSION)
+AC_SUBST(ENCHANT_CFLAGS)
+AC_SUBST(ENCHANT_LIBS)
+
# check for target-specific dependencies
if test "$with_target" = "directfb"; then
PKG_CHECK_MODULES(CAIRO, cairo-directfb >= $CAIRO_REQUIRED_VERSION)
@@ -224,7 +228,6 @@ if test "$with_target" = "directfb"; then
else
PKG_CHECK_MODULES(CAIRO, cairo >= $CAIRO_REQUIRED_VERSION)
PKG_CHECK_MODULES(GTK, gtk+-2.0 >= $GTK_REQUIRED_VERSION)
- PKG_CHECK_MODULES(ENCHANT, enchant >= $ENCHANT_REQUIRED_VERSION)
if test "$with_target" = "x11" && test "$os_win32" = "no"; then
# check for XT
@@ -251,8 +254,6 @@ AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(CAIRO_LIBS)
-AC_SUBST(ENCHANT_CFLAGS)
-AC_SUBST(ENCHANT_LIBS)
# check whether to build with debugging enabled
AC_MSG_CHECKING([whether to do a debug build])
@@ -495,13 +496,21 @@ AC_ARG_ENABLE([jit],
[],[enable_jit="yes"])
if test "$enable_jit" = "yes"; then
case "$target_cpu" in
- i*86)
+ i*86|x86_64)
AC_DEFINE([ENABLE_JIT], [1], [Define to enable JIT])
AC_DEFINE([ENABLE_WREC], [1], [Define to enable WREC])
AC_DEFINE([ENABLE_JIT_OPTIMIZE_CALL], [1], [Define to enable optimizing calls])
AC_DEFINE([ENABLE_JIT_OPTIMIZE_PROPERTY_ACCESS], [1], [Define to enable optimized property access])
AC_DEFINE([ENABLE_JIT_OPTIMIZE_ARITHMETIC], [1], [Define to enable optimized arithmetic])
- AC_DEFINE([WTF_USE_JIT_STUB_ARGUMENT_VA_LIST], [1], [Use stub va_list])
+ case "$target_cpu" in
+ i*86)
+ AC_DEFINE([WTF_USE_JIT_STUB_ARGUMENT_VA_LIST], [1], [Use stub va_list])
+ ;;
+ x86_64)
+ AC_DEFINE([WTF_USE_JIT_STUB_ARGUMENT_REGISTER], [1], [Use stub register])
+ AC_DEFINE([WTF_USE_ALTERNATE_JSIMMEDIATE], [1], [Use alternate JSImmediate])
+ ;;
+ esac
;;
*)
enable_jit="no (CPU '$target_cpu' not supported)"
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index 3c7ec06185..ec76d23ceb 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -3,7 +3,7 @@ DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu lib
SRCREV_FORMAT = "webcore-rwebkit"
-PV = "1.1.6+svnr${SRCREV}"
+PV = "1.1.7+svnr${SRCREV}"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \