aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@buglabs.net>2009-05-16 11:15:35 +0200
committerMarcin Juszkiewicz <marcin@buglabs.net>2009-05-16 11:18:03 +0200
commit039cc994ff1401acc643b10adf2cba4be75f3d86 (patch)
tree1a8437a9ec51f302f65ea819e0ff47114d8f6951
parent3dd84182dd989ba809bd6cb22d9385d93803b9cc (diff)
downloadopenembedded-039cc994ff1401acc643b10adf2cba4be75f3d86.tar.gz
fbprogress: BUG only tool to show boot progress on built-in monochrome LCD
-rwxr-xr-xrecipes/fbprogress/fbprogress/fbprogress-init34
-rw-r--r--recipes/fbprogress/fbprogress_1.1.bb32
2 files changed, 66 insertions, 0 deletions
diff --git a/recipes/fbprogress/fbprogress/fbprogress-init b/recipes/fbprogress/fbprogress/fbprogress-init
new file mode 100755
index 0000000000..c1dd3787b1
--- /dev/null
+++ b/recipes/fbprogress/fbprogress/fbprogress-init
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+. /etc/init.d/functions
+
+case "$1" in
+ start)
+ # We don't want this script to block the rest of the boot process
+ if [ "$2" != "background" ]; then
+ $0 $1 background &
+ else
+ . /etc/profile
+
+ echo "Starting FBProgress"
+ fbprogress.sh &
+ fi
+ ;;
+
+ stop)
+ echo "Stopping FBProgress"
+ killproc fbprogress.sh
+ ;;
+
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+
+ *)
+ echo "usage: $0 { start | stop | restart }"
+ ;;
+esac
+
+exit 0
diff --git a/recipes/fbprogress/fbprogress_1.1.bb b/recipes/fbprogress/fbprogress_1.1.bb
new file mode 100644
index 0000000000..8d603b8a3e
--- /dev/null
+++ b/recipes/fbprogress/fbprogress_1.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Bug framebuffer progress indicator"
+AUTHOR = "Angel Roman"
+HOMEPAGE = "http://www.buglabs.net/"
+LICENSE = "GPL"
+DEPENDS = "freetype zlib virtual/kernel"
+SRCREV = "9118"
+PR = "r1"
+
+SRC_URI = "svn://svn.buglabs.net/bug/trunk;module=com.buglabs.bug.native.fbprogress;proto=svn \
+ file://fbprogress-init"
+
+S = "${WORKDIR}/com.buglabs.bug.native.fbprogress"
+
+inherit update-rc.d
+
+EXTRA_OEMAKE = "BUG_LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/fbprogress
+ install -m 0644 ${S}/images/* ${D}/${sysconfdir}/fbprogress/
+ install -d ${D}${layout_bindir}
+ install -m 0755 fbprogress ${D}${layout_bindir}
+ install -m 0755 fbprogress.sh ${D}${layout_bindir}
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/fbprogress-init ${D}/${sysconfdir}/init.d/fbprogress
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "bug"
+
+INITSCRIPT_NAME = "fbprogress"
+INITSCRIPT_PARAMS = "start 01 S . stop 15 0 1 2 3 4 5 6 ."