aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Smith <msmith@cbnco.com>2009-10-22 17:19:34 -0400
committerMichael Smith <msmith@cbnco.com>2009-10-25 16:27:56 -0400
commite698a27699e7b64c8f654bce414746bc8584b329 (patch)
tree6a448373f12cefb5b38909de745e16d61d6b111a
parent97a4caf877fd9d1eb4f63acc21ae8df1003fc353 (diff)
downloadopenembedded-e698a27699e7b64c8f654bce414746bc8584b329.tar.gz
libsdl-mixer: add 1.2.9
Signed-off-by: Michael Smith <msmith@cbnco.com>
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.9.bb23
2 files changed, 27 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index bf1e7425b9..140f485622 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1010,6 +1010,10 @@ sha256=89f94840b1b42ddfe53a8aee415331516f1bbdd942b42d25e74906a332cdf22a
md5=0b5b91015d0f3bd9597e094ba67c4d65
sha256=a8222a274778ff16d0e3ee49a30db27a48a4d357169a915fc599a764e405e0b6
+[http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-1.2.9.tar.gz]
+md5=a9eb8750e920829ff41dbe7555850156
+sha256=557910a4a3aeed6d10238e26b5a39b19247115a1b352580082bb15dc02ae4b8d
+
[http://www.libsdl.org/projects/SDL_net/release/SDL_net-1.2.5.tar.gz]
md5=e45b1048d2747480dcc65ece4130a920
sha256=397dee6b7ac13dea70dd3dd2ae6044f45a632a1ba156da178c96df66fb8ccdcb
diff --git a/recipes/libsdl/libsdl-mixer_1.2.9.bb b/recipes/libsdl/libsdl-mixer_1.2.9.bb
new file mode 100644
index 0000000000..5ecd2944a2
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer_1.2.9.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libmikmod libvorbis"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+inherit autotools_stage
+
+EXTRA_OECONF = "--disable-music-mp3"
+# although we build smpeg... need to find out how
+# to deal with optional dependencies
+
+do_compile() {
+ # Override SDL_LIBS to include a linker rpath so the linker
+ # can find the correct libdl.so when it links playwave to
+ # libSDL_mixer.so.
+ oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
+}