aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGregoire Gentil <gregoire@gentil.com>2009-10-25 10:21:54 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-26 18:23:04 +0100
commitb293c570854d6eb954491ba794cb0df2da2284f2 (patch)
tree87e00b9bfa7e279d6773bc08a8cb1162f6a62983
parent083679cd9634449aff829be751cfb236e1175956 (diff)
downloadopenembedded-b293c570854d6eb954491ba794cb0df2da2284f2.tar.gz
x-load: sync touchbook patches with AI repo
-rw-r--r--recipes/x-load/x-load-git/omap3-touchbook/name.patch14
-rw-r--r--recipes/x-load/x-load-git/omap3-touchbook/screen-off.patch20
-rw-r--r--recipes/x-load/x-load_git.bb1
3 files changed, 35 insertions, 0 deletions
diff --git a/recipes/x-load/x-load-git/omap3-touchbook/name.patch b/recipes/x-load/x-load-git/omap3-touchbook/name.patch
new file mode 100644
index 0000000000..98dcbae497
--- /dev/null
+++ b/recipes/x-load/x-load-git/omap3-touchbook/name.patch
@@ -0,0 +1,14 @@
+--- git/Makefile-orig 2008-07-29 22:31:03.000000000 -0700
++++ git/Makefile 2008-07-29 22:34:36.000000000 -0700
+@@ -152,9 +152,9 @@ omap3evm_config : unconfig
+ overo_config : unconfig
+ @./mkconfig $(@:_config=) arm omap3 overo
+
+-omap3530beagle_config : unconfig
++beagleboard_config : unconfig
+
+- @./mkconfig $(@:_config=) arm omap3 omap3530beagle
++ @./mkconfig omap3530beagle arm omap3 omap3530beagle
+
+ #########################################################################
+
diff --git a/recipes/x-load/x-load-git/omap3-touchbook/screen-off.patch b/recipes/x-load/x-load-git/omap3-touchbook/screen-off.patch
new file mode 100644
index 0000000000..06937bd3cd
--- /dev/null
+++ b/recipes/x-load/x-load-git/omap3-touchbook/screen-off.patch
@@ -0,0 +1,20 @@
+--- a/board/omap3530beagle/omap3530beagle.c 2009-09-05 16:23:03.000000000 -0700
++++ b/board/omap3530beagle/omap3530beagle.c 2009-09-05 16:23:50.000000000 -0700
+@@ -768,6 +768,7 @@
+ MUX_VAL(CP(SYS_BOOT4), (IEN | PTD | DIS | M4)) /*GPIO_6 */\
+ MUX_VAL(CP(SYS_BOOT5), (IEN | PTD | DIS | M4)) /*GPIO_7 */\
+ MUX_VAL(CP(SYS_BOOT6), (IEN | PTD | DIS | M4)) /*GPIO_8 */\
++ MUX_VAL(CP(MCSPI1_CS2), (IDIS | PTD | EN | M4)) /*GPIO_176*/\
+ MUX_VAL(CP(SYS_CLKOUT2), (IEN | PTU | EN | M4)) /*GPIO_186*/\
+ MUX_VAL(CP(JTAG_nTRST), (IEN | PTD | DIS | M0)) /*JTAG_nTRST*/\
+ MUX_VAL(CP(JTAG_TCK), (IEN | PTD | DIS | M0)) /*JTAG_TCK*/\
+--- a/include/asm/arch-omap3/mux.h 2009-09-05 16:28:14.000000000 -0700
++++ b/include/asm/arch-omap3/mux.h 2009-09-05 16:30:48.000000000 -0700
+@@ -321,6 +321,7 @@
+ #define CONTROL_PADCONF_SYS_BOOT6 0x0A16
+ #define CONTROL_PADCONF_SYS_OFF_MODE 0x0A18
+ #define CONTROL_PADCONF_SYS_CLKOUT1 0x0A1A
++#define CONTROL_PADCONF_MCSPI1_CS2 0x01D2
+ #define CONTROL_PADCONF_SYS_CLKOUT2 0x01E2
+ #define CONTROL_PADCONF_JTAG_nTRST 0x0A1C
+ #define CONTROL_PADCONF_JTAG_TCK 0x0A1E
diff --git a/recipes/x-load/x-load_git.bb b/recipes/x-load/x-load_git.bb
index 35090e621a..a369f4e3c9 100644
--- a/recipes/x-load/x-load_git.bb
+++ b/recipes/x-load/x-load_git.bb
@@ -18,6 +18,7 @@ SRC_URI_append_beagleboard = " \
SRC_URI_append_omap3-touchbook = " \
file://name.patch;patch=1 \
+ file://screen-off.patch;patch=1 \
"