aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-24 17:06:22 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-27 08:57:30 +0100
commit16726220cdea8de0a9a9cd6cbb3c2e2cb8b88df5 (patch)
treee9dd14a80979597524f8bd1602f9755d02af836f
parent4b276575de6c202b8b8832c8ab615be8a7d2a3a7 (diff)
downloadopenembedded-16726220cdea8de0a9a9cd6cbb3c2e2cb8b88df5.tar.gz
libxml2: stop overriding PACKAGES
-rw-r--r--recipes/libxml/libxml2.inc13
-rw-r--r--recipes/libxml/libxml2_2.7.3.bb2
2 files changed, 11 insertions, 4 deletions
diff --git a/recipes/libxml/libxml2.inc b/recipes/libxml/libxml2.inc
index f7ecaff977..bc31123e7c 100644
--- a/recipes/libxml/libxml2.inc
+++ b/recipes/libxml/libxml2.inc
@@ -5,6 +5,8 @@ LICENSE = "MIT"
SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
+PR = "r1"
+
inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
@@ -23,7 +25,14 @@ do_stage() {
DEBIANNAME_${PN} = "libxml2"
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+PACKAGES =+ "${PN}-utils"
+FILES_${PN} = "${libexecdir}/* ${libdir}/lib*${SOLIBS} \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_libdir}/*${SOLIBS} \
+ ${datadir}/${PN} ${libdir}/${PN}/* \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers"
FILES_${PN}-dev += "${bindir}/*-config"
-FILES_${PN}-utils += "${bindir}/* ${libdir}/*.sh"
+FILES_${PN}-utils = "${bindir}/xmllint ${bindir}/xmlcatalog ${libdir}/*.sh"
diff --git a/recipes/libxml/libxml2_2.7.3.bb b/recipes/libxml/libxml2_2.7.3.bb
index 555a436a63..fa80f36f2f 100644
--- a/recipes/libxml/libxml2_2.7.3.bb
+++ b/recipes/libxml/libxml2_2.7.3.bb
@@ -1,4 +1,2 @@
require libxml2.inc
-PR = "r0"
-