aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-11-13 14:23:03 +0100
committerChris Larson <clarson@kergoth.com>2010-08-09 19:03:33 -0700
commit0ccd3ec35ed506920ba7ede80306e7bbcf73cac5 (patch)
tree9b7a6bc636de08ad3d4e477c264cebacf7a03f8f
parent9e081f251e1b5ee653166615374176fd7159c2f3 (diff)
downloadopenembedded-0ccd3ec35ed506920ba7ede80306e7bbcf73cac5.tar.gz
stage-manager: change cp -d to cp -p, add hacky check for BSD mktemp
-rwxr-xr-xrecipes/stage-manager/files/stage-manager2
-rwxr-xr-xrecipes/stage-manager/files/stage-manager-ipkg8
-rw-r--r--recipes/stage-manager/stagemanager-native_0.0.1.bb2
3 files changed, 9 insertions, 3 deletions
diff --git a/recipes/stage-manager/files/stage-manager b/recipes/stage-manager/files/stage-manager
index 536d1afda0..0c01a18f94 100755
--- a/recipes/stage-manager/files/stage-manager
+++ b/recipes/stage-manager/files/stage-manager
@@ -91,7 +91,7 @@ if __name__ == "__main__":
if options.copydir:
copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
mkdirhier(os.path.split(copypath)[0])
- os.system("cp -dp " + path + " " + copypath)
+ os.system("cp -Pp " + path + " " + copypath)
def copydir(path, fstamp):
if options.copydir:
diff --git a/recipes/stage-manager/files/stage-manager-ipkg b/recipes/stage-manager/files/stage-manager-ipkg
index 07005e3cb0..5486c05844 100755
--- a/recipes/stage-manager/files/stage-manager-ipkg
+++ b/recipes/stage-manager/files/stage-manager-ipkg
@@ -109,7 +109,13 @@ Valid destinations are directories or one of the dest names from $IPKG_CONF:" >&
IPKG_DIR_PREFIX=usr/lib/ipkg
IPKG_LISTS_DIR=$IPKG_OFFLINE_ROOT/$IPKG_DIR_PREFIX/lists
IPKG_PENDING_DIR=$IPKG_OFFLINE_ROOT/$IPKG_DIR_PREFIX/pending
- IPKG_TMP=`mktemp -d`
+
+ # test for bsd mktemp and pass -t <prefix> when needed
+ if (mktemp -V) ; then
+ IPKG_TMP=`mktemp -d`
+ else
+ IPKG_TMP=`mktemp -d -t ipkg`
+ fi
if [ ! -d "$IPKG_TMP" ]; then
echo "Error, could not create a temp directory"
diff --git a/recipes/stage-manager/stagemanager-native_0.0.1.bb b/recipes/stage-manager/stagemanager-native_0.0.1.bb
index 9eeac4b073..b54c38df02 100644
--- a/recipes/stage-manager/stagemanager-native_0.0.1.bb
+++ b/recipes/stage-manager/stagemanager-native_0.0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Helper script for packaged-staging.bbclass"
-PR = "r13"
+PR = "r14"
SRC_URI = "file://stage-manager \
file://stage-manager-ipkg \