aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-07-20 13:04:10 -0700
committerKhem Raj <raj.khem@gmail.com>2009-07-20 13:04:10 -0700
commit84cdf85f95bf122372d4558889dc64f1d232abb8 (patch)
treea0677e890d763e77957ce41306cc69ea562ffc67
parent6c333ee75ad6b633c9e218f22193a02453f9215d (diff)
parent21b107bab4a6fcb1bd4a3afa618dea6d53db07f0 (diff)
downloadopenembedded-84cdf85f95bf122372d4558889dc64f1d232abb8.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--conf/checksums.ini4
-rw-r--r--conf/local.conf.sample5
-rw-r--r--recipes/bluez/bluez4_4.46.bb13
-rw-r--r--recipes/dvsdk/gstreamer-ti_svn.bb2
-rw-r--r--recipes/gnash/gnash_0.8.5.bb8
-rw-r--r--recipes/mplayer/mplayer_svn.bb2
6 files changed, 30 insertions, 4 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index ec2f2a44eb..cd1c86ef70 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -2838,6 +2838,10 @@ sha256=0b22f518085528b71aa9eab8bbc44d2696458c85d902c6a6686076ae10d64549
md5=d24dfd3ca42847123e29f58b29af6948
sha256=ed7631a6d22b456eb26b881bdbe46ea47f93d2f192da420408bad4bbc245f796
+[http://www.kernel.org/pub/linux/bluetooth/bluez-4.46.tar.gz]
+md5=ed24b291e9a724a37bc8e9d04adae413
+sha256=31f058fb722dfb96a7b496a064e0c46d634d7dffdd5b64c7dce3ab6ec2fa48bc
+
[http://www.kernel.org/pub/linux/bluetooth/bluez-4.7.tar.gz]
md5=2aa806940d2c841e57a9b2ab7302b750
sha256=ed384dea4f5f21157758fcd7db64db19ce0b410509c26630706e4a3c779287a0
diff --git a/conf/local.conf.sample b/conf/local.conf.sample
index a00fec4c2a..643ae0b611 100644
--- a/conf/local.conf.sample
+++ b/conf/local.conf.sample
@@ -119,6 +119,11 @@ PREFERRED_PROVIDERS += " virtual/${TARGET_PREFIX}g++:gcc-cross"
# squashfs, squashfs-lzma
IMAGE_FSTYPES = "jffs2 tar"
+# Uncomment this if you want to keep the temporary rootfs
+# diretory, this can be useful during development.
+# (Note that this rootfs is NOT usuable as NFS export.)
+# IMAGE_KEEPROOTFS = "1"
+
# Uncomment this to disable the parse cache (not recommended).
# CACHE = ""
diff --git a/recipes/bluez/bluez4_4.46.bb b/recipes/bluez/bluez4_4.46.bb
new file mode 100644
index 0000000000..8f5c6e8f7c
--- /dev/null
+++ b/recipes/bluez/bluez4_4.46.bb
@@ -0,0 +1,13 @@
+require bluez4.inc
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
+
+DEPENDS += "libsndfile1"
+PR = "${INC_PR}.1"
+
+# Not all distros have a recent enough udev
+BTUDEV = " --disable-udevrules"
+BTUDEV_angstrom = " --enable-udevrules"
+EXTRA_OECONF += "${BTUDEV}"
+
diff --git a/recipes/dvsdk/gstreamer-ti_svn.bb b/recipes/dvsdk/gstreamer-ti_svn.bb
index 6eeffd0225..2b080a0576 100644
--- a/recipes/dvsdk/gstreamer-ti_svn.bb
+++ b/recipes/dvsdk/gstreamer-ti_svn.bb
@@ -5,7 +5,7 @@ inherit autotools
DEPENDS = "ti-dmai gstreamer gst-plugins-base gst-plugins-good gst-plugins-ugly"
# Fetch source from svn repo
-SRCREV = "285"
+SRCREV = "308"
SRC_URI = "svn://gforge.ti.com/svn/gstreamer_ti/trunk;module=gstreamer_ti;proto=https;user=anonymous;pswd='' \
"
diff --git a/recipes/gnash/gnash_0.8.5.bb b/recipes/gnash/gnash_0.8.5.bb
index fa9b3230e3..c68700fed4 100644
--- a/recipes/gnash/gnash_0.8.5.bb
+++ b/recipes/gnash/gnash_0.8.5.bb
@@ -1,6 +1,6 @@
require gnash.inc
-DEPENDS += "gst-plugins-base"
+DEPENDS += "gst-plugins-base cairo"
acpaths = " -Imacros"
@@ -33,6 +33,10 @@ EXTRA_OECONF += " --without-included-ltdl \
--enable-png \
--with-png-incl=${STAGING_INCDIR} \
--with-png-lib=${STAGING_LIBDIR} \
+ --with-cairo-incl=${STAGING_DIR_HOST}/usr/include/cairo \
+ --with-cairo-lib=${STAGING_DIR_HOST}/usr/lib \
--enable-media=gst \
- "
+ --disable-speex \
+ --disable-speexdsp \
+ "
diff --git a/recipes/mplayer/mplayer_svn.bb b/recipes/mplayer/mplayer_svn.bb
index dfb73536de..d26302e65b 100644
--- a/recipes/mplayer/mplayer_svn.bb
+++ b/recipes/mplayer/mplayer_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Open Source multimedia player."
SECTION = "multimedia"
PRIORITY = "optional"
HOMEPAGE = "http://www.mplayerhq.hu/"
-DEPENDS = "libdvdread libtheora virtual/libsdl ffmpeg xsp zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11 virtual/kernel \
+DEPENDS = "live555 libdvdread libtheora virtual/libsdl ffmpeg xsp zlib libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses lame libxv virtual/libx11 virtual/kernel \
${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad liba52 lame', d)}"
RDEPENDS = "mplayer-common"