aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-03-24 16:33:40 -0700
committerKhem Raj <raj.khem@gmail.com>2009-03-24 16:33:40 -0700
commitd92c10af44683f2c7ee36c7c52583d6fb807f47a (patch)
treee3572f803c423db8d465d2ef61c5c3a3464f8dc1
parent612f5698260021eadb06a3e8f618b555b9f7cf21 (diff)
parent3751f09c2b00e7bf9564efe6a9dc30fd14febea8 (diff)
downloadopenembedded-d92c10af44683f2c7ee36c7c52583d6fb807f47a.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
-rw-r--r--recipes/mpeg-encode/files/fixup.patch30
-rw-r--r--recipes/mpeg-encode/mpeg-encode_1.5b.bb2
2 files changed, 22 insertions, 10 deletions
diff --git a/recipes/mpeg-encode/files/fixup.patch b/recipes/mpeg-encode/files/fixup.patch
index c90f32760a..eda092058e 100644
--- a/recipes/mpeg-encode/files/fixup.patch
+++ b/recipes/mpeg-encode/files/fixup.patch
@@ -1,6 +1,6 @@
-diff -urN mpeg_encode.old//headers/libpnmrw.h mpeg_encode//headers/libpnmrw.h
---- mpeg_encode.old//headers/libpnmrw.h 1995-08-09 16:17:41.000000000 +0100
-+++ mpeg_encode//headers/libpnmrw.h 2009-02-10 17:06:09.508519503 +0000
+diff -urN mpeg_encode.old/headers/libpnmrw.h mpeg_encode/headers/libpnmrw.h
+--- mpeg_encode.old/headers/libpnmrw.h 1995-08-09 16:17:41.000000000 +0100
++++ mpeg_encode/headers/libpnmrw.h 2009-03-24 23:24:25.000000000 +0000
@@ -13,18 +13,7 @@
#ifndef _PNMRW_H_
#define _PNMRW_H_
@@ -20,9 +20,9 @@ diff -urN mpeg_encode.old//headers/libpnmrw.h mpeg_encode//headers/libpnmrw.h
/* Definitions to make PBMPLUS work with either ANSI C or C Classic. */
-diff -urN mpeg_encode.old//jpeg/Makefile mpeg_encode//jpeg/Makefile
---- mpeg_encode.old//jpeg/Makefile 1995-08-05 00:27:00.000000000 +0100
-+++ mpeg_encode//jpeg/Makefile 2009-02-10 17:27:20.488862124 +0000
+diff -urN mpeg_encode.old/jpeg/Makefile mpeg_encode/jpeg/Makefile
+--- mpeg_encode.old/jpeg/Makefile 1995-08-05 00:27:00.000000000 +0100
++++ mpeg_encode/jpeg/Makefile 2009-03-24 23:24:25.000000000 +0000
@@ -20,9 +20,6 @@
manprefix =
manext = 1
@@ -54,9 +54,9 @@ diff -urN mpeg_encode.old//jpeg/Makefile mpeg_encode//jpeg/Makefile
$(AR2) libjpeg.a
cjpeg: $(COBJECTS) libjpeg.a
-diff -urN mpeg_encode.old//libpnmrw.c mpeg_encode//libpnmrw.c
---- mpeg_encode.old//libpnmrw.c 1995-08-16 23:24:26.000000000 +0100
-+++ mpeg_encode//libpnmrw.c 2009-02-10 17:58:49.768855068 +0000
+diff -urN mpeg_encode.old/libpnmrw.c mpeg_encode/libpnmrw.c
+--- mpeg_encode.old/libpnmrw.c 1995-08-16 23:24:26.000000000 +0100
++++ mpeg_encode/libpnmrw.c 2009-03-24 23:24:25.000000000 +0000
@@ -28,6 +28,7 @@
#endif
@@ -74,3 +74,15 @@ diff -urN mpeg_encode.old//libpnmrw.c mpeg_encode//libpnmrw.c
char* e;
e = sys_errlist[errno];
+diff -urN mpeg_encode.old/Makefile mpeg_encode/Makefile
+--- mpeg_encode.old/Makefile 1995-08-16 23:16:56.000000000 +0100
++++ mpeg_encode/Makefile 2009-03-24 23:24:47.000000000 +0000
+@@ -204,7 +204,7 @@
+
+ mpeg_encode: $(MP_ALL_OBJS) $(JPEG_LIB)
+ $(PURIFY) $(CC) $(CFLAGS) -o $@ $(MP_ALL_OBJS) $(LIBDIRS) $(LIBS)
+- strip mpeg_encode
++ $(STRIP) mpeg_encode
+
+ profile: $(MP_ALL_OBJS)
+ $(PURIFY) $(CC) -Bstatic -pg $(CFLAGS) -o $@ $(MP_ALL_OBJS) $(LIBDIRS) $(LIBS)
diff --git a/recipes/mpeg-encode/mpeg-encode_1.5b.bb b/recipes/mpeg-encode/mpeg-encode_1.5b.bb
index c350739531..d32322a504 100644
--- a/recipes/mpeg-encode/mpeg-encode_1.5b.bb
+++ b/recipes/mpeg-encode/mpeg-encode_1.5b.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "The Berkeley MPEG Encoder."
HOMEPAGE = "http://bmrc.berkeley.edu/frame/research/mpeg/mpeg_encode.html"
SECTION = "multimedia"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://bmrc.berkeley.edu/ftp/pub/multimedia/mpeg/encode/mpeg_encode-${PV}-src.tar.gz \
file://fixup.patch;patch=1"