aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-03-25 16:35:04 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-03-25 16:35:04 +0100
commit82b9cae9c7298e430843f6d547abfaf9ff26eed0 (patch)
tree0015c884e0280b0bbdf9aa8707a5cfe696b434c3
parent8ec53c8f0baed036778e380462838fe723a5f4b8 (diff)
downloadopenembedded-82b9cae9c7298e430843f6d547abfaf9ff26eed0.tar.gz
qt4-tools-native: stage mkspecs for the host platform
-rw-r--r--recipes/qt4/qt4-tools-native_4.4.3.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes/qt4/qt4-tools-native_4.4.3.bb b/recipes/qt4/qt4-tools-native_4.4.3.bb
index 4e35149b21..03bffcce6d 100644
--- a/recipes/qt4/qt4-tools-native_4.4.3.bb
+++ b/recipes/qt4/qt4-tools-native_4.4.3.bb
@@ -4,11 +4,12 @@ SECTION = "libs"
HOMEPAGE = "http://www.trolltech.com"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
inherit native
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://0005-fix-mkspecs.patch;patch=1 \
file://qt-config.patch;patch=1"
S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
@@ -24,14 +25,13 @@ EXTRA_OECONF = "-prefix ${prefix} \
-no-libpng \
-verbose -release -fast -static \
-qt3support "
-# yank default -e
+
+# yank default -e, otherwise we get the following error:
+# moc_qbuffer.cpp: No such file or directory
EXTRA_OEMAKE = " "
do_configure() {
- # Make sure we regenerate all Makefiles
- find ${S} -name "Makefile" | xargs rm
-
- sed -i 's:^QT += xml qt3support$:QT += xml qt3support network:' "${S}"/src/tools/uic3/uic3.pro
+ ln -s linux-g++ mkspecs/${BUILD_OS}-oe-g++
echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
}
@@ -57,13 +57,13 @@ do_compile() {
}
do_stage() {
- install -d ${STAGING_BINDIR}/
- install -m 0755 bin/qmake ${STAGING_BINDIR}/qmake2
- ln -sf qmake2 ${STAGING_BINDIR}/qmake-qt4
+ install -d ${STAGING_BINDIR_NATIVE}/
+ install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake2
for i in moc uic uic3 rcc lrelease lupdate; do
- install -m 0755 bin/${i} ${STAGING_BINDIR}/${i}4
+ install -m 0755 bin/${i} ${STAGING_BINDIR_NATIVE}/${i}4
done
install -d ${STAGING_DATADIR_NATIVE}/qt4/
cp -PfR mkspecs ${STAGING_DATADIR_NATIVE}/qt4/
install -m 0644 tools/porting/src/q3porting.xml ${STAGING_DATADIR_NATIVE}/qt4/
}
+