aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-24 19:22:13 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-24 19:22:13 +0100
commit5a03b8a7b4bab46eaf0074e383b38c82919ac808 (patch)
tree73a45af141bb1802a76a3628293129d7e0d54515
parentdf49f5e7f5a14c6736806f3163787608c958f4c9 (diff)
downloadopenembedded-5a03b8a7b4bab46eaf0074e383b38c82919ac808.tar.gz
ti-dmai: fetch from svn
* gets us some buildfixes for free * no need to download it from my.ti.com, which requires a login
-rw-r--r--recipes/dsplink/ti-dmai_svn.bb (renamed from recipes/dsplink/ti-dmai_1.20.bb)27
1 files changed, 5 insertions, 22 deletions
diff --git a/recipes/dsplink/ti-dmai_1.20.bb b/recipes/dsplink/ti-dmai_svn.bb
index 026f5a382c..f6ff173a42 100644
--- a/recipes/dsplink/ti-dmai_1.20.bb
+++ b/recipes/dsplink/ti-dmai_svn.bb
@@ -4,22 +4,17 @@ LICENCE = "unknown"
require ti-paths.inc
-# https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_20_00_06/dmai_setuplinux_1_20_00_06.bin
-# Install the above link and put the dmai_1_20_00_06.tar.gz file in the same directory as this recipe
-SRC_URI = "file://dmai_1_20_00_06.tar.gz \
- file://dmai-update-cpu-name.patch;patch=1 \
- file://dmai-update-fb-display.patch;patch=1 \
- file://dmai-update-v4l2-display.patch;patch=1 \
- file://dmai-do-not-panic-on-mixer-failure.patch;patch=1 \
- file://dmai-support-32bit-align.patch;patch=1 \
+SRC_URI = "svn://gforge.ti.com/svn/dmai/branches;module=BRIJESH_GIT_022309;proto=https;user=anonymous;pswd='' \
file://dmai-built-with-angstrom.patch;patch=1 \
file://loadmodules-ti-dmai-apps.sh \
file://unloadmodules-ti-dmai-apps.sh \
"
-S = "${WORKDIR}/dmai_1_20_00_06"
+SRCREV = "36"
+
+S = "${WORKDIR}/BRIJESH_GIT_022309/davinci_multimedia_application_interface/dmai"
# Yes, the xdc stuff still breaks with a '.' in PWD
-PV = "120"
+PV = "120+svnr${SRCREV}"
PR = "r15"
TARGET = "all"
@@ -31,18 +26,6 @@ export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine"
export FC_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/cetools"
export CODEC_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combos"
-do_compile_prepend_omap3evm() {
-
-#temp removal of sources that fail to build on evm3530
- if [ -e packages/ti/sdo/dmai/linux/omap3530/Resize.c ]; then
- rm packages/ti/sdo/dmai/linux/omap3530/Resize.c
- fi
-
- if [ -e packages/ti/sdo/dmai/linux/omap3530/Framecopy_accel.c ]; then
- rm packages/ti/sdo/dmai/linux/omap3530/Framecopy_accel.c
- fi
-}
-
do_compile() {
cd packages/ti/sdo/dmai
oe_runmake clean