aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-03-25 10:47:35 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-03-25 10:47:35 +0100
commit1476b9765624d62a30fadcd6a7a2abdaeea842e8 (patch)
tree82d2c07da591b3414d8f946982bf33e96eefd2c6
parentcfb474d9392e9edb5cd42e07c057b0a084bf18c5 (diff)
downloadopenembedded-1476b9765624d62a30fadcd6a7a2abdaeea842e8.tar.gz
qt4-native: add qt-config.patch from qmake2-native
-rw-r--r--recipes/qt4/qt4-native-4.4.3/qt-config.patch21
-rw-r--r--recipes/qt4/qt4-native_4.4.3.bb3
2 files changed, 23 insertions, 1 deletions
diff --git a/recipes/qt4/qt4-native-4.4.3/qt-config.patch b/recipes/qt4/qt4-native-4.4.3/qt-config.patch
new file mode 100644
index 0000000000..3aa041aa51
--- /dev/null
+++ b/recipes/qt4/qt4-native-4.4.3/qt-config.patch
@@ -0,0 +1,21 @@
+--- /tmp/qlibraryinfo.cpp 2008-08-02 17:16:41.000000000 +0200
++++ qt-embedded-linux-opensource-src-4.4.1/src/corelib/global/qlibraryinfo.cpp 2008-08-02 17:17:42.000000000 +0200
+@@ -47,6 +47,7 @@
+ QT_BEGIN_NAMESPACE
+ extern QString qmake_libraryInfoFile();
+ QT_END_NAMESPACE
++#include <stdlib.h>
+ #else
+ # include "qcoreapplication.h"
+ #endif
+@@ -113,6 +114,10 @@
+ #ifdef QT_BUILD_QMAKE
+ if(!QFile::exists(qtconfig))
+ qtconfig = qmake_libraryInfoFile();
++ if (!QFile::exists(qtconfig)) {
++ QByteArray config = getenv("QT_CONF_PATH");
++ qtconfig = config;
++ }
+ #else
+ if (!QFile::exists(qtconfig) && QCoreApplication::instance()) {
+ #ifdef Q_OS_MAC
diff --git a/recipes/qt4/qt4-native_4.4.3.bb b/recipes/qt4/qt4-native_4.4.3.bb
index b32a9da28f..4e35149b21 100644
--- a/recipes/qt4/qt4-native_4.4.3.bb
+++ b/recipes/qt4/qt4-native_4.4.3.bb
@@ -8,7 +8,8 @@ PR = "r0"
inherit native
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2"
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://qt-config.patch;patch=1"
S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
EXTRA_OECONF = "-prefix ${prefix} \