aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-14 17:46:00 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-14 17:46:36 +0100
commitbc68ed7c92effcdc7b475286bf1c3ac2f772f073 (patch)
tree19caa209c21ab0defd8ad705c98ef011025e8a59
parent2e3f7f97267390bd0c70a41a9f58948f860bc66b (diff)
downloadopenembedded-bc68ed7c92effcdc7b475286bf1c3ac2f772f073.tar.gz
serial-forward: catch up with conversion to autotools
pty-forward-native: dito
-rw-r--r--conf/distro/include/sane-srcrevs.inc4
-rw-r--r--recipes/serial-utils/pty-forward-native.bb15
-rw-r--r--recipes/serial-utils/serial-forward.bb14
3 files changed, 8 insertions, 25 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 7f1f7742ce..5377a07266 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -262,7 +262,7 @@ SRCREV_pn-phoneui-apps ?= "c27e620302d0ea956da777f76a4aa217ae8366c6"
SRCREV_pn-phoneuid ?= "215e0b6e021e27cd042d675ec91d501a03211091"
SRCREV_pn-portaudio-v19 ?= "1387"
SRCREV_pn-psplash ?= "249"
-SRCREV_pn-pty-forward-native ?= "a41cae9df1af4fc710c701ac01016d3668dd5fba"
+SRCREV_pn-pty-forward-native ?= "4662b55fdba528bb5b3349f83055bf236af5d63b"
SRCREV_pn-pyefl-sudoku ?= "49"
SRCREV_pn-pygsm ?= "976477f6b403f422b4ea730f71ebf409f6671141"
SRCREV_pn-pyphonelog ?= "45783c7fd5ec274421bf87a5cdb372c122370fda"
@@ -286,7 +286,7 @@ SRCREV_pn-remoko ?= "121"
SRCREV_pn-remoko-server ?= "121"
SRCREV_pn-s3c24xx-gpio ?= "4949"
SRCREV_pn-s3c64xx-gpio ?= "4949"
-SRCREV_pn-serial-forward ?= "a41cae9df1af4fc710c701ac01016d3668dd5fba"
+SRCREV_pn-serial-forward ?= "4662b55fdba528bb5b3349f83055bf236af5d63b"
SRCREV_pn-settings-daemon ?= "2006"
SRCREV_pn-shr-config ?= "37dd7ac950e2bfd438801faf34c29fccfdbbaccf"
SRCREV_pn-shr-contacts ?= "9d7ca1cecb93022e5b890cd87756ac6f072710ca"
diff --git a/recipes/serial-utils/pty-forward-native.bb b/recipes/serial-utils/pty-forward-native.bb
index c613276645..0cc21e1fc6 100644
--- a/recipes/serial-utils/pty-forward-native.bb
+++ b/recipes/serial-utils/pty-forward-native.bb
@@ -2,26 +2,17 @@ DESCRIPTION = "Receive a forwarded serial from serial-forward and provide a PTY"
AUTHOR = "Holger 'Zecke' Freyther"
LICENSE = "GPL"
SECTION = "console/network"
-PV = "1.0.1+gitr${SRCREV}"
+PV = "1.1+gitr${SRCREV}"
PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git"
S = "${WORKDIR}/git/tools/serial_forward"
-inherit native
-
-do_compile() {
- cd ${S}
- oe_runmake
-}
-
-do_stage() {
- :
-}
+inherit autotools native
do_deploy() {
install -d ${DEPLOY_DIR_IMAGE}
- install -m 0755 ${S}/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
+ install -m 0755 ${S}/src/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
}
addtask deploy before do_package after do_install
diff --git a/recipes/serial-utils/serial-forward.bb b/recipes/serial-utils/serial-forward.bb
index b03fc597dd..8645b85c71 100644
--- a/recipes/serial-utils/serial-forward.bb
+++ b/recipes/serial-utils/serial-forward.bb
@@ -2,18 +2,10 @@ DESCRIPTION = "Forward a serial using TCP/IP"
AUTHOR = "Holger 'Zecke' Freyther'"
LICENSE = "GPL"
SECTION = "console/devel"
-PV = "1.0.1+gitr${SRCREV}"
-PR = "r1"
+PV = "1.1+gitr${SRCREV}"
+PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git/;protocol=git"
S = "${WORKDIR}/git/tools/serial_forward"
-EXTRA_OEMAKE = "CC="${CC} ${LDFLAGS}""
-do_compile() {
- cd ${S}
- oe_runmake
-}
-do_install() {
- install -d ${D}/${bindir}
- install -m 0755 ${S}/forward ${D}/${bindir}/${PN}
-}
+inherit autotools