aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-17 16:06:29 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-17 16:06:29 +0100
commit8cb3620fee3c4011367f53d7c69d014e21d45461 (patch)
tree01fae8214f4c9e625e74ae3fec6b9aeff523af52
parent3429df86535d1ae420ed2497ef564c2e89143313 (diff)
downloadopenembedded-8cb3620fee3c4011367f53d7c69d014e21d45461.tar.gz
python-pyid3lib: fix compiling for gcc4.x
-rw-r--r--recipes/python/python-pyid3lib/gcc4-fix.patch13
-rw-r--r--recipes/python/python-pyid3lib_0.5.1.bb9
2 files changed, 18 insertions, 4 deletions
diff --git a/recipes/python/python-pyid3lib/gcc4-fix.patch b/recipes/python/python-pyid3lib/gcc4-fix.patch
new file mode 100644
index 0000000000..cfd972771f
--- /dev/null
+++ b/recipes/python/python-pyid3lib/gcc4-fix.patch
@@ -0,0 +1,13 @@
+Index: pyid3lib-0.5.1/pyid3lib.cc
+===================================================================
+--- pyid3lib-0.5.1.orig/pyid3lib.cc
++++ pyid3lib-0.5.1/pyid3lib.cc
+@@ -1013,7 +1013,7 @@
+ {
+ ID3_Frame* frame;
+ const char* str;
+- char* slash;
++ const char* slash;
+ ID3_Field* fld;
+ int i;
+
diff --git a/recipes/python/python-pyid3lib_0.5.1.bb b/recipes/python/python-pyid3lib_0.5.1.bb
index bf7e3d0a2f..1d24b347c9 100644
--- a/recipes/python/python-pyid3lib_0.5.1.bb
+++ b/recipes/python/python-pyid3lib_0.5.1.bb
@@ -4,11 +4,12 @@ PRIORITY = "optional"
LICENSE = "LGPL"
DEPENDS = "id3lib"
SRCNAME = "pyid3lib"
-PR = "r1"
+PR = "r2"
-SRC_URI = "${SOURCEFORGE_MIRROR}/pyid3lib/${SRCNAME}-${PV}.tar.bz2"
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/pyid3lib/${SRCNAME}-${PV}.tar.bz2\
+ file://gcc4-fix.patch;patch=1 \
+"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
-
-