aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2010-10-25 13:16:37 +0200
committerEric BĂ©nard <eric@eukrea.com>2010-11-01 14:20:58 +0100
commit720ef414283749422517f2bdb5d884b08121e1cd (patch)
treec1e4321061d3f1639083146060725ce9f7b32749
parentcb798dc31dee5c131e0f634021678e9c2fedeca8 (diff)
downloadopenembedded-720ef414283749422517f2bdb5d884b08121e1cd.tar.gz
qwt 5.2.1: add recipes for /e and /x11 versions
* QT/e apps using this lib will need some s/qwt/qwt$QTLIBINFIX/g love Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/qwt/qwt-e_5.2.1.bb7
-rw-r--r--recipes/qwt/qwt.inc23
-rw-r--r--recipes/qwt/qwt_5.2.1.bb7
3 files changed, 37 insertions, 0 deletions
diff --git a/recipes/qwt/qwt-e_5.2.1.bb b/recipes/qwt/qwt-e_5.2.1.bb
new file mode 100644
index 0000000000..a9f3e38fda
--- /dev/null
+++ b/recipes/qwt/qwt-e_5.2.1.bb
@@ -0,0 +1,7 @@
+inherit qt4e
+
+require qwt.inc
+
+SRC_URI[qwt.md5sum] = "4a595b8db0ec3856b117836c1d60cb27"
+SRC_URI[qwt.sha256sum] = "e2b8bb755404cb3dc99e61f3e2d7262152193488f5fbe88524eb698e11ac569f"
+
diff --git a/recipes/qwt/qwt.inc b/recipes/qwt/qwt.inc
new file mode 100644
index 0000000000..98117fb401
--- /dev/null
+++ b/recipes/qwt/qwt.inc
@@ -0,0 +1,23 @@
+DESCRIPTION = "Qt Widget Extension for Technical Applications"
+SECTION = "libs"
+PRIORITY = "optional"
+
+# LGPLv2.1 + some exceptions
+LICENSE = "QWTv1.0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tar.bz2;name=qwt"
+
+S = "${WORKDIR}/qwt-${PV}"
+
+do_configure_prepend() {
+ sed -i -e 's:RELEASE_SUFFIX = :RELEASE_SUFFIX = ${QT_LIBINFIX}:' *.pri
+ sed -i -e s:lqwt:lqwt${QT_LIBINFIX}:g -e s:/usr/local/qwt-$\${QwtVersion}:${prefix}:g *.prf
+}
+
+do_install() {
+ sed -i -e s:/usr/local/qwt-${PV}:${D}${prefix}:g ${S}/*.pri
+ oe_runmake -e install
+ install -d ${D}${datadir}/doc/${PN}
+ mv ${D}${prefix}/doc/* ${D}${datadir}/doc/${PN}/
+}
+
diff --git a/recipes/qwt/qwt_5.2.1.bb b/recipes/qwt/qwt_5.2.1.bb
new file mode 100644
index 0000000000..15e767c9c3
--- /dev/null
+++ b/recipes/qwt/qwt_5.2.1.bb
@@ -0,0 +1,7 @@
+inherit qt4x11
+
+require qwt.inc
+
+SRC_URI[qwt.md5sum] = "4a595b8db0ec3856b117836c1d60cb27"
+SRC_URI[qwt.sha256sum] = "e2b8bb755404cb3dc99e61f3e2d7262152193488f5fbe88524eb698e11ac569f"
+