aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak <seba.dos1@gmail.com>2010-10-31 13:32:39 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-31 16:04:36 +0100
commit5fb62a67b1f9a54b428ca0be6a259b4cc940fd46 (patch)
tree8fb5c2a3be2aeefb8949278a3a38fef2b3ef8933
parentd1e63916de163f52d21dffe123f4cc58e13391d2 (diff)
downloadopenembedded-5fb62a67b1f9a54b428ca0be6a259b4cc940fd46.tar.gz
mokomaze: fix vibration on gta02 with 2.6.34 kernel
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/mokomaze/files/0001-Fix-vibration-on-gta02-with-2.6.34-kernel.patch26
-rw-r--r--recipes/mokomaze/mokomaze_0.5.5.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/recipes/mokomaze/files/0001-Fix-vibration-on-gta02-with-2.6.34-kernel.patch b/recipes/mokomaze/files/0001-Fix-vibration-on-gta02-with-2.6.34-kernel.patch
new file mode 100644
index 0000000000..9928718b69
--- /dev/null
+++ b/recipes/mokomaze/files/0001-Fix-vibration-on-gta02-with-2.6.34-kernel.patch
@@ -0,0 +1,26 @@
+From a423e4ec58be48a603ab672c3e5d0921b4fff095 Mon Sep 17 00:00:00 2001
+From: Sebastian Krzyszkowiak <seba.dos1@gmail.com>
+Date: Sun, 31 Oct 2010 15:29:12 +0100
+Subject: [PATCH] Fix vibration on gta02 with 2.6.34 kernel
+
+---
+ src/vibro.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/vibro.c b/src/vibro.c
+index 97ef0da..aa025d4 100644
+--- a/src/vibro.c
++++ b/src/vibro.c
+@@ -47,6 +47,9 @@ int init_vibro()
+ fvibro = fopen("/sys/devices/platform/neo1973-vibrator.0/leds/neo1973:vibrator/brightness", "w");
+ if (fvibro != NULL) return 0;
+
++ fvibro = fopen("/sys/class/leds/gta02::vibrator/brightness", "w");
++ if (fvibro != NULL) return 0;
++
+ fprintf(stderr, "Vibro: can't init.\n");
+ return 1;
+ }
+--
+1.7.2.3
+
diff --git a/recipes/mokomaze/mokomaze_0.5.5.bb b/recipes/mokomaze/mokomaze_0.5.5.bb
index 842175244b..223414d9ba 100644
--- a/recipes/mokomaze/mokomaze_0.5.5.bb
+++ b/recipes/mokomaze/mokomaze_0.5.5.bb
@@ -7,11 +7,12 @@ DEPENDS = "libsdl-ttf libsdl-image ode"
RDEPENDS_${PN} = "ttf-liberation-mono libpng"
RDEPENDS_${PN}_shr = "ttf-liberation-mono libpng fsoraw"
PV = "0.5.5+git8"
-PR = "r5"
+PR = "r6"
SRC_URI = "http://mokomaze.projects.openmoko.org/files/${PN}-${PV}.tar.gz"
SRC_URI_append_shr = " file://fsoraw.patch"
SRC_URI_append_shr = " file://0001-Fix-accelerometers-with-2.6.34-kernels.patch"
+SRC_URI_append_shr = " file://0001-Fix-vibration-on-gta02-with-2.6.34-kernel.patch"
SRC_URI[md5sum] = "f4e1dbd444b4049c361f9c1c3d40d32b"
SRC_URI[sha256sum] = "515d842b79a2c34f5789fa10110bc9d7b15c65a7b1fa623131a1e03599fe7362"