aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-20 13:19:31 -0700
committerChris Larson <chris_larson@mentor.com>2010-11-02 18:39:03 -0700
commit38dcd83a31de112645be2490dc64b26f044d81ea (patch)
treec9840ac5b01dcdd47376f5382dc183ca698bd67d
parent379462b1f6cdc713d6f9db203e9bda17168cfcd7 (diff)
downloadopenembedded-38dcd83a31de112645be2490dc64b26f044d81ea.tar.gz
autotools: shift default acpaths into oe_autoreconf
Signed-off-by: Chris Larson <chris_larson@mentor.com>
-rw-r--r--classes/autotools.bbclass12
1 files changed, 6 insertions, 6 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index 7f353146c2..888e4fffb6 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -66,7 +66,11 @@ _autoconf_trace () {
}
oe_autoreconf () {
- aclocal "$@"
+ AUTOV=`automake --version | head -n 1 | sed "s/.* //;s/\.[0-9]\+$//"`
+ mkdir -p ${STAGING_DATADIR}/aclocal \
+ ${STAGING_DATADIR}/aclocal-$AUTOV
+ aclocal "$@" -I${STAGING_DATADIR}/aclocal \
+ -I${STAGING_DATADIR}/aclocal-$AUTOV
for subdir in $(_autoconf_trace AC_CONFIG_SUBDIRS | cut -d: -f4); do
pushd $subdir
oe_autoreconf "$@"
@@ -74,7 +78,7 @@ oe_autoreconf () {
done
rm -f configure
- autoreconf --install --symlink --force --no-recursive ${EXTRA_AUTORECONF} "$@"
+ autoreconf --install --symlink --force --no-recursive ${EXTRA_AUTORECONF} "$@" $acpaths
if [ -n "`_autoconf_trace AM_GLIB_GNU_GETTEXT`" ]; then
if [ -e configure.in ]; then
CONFIGURE_AC=$srcdir/configure.in
@@ -115,10 +119,6 @@ autotools_do_configure() {
else
acpaths="${acpaths}"
fi
- AUTOV=`automake --version | head -n 1 | sed "s/.* //;s/\.[0-9]\+$//"`
- install -d ${STAGING_DATADIR}/aclocal
- install -d ${STAGING_DATADIR}/aclocal-$AUTOV
- acpaths="$acpaths -I${STAGING_DATADIR}/aclocal-$AUTOV -I ${STAGING_DATADIR}/aclocal"
pushd ${S}
oe_autoreconf $acpaths
popd