aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-11-01 22:22:14 +0100
committerEric Bénard <eric@eukrea.com>2010-11-02 22:03:20 +0100
commit04386651d904b8f5c2dd8b9adbb3e2f4b94fcc3a (patch)
tree46b5efc5ec1cf6b4cfcdc0a83ad12ea697b24833
parent5efecae8b7f4b814f2d055daf6dc7ae1ce05e41a (diff)
downloadopenembedded-04386651d904b8f5c2dd8b9adbb3e2f4b94fcc3a.tar.gz
gdb-cross-sdk: reconfigure before running oe_runmake configure-host
so we have : configure then make configure-host which generates the Makefile that we modify using sed to statically link the libs Without this patch, we don't statically link libncurses, libtinfo and libz which leads to : /usr/local/angstrom/arm/bin/arm-angstrom-linux-gnueabi-gdb: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory when trying to use the toolchain. Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/gdb/gdb-cross-sdk.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/gdb/gdb-cross-sdk.inc b/recipes/gdb/gdb-cross-sdk.inc
index 6a708ca1f6..e1d4895635 100644
--- a/recipes/gdb/gdb-cross-sdk.inc
+++ b/recipes/gdb/gdb-cross-sdk.inc
@@ -8,6 +8,7 @@ EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' L
# add a depenency on the -sdk versions of them.
do_configure_append () {
cd ${B}
+ oe_runconf
oe_runmake configure-host
sed -e 's,-lncurses,${STAGING_LIBDIR_NATIVE}/libncurses.a ${STAGING_LIBDIR_NATIVE}/libtinfo.a ,g' -i ${B}/gdb/Makefile
sed -e 's,-lz, ${STAGING_LIBDIR_NATIVE}/libz.a ,g' -i ${B}/gdb/Makefile
@@ -16,5 +17,4 @@ do_configure_append () {
for SIM in ${B}/sim/*/Makefile; do
[ -f $SIM ] && sed -e 's,-lz, ${STAGING_LIBDIR_NATIVE}/libz.a ,g' -i $SIM
done
- oe_runconf
}