aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-12-10 11:31:25 +0100
committerKoen Kooi <koen@openembedded.org>2009-12-10 11:31:25 +0100
commit848c704c03affb24c5261b11faec74d6ad2374ed (patch)
tree643121809a2ecc3f62a2a655f9215e61af08ac0c
parent6e0172f360053c39bfad106592fbb55509167103 (diff)
downloadopenembedded-848c704c03affb24c5261b11faec74d6ad2374ed.tar.gz
linux-omap 2.6.32: fix problems with SCTP
-rw-r--r--recipes/linux/linux-omap-2.6.32/beagleboard/defconfig35
-rw-r--r--recipes/linux/linux-omap-2.6.32/sctp-fix.patch47
-rw-r--r--recipes/linux/linux-omap_2.6.32.bb1
3 files changed, 77 insertions, 6 deletions
diff --git a/recipes/linux/linux-omap-2.6.32/beagleboard/defconfig b/recipes/linux/linux-omap-2.6.32/beagleboard/defconfig
index c22fc99949..29082720f6 100644
--- a/recipes/linux/linux-omap-2.6.32/beagleboard/defconfig
+++ b/recipes/linux/linux-omap-2.6.32/beagleboard/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.32
-# Wed Dec 9 16:04:50 2009
+# Thu Dec 10 10:50:29 2009
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -519,7 +519,7 @@ CONFIG_NF_CONNTRACK_MARK=y
CONFIG_NF_CONNTRACK_EVENTS=y
CONFIG_NF_CT_PROTO_DCCP=m
CONFIG_NF_CT_PROTO_GRE=m
-# CONFIG_NF_CT_PROTO_SCTP is not set
+CONFIG_NF_CT_PROTO_SCTP=m
CONFIG_NF_CT_PROTO_UDPLITE=m
CONFIG_NF_CONNTRACK_AMANDA=m
CONFIG_NF_CONNTRACK_FTP=m
@@ -573,7 +573,7 @@ CONFIG_NETFILTER_XT_MATCH_RATEEST=m
CONFIG_NETFILTER_XT_MATCH_REALM=m
CONFIG_NETFILTER_XT_MATCH_RECENT=m
# CONFIG_NETFILTER_XT_MATCH_RECENT_PROC_COMPAT is not set
-# CONFIG_NETFILTER_XT_MATCH_SCTP is not set
+CONFIG_NETFILTER_XT_MATCH_SCTP=m
CONFIG_NETFILTER_XT_MATCH_STATE=m
CONFIG_NETFILTER_XT_MATCH_STATISTIC=m
CONFIG_NETFILTER_XT_MATCH_STRING=m
@@ -639,6 +639,7 @@ CONFIG_NF_NAT_SNMP_BASIC=m
CONFIG_NF_NAT_PROTO_DCCP=m
CONFIG_NF_NAT_PROTO_GRE=m
CONFIG_NF_NAT_PROTO_UDPLITE=m
+CONFIG_NF_NAT_PROTO_SCTP=m
CONFIG_NF_NAT_FTP=m
CONFIG_NF_NAT_IRC=m
CONFIG_NF_NAT_TFTP=m
@@ -676,8 +677,28 @@ CONFIG_IP6_NF_TARGET_REJECT=m
CONFIG_IP6_NF_MANGLE=m
CONFIG_IP6_NF_RAW=m
# CONFIG_BRIDGE_NF_EBTABLES is not set
-# CONFIG_IP_DCCP is not set
-# CONFIG_IP_SCTP is not set
+CONFIG_IP_DCCP=m
+CONFIG_INET_DCCP_DIAG=m
+
+#
+# DCCP CCIDs Configuration (EXPERIMENTAL)
+#
+# CONFIG_IP_DCCP_CCID2_DEBUG is not set
+CONFIG_IP_DCCP_CCID3=y
+# CONFIG_IP_DCCP_CCID3_DEBUG is not set
+CONFIG_IP_DCCP_CCID3_RTO=100
+CONFIG_IP_DCCP_TFRC_LIB=y
+
+#
+# DCCP Kernel Hacking
+#
+# CONFIG_IP_DCCP_DEBUG is not set
+CONFIG_IP_SCTP=m
+# CONFIG_SCTP_DBG_MSG is not set
+# CONFIG_SCTP_DBG_OBJCNT is not set
+# CONFIG_SCTP_HMAC_NONE is not set
+# CONFIG_SCTP_HMAC_SHA1 is not set
+CONFIG_SCTP_HMAC_MD5=y
# CONFIG_RDS is not set
CONFIG_TIPC=m
# CONFIG_TIPC_ADVANCED is not set
@@ -2437,6 +2458,7 @@ CONFIG_GFS2_FS=m
# CONFIG_GFS2_FS_LOCKING_DLM is not set
CONFIG_OCFS2_FS=m
CONFIG_OCFS2_FS_O2CB=m
+CONFIG_OCFS2_FS_USERSPACE_CLUSTER=m
CONFIG_OCFS2_FS_STATS=y
CONFIG_OCFS2_DEBUG_MASKLOG=y
# CONFIG_OCFS2_DEBUG_FS is not set
@@ -2658,7 +2680,8 @@ CONFIG_NLS_ISO8859_15=m
CONFIG_NLS_KOI8_R=m
CONFIG_NLS_KOI8_U=m
CONFIG_NLS_UTF8=y
-# CONFIG_DLM is not set
+CONFIG_DLM=m
+# CONFIG_DLM_DEBUG is not set
#
# Kernel hacking
diff --git a/recipes/linux/linux-omap-2.6.32/sctp-fix.patch b/recipes/linux/linux-omap-2.6.32/sctp-fix.patch
new file mode 100644
index 0000000000..fad8e1b67b
--- /dev/null
+++ b/recipes/linux/linux-omap-2.6.32/sctp-fix.patch
@@ -0,0 +1,47 @@
+From patchwork Tue Dec 8 19:52:09 2009
+Content-Type: text/plain; charset="utf-8"
+MIME-Version: 1.0
+Content-Transfer-Encoding: 7bit
+Subject: net/sctp/sysctl.c: Remove dead strategy handler
+Date: Tue, 08 Dec 2009 19:52:09 -0000
+From: Ingo Molnar <mingo@elte.hu>
+X-Patchwork-Id: 65744
+
+* Ingo Molnar <mingo@elte.hu> wrote:
+
+> hi Dave,
+>
+> i just switched to today's -git tree and there's this new build failure
+> on x86:
+>
+> net/sctp/sysctl.c:251: error: unknown field 'strategy' specified in initializer
+> net/sctp/sysctl.c:251: error: 'sysctl_intvec' undeclared here (not in a function)
+>
+> havent looked into it yet - config attached.
+
+That's interaction with the strategy handler removal from Eric. I think
+the patch below will do the trick - the callsites have been updated
+already to use proc_handler, so ->handler was a dead field.
+
+ Ingo
+
+Signed-off-by: Ingo Molnar <mingo@elte.hu>
+
+---
+To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
+the body of a message to majordomo@vger.kernel.org
+More majordomo info at http://vger.kernel.org/majordomo-info.html
+Please read the FAQ at http://www.tux.org/lkml/
+
+diff --git a/net/sctp/sysctl.c b/net/sctp/sysctl.c
+index 419e1e9..832590b 100644
+--- a/net/sctp/sysctl.c
++++ b/net/sctp/sysctl.c
+@@ -248,7 +248,6 @@ static ctl_table sctp_table[] = {
+ .maxlen = sizeof(int),
+ .mode = 0644,
+ .proc_handler = &proc_dointvec_minmax,
+- .strategy = &sysctl_intvec,
+ .extra1 = &one,
+ .extra2 = &rwnd_scale_max,
+ },
diff --git a/recipes/linux/linux-omap_2.6.32.bb b/recipes/linux/linux-omap_2.6.32.bb
index 71405b7f63..83c326a76a 100644
--- a/recipes/linux/linux-omap_2.6.32.bb
+++ b/recipes/linux/linux-omap_2.6.32.bb
@@ -17,6 +17,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.g
file://defconfig"
SRC_URI_append = " \
+file://sctp-fix.patch;patch=1 \
file://cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch;patch=1 \
file://cm-t35/0001-OMAP-DSS2-add-Toppoly-TDO35S-panel.patch;patch=1 \
file://cm-t35/0002-omap3-cm-t35-add-DSS2-display-support.patch;patch=1 \