aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonrad Mattheis <mattheis@ukma.de>2009-09-27 22:10:13 +0000
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-10-09 15:15:01 +0200
commit0fe7e7da98b3d84a584a04821b8503c3c408f523 (patch)
treeca66380246a20b2b434888f5636ea1f770e256d3
parent30a06f663f341086400aef4be1bfb66babb988ec (diff)
downloadopenembedded-0fe7e7da98b3d84a584a04821b8503c3c408f523.tar.gz
u-boot 2009.08
Hi, I have this patch to get the new Version of u-boot working. Please could you apply this an the repository or tell me how I can do this. bye Konrad Mattheis Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/u-boot/u-boot_2009.06.bb1
-rw-r--r--recipes/u-boot/u-boot_2009.08.bb16
3 files changed, 20 insertions, 1 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 654bec1eb6..106c479d5e 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -29386,3 +29386,7 @@ sha256=f57c4e33eb2cdd87a6c2f01bfa4794340fbe61ea1a1cfc7dac3b6671e1dd22af
md5=5f7b88ebb2bcd7e8044328482d079661
sha256=f57c4e33eb2cdd87a6c2f01bfa4794340fbe61ea1a1cfc7dac3b6671e1dd22af
+[ftp://ftp.denx.de/pub/u-boot/u-boot-2009.08.tar.bz2]
+md5=cd4788ea1c6ac4f9b100b888a1063a6b
+sha256=858fd04efd5b98e99fd1a074998b1a8ac5fbd07b176de1d20d8eb148492d949d
+
diff --git a/recipes/u-boot/u-boot_2009.06.bb b/recipes/u-boot/u-boot_2009.06.bb
index cefbed21f8..3ea182a15f 100644
--- a/recipes/u-boot/u-boot_2009.06.bb
+++ b/recipes/u-boot/u-boot_2009.06.bb
@@ -3,7 +3,6 @@ require u-boot.inc
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_mpc8315e-rdb = "1"
-DEFAULT_PREFERENCE_at91sam9g20ek = "1"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 "
diff --git a/recipes/u-boot/u-boot_2009.08.bb b/recipes/u-boot/u-boot_2009.08.bb
new file mode 100644
index 0000000000..d0e387cd03
--- /dev/null
+++ b/recipes/u-boot/u-boot_2009.08.bb
@@ -0,0 +1,16 @@
+PR = "r0"
+require u-boot.inc
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_at91sam9g20ek = "1"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 "
+
+TARGET_LDFLAGS = ""
+
+inherit base
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake all
+}