aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-11 16:19:06 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-11 16:19:06 +0100
commitf8d4b8781f2b228754a448289f5b2a97844f50bc (patch)
tree4bbcce97f5e3445c908dd00bbe8a51a1f399e2bd
parentc64ada5c2865a4b3f84ca64f4515034e215a86dd (diff)
downloadopenembedded-f8d4b8781f2b228754a448289f5b2a97844f50bc.tar.gz
mtd-utils: add 1.2.0+git for ubifs-support
* no -native version added yet
-rw-r--r--packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git-2.patch101
-rw-r--r--packages/mtd/mtd-utils/lzo_1x-git.patch13
-rw-r--r--packages/mtd/mtd-utils_1.2.0+git.bb92
3 files changed, 206 insertions, 0 deletions
diff --git a/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git-2.patch b/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git-2.patch
new file mode 100644
index 0000000000..fb776fddce
--- /dev/null
+++ b/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git-2.patch
@@ -0,0 +1,101 @@
+--- /tmp/mkfs.jffs2.c 2009-01-11 15:28:41.000000000 +0100
++++ git/mkfs.jffs2.c 2009-01-11 15:59:29.000000000 +0100
+@@ -100,6 +100,11 @@
+ struct rb_node hardlink_rb;
+ };
+
++struct ignorepath_entry {
++ struct ignorepath_entry* next; /* Points to the next ignorepath element */
++ char name[PATH_MAX]; /* Name of the entry */
++};
++static struct ignorepath_entry* ignorepath = 0;
+ struct rb_root hardlinks;
+ static int out_fd = -1;
+ static int in_fd = -1;
+@@ -408,7 +413,7 @@
+ char *hpath, *tpath;
+ struct dirent *dp, **namelist;
+ struct filesystem_entry *entry;
+-
++ struct ignorepath_entry* element = ignorepath;
+
+ if (lstat(hostpath, &sb)) {
+ perror_msg_and_die("%s", hostpath);
+@@ -417,6 +422,15 @@
+ entry = add_host_filesystem_entry(targetpath, hostpath,
+ sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
+
++ while ( element ) {
++ if ( strcmp( element->name, targetpath ) == 0 ) {
++ printf( "Note: ignoring directories below '%s'\n", targetpath );
++ return entry;
++ break;
++ }
++ element = element->next;
++ }
++
+ n = scandir(hostpath, &namelist, 0, alphasort);
+ if (n < 0) {
+ perror_msg_and_die("opening directory %s", hostpath);
+@@ -1453,6 +1467,7 @@
+ {"root", 1, NULL, 'r'},
+ {"pagesize", 1, NULL, 's'},
+ {"eraseblock", 1, NULL, 'e'},
++ {"ignore", 1, NULL, 'I'},
+ {"output", 1, NULL, 'o'},
+ {"help", 0, NULL, 'h'},
+ {"verbose", 0, NULL, 'v'},
+@@ -1500,6 +1515,7 @@
+ " -L, --list-compressors Show the list of the avaiable compressors\n"
+ " -t, --test-compression Call decompress and compare with the original (for test)\n"
+ " -n, --no-cleanmarkers Don't add a cleanmarker to every eraseblock\n"
++" -I, --ignore=PATH Ignore sub directory and file tree below PATH when recursing over the file system\n"
+ " -o, --output=FILE Output to FILE (default: stdout)\n"
+ " -l, --little-endian Create a little-endian filesystem\n"
+ " -b, --big-endian Create a big-endian filesystem\n"
+@@ -1666,6 +1682,7 @@
+ char *compr_name = NULL;
+ int compr_prior = -1;
+ int warn_page_size = 0;
++ struct ignorepath_entry* element = ignorepath;
+
+ page_size = sysconf(_SC_PAGESIZE);
+ if (page_size < 0) /* System doesn't know so ... */
+@@ -1676,7 +1693,7 @@
+ jffs2_compressors_init();
+
+ while ((opt = getopt_long(argc, argv,
+- "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
++ "D:d:r:s:I:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
+ {
+ switch (opt) {
+ case 'D':
+@@ -1700,6 +1717,28 @@
+ warn_page_size = 0; /* set by user, so don't need to warn */
+ break;
+
++ case 'I':
++ printf( "Note: Adding '%s' to ignore Path\n", optarg );
++ element = ignorepath;
++ if ( !ignorepath ) {
++ ignorepath = xmalloc( sizeof( struct ignorepath_entry ) );
++ ignorepath->next = 0;
++ strcpy( &ignorepath->name[0], optarg );
++ } else {
++ while ( element->next ) element = element->next;
++ element->next = xmalloc( sizeof( struct ignorepath_entry ) );
++ element->next->next = 0;
++ strcpy( &element->next->name[0], optarg );
++ }
++ printf( "--------- Dumping ignore path list ----------------\n" );
++ element = ignorepath;
++ while ( element ) {
++ printf( " * '%s'\n", &element->name[0] );
++ element = element->next;
++ }
++ printf( "---------------------------------------------------\n" );
++ break;
++
+ case 'o':
+ if (out_fd != -1) {
+ error_msg_and_die("output filename specified more than once");
diff --git a/packages/mtd/mtd-utils/lzo_1x-git.patch b/packages/mtd/mtd-utils/lzo_1x-git.patch
new file mode 100644
index 0000000000..e5306875da
--- /dev/null
+++ b/packages/mtd/mtd-utils/lzo_1x-git.patch
@@ -0,0 +1,13 @@
+Index: git/compr_lzo.c
+===================================================================
+--- git.orig/compr_lzo.c
++++ git/compr_lzo.c
+@@ -26,7 +26,7 @@
+ #include <string.h>
+ #include <asm/types.h>
+ #include <linux/jffs2.h>
+-#include <lzo/lzo1x.h>
++#include <lzo1x.h>
+ #include "compr.h"
+
+ extern int page_size;
diff --git a/packages/mtd/mtd-utils_1.2.0+git.bb b/packages/mtd/mtd-utils_1.2.0+git.bb
new file mode 100644
index 0000000000..2815aed5bd
--- /dev/null
+++ b/packages/mtd/mtd-utils_1.2.0+git.bb
@@ -0,0 +1,92 @@
+DESCRIPTION = "Tools for managing memory technology devices."
+SECTION = "base"
+DEPENDS = "zlib lzo"
+HOMEPAGE = "http://www.linux-mtd.infradead.org/"
+LICENSE = "GPLv2"
+PR = "r0"
+
+# This is the default package, thus we lock to a specific git version so
+# upstream changes will not break builds.
+
+TAG = "149d3c8ac8d32c05836ed8add1324561ce0952ad"
+
+SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG} \
+ file://add-exclusion-to-mkfs-jffs2-git-2.patch;patch=1 \
+ file://fix-ignoreerrors-git.patch;patch=1 \
+ file://lzo_1x-git.patch;patch=1"
+
+S = "${WORKDIR}/git/"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR'"
+
+do_configure_prepend() {
+ for i in $(find . -name "Makefile") ; do
+ sed -i -e s:lzo2:lzo:g $i
+ done
+ sed -i -e s:lzo/::g mkfs.ubifs/compr.c
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/mtd
+ for f in ${S}/include/mtd/*.h; do
+ install -m 0644 $f ${STAGING_INCDIR}/mtd/
+ done
+ for binary in ${mtd_utils}; do
+ install -m 0755 $binary ${STAGING_BINDIR}
+ done
+}
+
+mtd_utils = " docfdisk \
+ docfdisk \
+ doc_loadbios \
+ flashcp \
+ flash_erase \
+ flash_eraseall \
+ flash_info \
+ flash_lock \
+ flash_otp_dump \
+ flash_otp_info \
+ flash_unlock \
+ ftl_check \
+ ftl_format \
+ jffs2dump \
+ mkfs.jffs2 \
+ mtd_debug \
+ nanddump \
+ nandtest \
+ nandwrite \
+ nftldump \
+ nftl_format \
+ recv_image \
+ rfddump \
+ rfdformat \
+ serve_image \
+ sumtool \
+ mkfs.ubifs/mkfs.ubifs \
+ ubi-utils/bin2nand \
+ ubi-utils/mkbootenv \
+ ubi-utils/nand2bin \
+ ubi-utils/pddcustomize \
+ ubi-utils/pfi2bin \
+ ubi-utils/pfiflash \
+ ubi-utils/ubigen \
+ ubi-utils/ubimirror \
+ ubi-utils/unubi"
+
+
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}${includedir}/mtd
+ for binary in ${mtd_utils}; do
+ install -m 0755 $binary ${D}${bindir}
+ done
+ for f in ${S}/include/mtd/*.h; do
+ install -m 0644 $f ${D}${includedir}/mtd
+ done
+}
+
+PACKAGES =+ "mkfs-jffs mkfs-jffs2"
+FILES_mkfs-jffs = "${bindir}/mkfs.jffs"
+FILES_mkfs-jffs2 = "${bindir}/mkfs.jffs2"
+