aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-11 19:07:32 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-11 19:07:32 +0100
commit49cc2f74567ecabb2f08a623ea58538788464db1 (patch)
tree2f16f7427ef878d2c0892cced0da948b1a5b7eaf
parenta6a6f337228f918e80a99240dfaa2dd4f27c1b81 (diff)
downloadopenembedded-49cc2f74567ecabb2f08a623ea58538788464db1.tar.gz
linux-omap-pm git: add patch to add rate tables to beagleboard board file
-rw-r--r--packages/linux/linux-omap-pm/beagle-cpufreq.diff84
-rw-r--r--packages/linux/linux-omap-pm_git.bb5
2 files changed, 87 insertions, 2 deletions
diff --git a/packages/linux/linux-omap-pm/beagle-cpufreq.diff b/packages/linux/linux-omap-pm/beagle-cpufreq.diff
new file mode 100644
index 0000000000..f56b27781d
--- /dev/null
+++ b/packages/linux/linux-omap-pm/beagle-cpufreq.diff
@@ -0,0 +1,84 @@
+--- /tmp/board-omap3beagle.c 2009-01-11 18:41:58.000000000 +0100
++++ git/arch/arm/mach-omap2/board-omap3beagle.c 2009-01-11 18:47:03.000000000 +0100
+@@ -41,12 +41,71 @@
+ #include <mach/usb-ehci.h>
+ #include <mach/common.h>
+ #include <mach/gpmc.h>
++#include <mach/omap-pm.h>
+ #include <mach/nand.h>
+ #include <mach/mux.h>
++#include <mach/clock.h>
++
+
+ #include "twl4030-generic-scripts.h"
+ #include "mmc-twl4030.h"
++#include "pm.h"
++
++/* MPU speeds */
++#define S600M 600000000
++#define S550M 550000000
++#define S500M 500000000
++#define S250M 250000000
++#define S125M 125000000
++
++/* DSP speeds */
++#define S430M 430000000
++#define S400M 400000000
++#define S360M 360000000
++#define S180M 180000000
++#define S90M 90000000
++
++/* L3 speeds */
++#define S83M 83000000
++#define S166M 166000000
++
++static struct omap_opp mpu_rate_table[] = {
++ {0, 0, 0},
++ /*OPP1*/
++ {S125M, VDD1_OPP1, 0x18},
++ /*OPP2*/
++ {S250M, VDD1_OPP2, 0x20},
++ /*OPP3*/
++ {S500M, VDD1_OPP3, 0x30},
++ /*OPP4*/
++ {S550M, VDD1_OPP4, 0x36},
++ /*OPP5*/
++ {S600M, VDD1_OPP5, 0x3C},
++};
+
++static struct omap_opp l3_rate_table[] = {
++ {0, 0, 0},
++ /*OPP1*/
++ {0, VDD2_OPP1, 0x18},
++ /*OPP2*/
++ {S83M, VDD2_OPP2, 0x20},
++ /*OPP3*/
++ {S166M, VDD2_OPP3, 0x2C},
++};
++
++struct omap_opp dsp_rate_table[] = {
++ {0, 0, 0},
++ /*OPP1*/
++ {S90M, VDD1_OPP1, 0x18},
++ /*OPP2*/
++ {S180M, VDD1_OPP2, 0x20},
++ /*OPP3*/
++ {S360M, VDD1_OPP3, 0x30},
++ /*OPP4*/
++ {S400M, VDD1_OPP4, 0x36},
++ /*OPP5*/
++ {S430M, VDD1_OPP5, 0x3C},
++};
+
+ #define GPMC_CS0_BASE 0x60
+ #define GPMC_CS_SIZE 0x30
+@@ -233,7 +292,8 @@
+
+ static void __init omap3_beagle_init_irq(void)
+ {
+- omap2_init_common_hw(mt46h32m32lf6_sdrc_params, NULL, NULL, NULL);
++ omap2_init_common_hw(mt46h32m32lf6_sdrc_params, mpu_rate_table,
++ dsp_rate_table, l3_rate_table);
+ omap_init_irq();
+ omap_gpio_init();
+ }
diff --git a/packages/linux/linux-omap-pm_git.bb b/packages/linux/linux-omap-pm_git.bb
index bc9221a050..f3af9dd61c 100644
--- a/packages/linux/linux-omap-pm_git.bb
+++ b/packages/linux/linux-omap-pm_git.bb
@@ -9,8 +9,8 @@ DEFAULT_PREFERENCE = "-1"
SRCREV = "b5d11429ffe91c26903ff206e4c7ce5dd3ec4806"
-PV = "2.6.28"
-PR = "r5"
+PV = "2.6.28-pm1+gitr${SRCREV}"
+PR = "r6"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;protocol=git;branch=pm-next \
file://defconfig"
@@ -43,6 +43,7 @@ SRC_URI_append = " \
# file://0010-DSS-OMAPFB-remove-extra-omapfb_setup_overlay-call.patch;patch=1 \
# file://0011-DSS-OMAPFB-fix-GFX_SYNC-to-be-compatible-with-DSS1.patch;patch=1 \
file://0001-ASoC-Add-support-for-OMAP3-EVM.patch;patch=1 \
+ file://beagle-cpufreq.diff;patch=1 \
"