aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-08 00:04:08 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-08 00:04:08 +0100
commitbbbf56d7c111a4a8f6162803675be1feb74b0084 (patch)
tree076111f0ec5d49740dcbee8c5004835b7ca7f325
parent6d843b2fba50b876f1b75c050c18122b1c076607 (diff)
downloadopenembedded-bbbf56d7c111a4a8f6162803675be1feb74b0084.tar.gz
linux-omap 2.6.27: fix NAND access
-rw-r--r--packages/linux/linux-omap-2.6.27/nand.patch35
-rw-r--r--packages/linux/linux-omap_2.6.27.bb3
2 files changed, 37 insertions, 1 deletions
diff --git a/packages/linux/linux-omap-2.6.27/nand.patch b/packages/linux/linux-omap-2.6.27/nand.patch
new file mode 100644
index 0000000000..a5e942c8f9
--- /dev/null
+++ b/packages/linux/linux-omap-2.6.27/nand.patch
@@ -0,0 +1,35 @@
+On Fri, Nov 7, 2008 at 1:30 PM, David Brownell <david-b@pacbell.net> wrote:
+> On Friday 07 November 2008, Steve Sakoman wrote:
+>> On Fri, Nov 7, 2008 at 12:46 PM, David Brownell <david-b@pacbell.net> wrote:
+>> > On Friday 07 November 2008, Steve Sakoman wrote:
+>> >> I'm having little success. It used to work back in 2.6.26 timeframe
+>> >> but seems to have broken sometime during 2.6.27.
+>> >
+>> > There's a patch floating around making the omap2 NAND driver
+>> > use readsw not readsl, which might explain that problem...
+>>
+>> Do you recall where you saw that patch? Here or linux-mtd? My
+>> initial search efforts weren't successful.
+>
+> On linux-omap. Or just look at the driver to see the
+> readsl()... it's a one-liner.
+
+Yes, that one line change did indeed fix the issue!
+
+Is that patch currently in the queue somewhere?
+
+For the record:
+
+diff --git a/drivers/mtd/nand/omap2.c b/drivers/mtd/nand/omap2.c
+index 2ede116..d18a8c9 100644
+--- a/drivers/mtd/nand/omap2.c
++++ b/drivers/mtd/nand/omap2.c
+@@ -196,7 +196,7 @@ static void omap_read_buf16(struct mtd_info *mtd, u_char *buf, int len)
+ {
+ struct nand_chip *nand = mtd->priv;
+
+- __raw_readsl(nand->IO_ADDR_R, buf, len / 2);
++ readsw(nand->IO_ADDR_R, buf, len / 2);
+ }
+
+ /*
diff --git a/packages/linux/linux-omap_2.6.27.bb b/packages/linux/linux-omap_2.6.27.bb
index 26b0994ec2..6aed140a9b 100644
--- a/packages/linux/linux-omap_2.6.27.bb
+++ b/packages/linux/linux-omap_2.6.27.bb
@@ -6,7 +6,7 @@ KERNEL_IMAGETYPE = "uImage"
COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm"
SRCREV = "2a3408be17f287fdb5809c9b6c68e7ad96d25b74"
-PR = "r10"
+PR = "r11"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
file://defconfig"
@@ -38,6 +38,7 @@ SRC_URI_append = " \
# file://openvz/0004-arm-add-openvz-and-bc-Kconfigs.patch;patch=1 \
# file://openvz/openvz-2.6.27.diff;patch=1 \
file://sitecomwl168-support.diff;patch=1 \
+ file://nand.patch;patch=1 \
"