aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-06 19:41:33 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-06 19:41:33 +0100
commit785b8609e69082befd9a3a4a6f369d2101b1b884 (patch)
treefb201c4e89499a8d0ec2549d5b3463b62b06b152
parent993b786f90067323d6a2daf0ffa8746414c41655 (diff)
downloadopenembedded-785b8609e69082befd9a3a4a6f369d2101b1b884.tar.gz
omap3-sgx-modules: recipe to build sgx modules using the kbuild system from the GPL'ed imgtec sources
-rw-r--r--packages/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb b/packages/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb
new file mode 100644
index 0000000000..afed44182d
--- /dev/null
+++ b/packages/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://dominion.thruhere.net/koen/OE/omap3-sgx-modules-1.3.13.1397.tar.bz2"
+
+S = ${WORKDIR}/${PN}-${PV}/eurasiacon/build/linux/omap3430_linux/kbuild/
+
+MAKE_TARGETS = "BUILD=debug"
+
+do_install() {
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/drivers/gpu
+ cp ${WORKDIR}/${PN}-${PV}/eurasiacon/binary_omap3430_linux_debug/*.ko ${D}/lib/modules/${KERNEL_VERSION}/drivers/gpu
+}