aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Lübbe <jluebbe@debian.org>2009-03-20 11:28:41 +0000
committerJan Luebbe <jluebbe@debian.org>2009-03-26 11:34:35 +0100
commite4a3efd8080835c1013cf7e9a34fe8242d883a90 (patch)
tree904311c7c14618648e614327107ae145a84f76d8
parent74a53e093a52c80b85005c1e77a46523379e0005 (diff)
downloadopenembedded-e4a3efd8080835c1013cf7e9a34fe8242d883a90.tar.gz
openobex: add version 1.5
-rw-r--r--conf/checksums.ini4
-rw-r--r--conf/distro/include/preferred-om-2008-versions.inc2
-rw-r--r--recipes/openobex/openobex-1.5/libusb_crosscompile_check.patch12
-rw-r--r--recipes/openobex/openobex_1.5.bb28
4 files changed, 45 insertions, 1 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 77b63a75cf..6c09dd71b5 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -17250,6 +17250,10 @@ sha256=3a80ba2524c66a46db3ac17a788a759015a1f79de6a495fcdf3a316e19fe7c23
md5=feaa5dfe5151c0e70e8f868fa4648a43
sha256=3a80ba2524c66a46db3ac17a788a759015a1f79de6a495fcdf3a316e19fe7c23
+[http://www.kernel.org/pub/linux/bluetooth/openobex-1.5.tar.gz]
+md5=0d83dc86445a46a1b9750107ba7ab65c
+sha256=e602047570799a47ecb028420bda8f2cef41310e5a99d084de10aa9422935e65
+
[http://www.openpbx.org/releases/openpbx.org-1.2_rc3.tar.gz]
md5=e270c40626dfa2131cc39dd1352b46f9
sha256=934e1e5438c46927236f1f3254265e94c7e38e7c0e02d92abb7efc4e03ce91e9
diff --git a/conf/distro/include/preferred-om-2008-versions.inc b/conf/distro/include/preferred-om-2008-versions.inc
index 55d5136090..fd7367e53d 100644
--- a/conf/distro/include/preferred-om-2008-versions.inc
+++ b/conf/distro/include/preferred-om-2008-versions.inc
@@ -1365,7 +1365,7 @@ PREFERRED_VERSION_openjade ?= "1.3.2"
PREFERRED_VERSION_openjade-native ?= "1.3.2"
PREFERRED_VERSION_openldap ?= "2.3.11"
PREFERRED_VERSION_openntpd ?= "3.9p1"
-PREFERRED_VERSION_openobex ?= "1.3"
+PREFERRED_VERSION_openobex ?= "1.5"
PREFERRED_VERSION_openpbx.org ?= "1.2_rc3"
PREFERRED_VERSION_openpbx.org-perl ?= "1.0"
PREFERRED_VERSION_openprotium-init ?= "0.10"
diff --git a/recipes/openobex/openobex-1.5/libusb_crosscompile_check.patch b/recipes/openobex/openobex-1.5/libusb_crosscompile_check.patch
new file mode 100644
index 0000000000..23e5cc4591
--- /dev/null
+++ b/recipes/openobex/openobex-1.5/libusb_crosscompile_check.patch
@@ -0,0 +1,12 @@
+diff -Nurd openobex-1.5.old/acinclude.m4 openobex-1.5/acinclude.m4
+--- openobex-1.5.old/acinclude.m4 2009-02-08 18:30:22.000000000 +0000
++++ openobex-1.5/acinclude.m4 2009-03-20 11:23:50.000000000 +0000
+@@ -158,7 +158,7 @@
+ ;;
+ *)
+ PKG_CHECK_MODULES(USB, libusb, usb_lib_found=yes, AC_MSG_RESULT(no))
+- AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="libusb")
++ REQUIRES="libusb"
+ ;;
+ esac
+ AC_SUBST(USB_CFLAGS)
diff --git a/recipes/openobex/openobex_1.5.bb b/recipes/openobex/openobex_1.5.bb
new file mode 100644
index 0000000000..d244ceccef
--- /dev/null
+++ b/recipes/openobex/openobex_1.5.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb bluez-libs"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch;patch=1 \
+ file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+do_stage() {
+ autotools_stage_all
+}
+
+# how to stop shlibrename from renaming -apps?
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"