aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Lapin <slapin@ossfans.org>2009-01-29 16:23:36 +0300
committerSergey Lapin <slapin@ossfans.org>2009-01-29 18:37:37 +0300
commit54f043bf3da95b7016a7472a900a53973d391cb2 (patch)
tree248b489d898d8b159c09c7c6243372e32f37d502
parent6ab33b8447162215586baa89dcb69edce529f2ac (diff)
downloadopenembedded-54f043bf3da95b7016a7472a900a53973d391cb2.tar.gz
wireshark/tshark: extracted common parts
-rw-r--r--packages/wireshark/tshark_0.99.4.bb20
-rw-r--r--packages/wireshark/wireshark.inc20
-rw-r--r--packages/wireshark/wireshark_0.99.4.bb20
3 files changed, 24 insertions, 36 deletions
diff --git a/packages/wireshark/tshark_0.99.4.bb b/packages/wireshark/tshark_0.99.4.bb
index e63a0c2f23..b7fe2afeed 100644
--- a/packages/wireshark/tshark_0.99.4.bb
+++ b/packages/wireshark/tshark_0.99.4.bb
@@ -1,23 +1,5 @@
DESCRIPTION = "tshark is the text based verion of wireshark - a popular network protocol analyzer"
-HOMEPAGE = "http://www.ethereal.com"
-SECTION = "network"
-LICENSE = "GPL"
-DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 net-snmp"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
- file://use-our-lemon.patch;patch=1 \
- file://acinclude-net-snmp-fix.patch;patch=1 \
- file://libtool-fix.patch;patch=1 \
- file://no-host-includes.patch;patch=1"
-
-S=${WORKDIR}/wireshark-${PV}
-
-inherit autotools
+require wireshark.inc
EXTRA_OECONF = "--disable-wireshark --with-net-snmp=${STAGING_DIR_HOST}${layout_bindir}/net-snmp-config"
-do_compile_prepend() {
- ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
- oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
-}
-
diff --git a/packages/wireshark/wireshark.inc b/packages/wireshark/wireshark.inc
new file mode 100644
index 0000000000..13715ea273
--- /dev/null
+++ b/packages/wireshark/wireshark.inc
@@ -0,0 +1,20 @@
+HOMEPAGE = "http://www.wireshark.org"
+SECTION = "network"
+LICENSE = "GPL"
+DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 net-snmp"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
+ file://use-our-lemon.patch;patch=1 \
+ file://acinclude-net-snmp-fix.patch;patch=1 \
+ file://libtool-fix.patch;patch=1 \
+ file://no-host-includes.patch;patch=1"
+
+S=${WORKDIR}/wireshark-${PV}
+
+inherit autotools
+
+do_compile_prepend() {
+ ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
+ oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
+}
+
diff --git a/packages/wireshark/wireshark_0.99.4.bb b/packages/wireshark/wireshark_0.99.4.bb
index 357f26448c..f4c90fce48 100644
--- a/packages/wireshark/wireshark_0.99.4.bb
+++ b/packages/wireshark/wireshark_0.99.4.bb
@@ -1,23 +1,9 @@
-DESCRIPTION = "Ethereal is the world's most popular network protocol analyzer"
-HOMEPAGE = "http://www.ethereal.com"
-SECTION = "x11/network"
-LICENSE = "GPL"
-DEPENDS = "perl-native gtk+ gnutls libpcap pcre expat"
+DESCRIPTION = "Wireshark is the world's most popular network protocol analyzer"
+require wireshark.inc
+DEPENDS += "gtk+"
PR = "r1"
-SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.bz2 \
- file://use-our-lemon.patch;patch=1 \
- file://acinclude-net-snmp-fix.patch;patch=1 \
- file://libtool-fix.patch;patch=1 \
- file://no-host-includes.patch;patch=1"
-
-inherit autotools
-
-do_compile_prepend() {
- ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
- oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
-}
FILES_${PN}-dbg += "${libdir}/wireshark/plugins/${PV}/.debug"