aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2010-01-27 09:32:44 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-28 14:21:59 +0100
commite9dfa3dc6741c9d2aad74fe1e4061ce9b89e9d0e (patch)
tree42ad337d44807eda4cb6392937a00cea58096e27
parentc9036538c209b019de5bbae066a3a80846a725a2 (diff)
downloadopenembedded-e9dfa3dc6741c9d2aad74fe1e4061ce9b89e9d0e.tar.gz
rt2x00: new recipe for rt3070 version 2.1.2.0
This patch adds support for rt3070 kernel driver, used for example by the new Belkin F6D4050v2 USB WiFi stick. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--recipes/rt2x00/files/add-belkin-F6D4050v2.patch12
-rw-r--r--recipes/rt2x00/files/makefile.patch18
-rw-r--r--recipes/rt2x00/rt3070_2.1.2.bb28
3 files changed, 58 insertions, 0 deletions
diff --git a/recipes/rt2x00/files/add-belkin-F6D4050v2.patch b/recipes/rt2x00/files/add-belkin-F6D4050v2.patch
new file mode 100644
index 0000000000..7454fafbbd
--- /dev/null
+++ b/recipes/rt2x00/files/add-belkin-F6D4050v2.patch
@@ -0,0 +1,12 @@
+Index: 2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/usb_main_dev.c
+===================================================================
+--- 2009_1110_RT3070_Linux_STA_v2.1.2.0.orig/os/linux/usb_main_dev.c 2010-01-23 23:37:09.000000000 +0100
++++ 2009_1110_RT3070_Linux_STA_v2.1.2.0/os/linux/usb_main_dev.c 2010-01-23 23:37:14.000000000 +0100
+@@ -74,6 +74,7 @@
+ {USB_DEVICE(0x5A57,0x0283)}, /* Zinwell 3072 */
+ {USB_DEVICE(0x04BB,0x0945)}, /* I-O DATA 3072 */
+ {USB_DEVICE(0x203D,0x1480)}, /* Encore 3070 */
++ {USB_DEVICE(0x050d,0x935b)}, /* Belkin F6D4050v2 (N150 enhanced) */
+ #endif // RT3070 //
+ { }/* Terminating entry */
+ };
diff --git a/recipes/rt2x00/files/makefile.patch b/recipes/rt2x00/files/makefile.patch
new file mode 100644
index 0000000000..e314d5f085
--- /dev/null
+++ b/recipes/rt2x00/files/makefile.patch
@@ -0,0 +1,18 @@
+Index: 2009_1110_RT3070_Linux_STA_v2.1.2.0/Makefile
+===================================================================
+--- 2009_1110_RT3070_Linux_STA_v2.1.2.0.orig/Makefile 2010-01-23 23:07:42.000000000 +0100
++++ 2009_1110_RT3070_Linux_STA_v2.1.2.0/Makefile 2010-01-23 23:08:02.000000000 +0100
+@@ -149,11 +149,11 @@
+ ifneq (,$(findstring 2.4,$(LINUX_SRC)))
+ cp -f os/linux/Makefile.4 $(RT28xx_DIR)/os/linux/Makefile
+ make -C $(RT28xx_DIR)/os/linux/
+- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.o /tftpboot
++ cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.o $(RT28xx_DIR)
+ else
+ cp -f os/linux/Makefile.6 $(RT28xx_DIR)/os/linux/Makefile
+ make -C $(LINUX_SRC) SUBDIRS=$(RT28xx_DIR)/os/linux modules
+- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
++ cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko $(RT28xx_DIR)
+ endif
+
+ clean:
diff --git a/recipes/rt2x00/rt3070_2.1.2.bb b/recipes/rt2x00/rt3070_2.1.2.bb
new file mode 100644
index 0000000000..16ad6a0690
--- /dev/null
+++ b/recipes/rt2x00/rt3070_2.1.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Driver for Ralink rt3070 USB 802.11abgn WiFi sticks"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+PR = "r0"
+
+TMP = "2009_1110_RT3070_Linux_STA_v${PV}.0"
+
+SRC_URI = "http://ynezz.ibawizard.net/dump/${TMP}.tar.bz2;name=tarball \
+ file://makefile.patch;patch=1 \
+ file://add-belkin-F6D4050v2.patch;patch=1 \
+"
+
+SRC_URI[tarball.md5sum] = "01a4d6804fff2a76584d20f7c21b1af4"
+SRC_URI[tarball.sha256sum] = "46723d7284360435a9d5769ac1f81fb7f6058c393bb0625dc3fa0a2f282feadd"
+
+inherit module
+
+S = "${WORKDIR}/${TMP}"
+
+EXTRA_OEMAKE = "LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/drivers/net/wireless
+ install -d ${D}${sysconfdir}/Wireless/RT2870STA
+ install -m 0644 ${S}/${PN}sta${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/drivers/net/wireless
+ touch ${D}${sysconfdir}/Wireless/RT2870STA/RT2870STA.dat
+}