aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-01-26 11:51:52 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-28 14:21:54 +0100
commit6494f93ae1ea319f23f0b4a8f47e905de12524df (patch)
treef9ab4c89c1dc709573ddc2976534a2880475a199
parenta4b8de91f536c53f7894d0439998e9440d14096a (diff)
downloadopenembedded-6494f93ae1ea319f23f0b4a8f47e905de12524df.tar.gz
small perl initialisation patch
HI all, Attached is a patch for perl to improve initialisation. >From the commit message: Perl file Lib/CPAN/FirstTime.pm can enter a dialog for continent which never ends. This problem is among others sometimes triggered by libxml-namespacesupport-perl_1.10.bb The patch forces the answer for manual configuration to "no" avoiding that we run into this problem As I am not really a perl wiz, I would like some more eyeballs to look at this one. And apologies for not inlining the patch, but gmail wraps and configuring git send-email requires several perl modules that are not on the opensuse feed Appreciated your feedback Frans >From 6e697b10c3d258c0f2bdf5ec1c755e3085e1340d Mon Sep 17 00:00:00 2001 From: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Date: Tue, 26 Jan 2010 22:21:21 +0100 Subject: [PATCH] perl 5.8.8: do not enter manual configuration Perl file Lib/CPAN/FirstTime.pm can enter a dialog for continent which never ends. This problem is among others sometimes triggered by libxml-namespacesupport-perl_1.10.bb The patch forces the answer for manual configuration to "no" avoiding that we run into this problem
-rw-r--r--recipes/perl/perl-5.8.8/firsttime.patch15
-rw-r--r--recipes/perl/perl-native_5.8.8.bb3
-rw-r--r--recipes/perl/perl_5.8.8.bb3
3 files changed, 19 insertions, 2 deletions
diff --git a/recipes/perl/perl-5.8.8/firsttime.patch b/recipes/perl/perl-5.8.8/firsttime.patch
new file mode 100644
index 0000000000..bd09589ce9
--- /dev/null
+++ b/recipes/perl/perl-5.8.8/firsttime.patch
@@ -0,0 +1,15 @@
+Index: perl-5.8.8/lib/CPAN/FirstTime.pm
+===================================================================
+--- perl-5.8.8.orig/lib/CPAN/FirstTime.pm
++++ perl-5.8.8/lib/CPAN/FirstTime.pm
+@@ -68,9 +68,7 @@ dialog anytime later by typing 'o conf i
+
+ ];
+
+- my $manual_conf =
+- ExtUtils::MakeMaker::prompt("Are you ready for manual configuration?",
+- "yes");
++ my $manual_conf = "no";
+ my $fastread;
+ {
+ local $^W;
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index 60a5cf5b0f..a9c66e848c 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -15,7 +15,8 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://native-no-gdbminc.patch;patch=1 \
file://native-perlinc.patch;patch=1 \
file://makedepend-dash.patch;patch=1 \
- file://asm-pageh-fix.patch;patch=1"
+ file://asm-pageh-fix.patch;patch=1 \
+ file://firsttime.patch;patch=1"
S = "${WORKDIR}/perl-${PV}"
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index edd3a83bfb..200e70cce6 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r31"
+PR = "r32"
# Major part of version
PVM = "5.8"
@@ -30,6 +30,7 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://64_debian_enc2xs_inc.patch;patch=1 \
file://asm-pageh-fix.patch;patch=1 \
file://shared-ldflags.patch;patch=1 \
+ file://firsttime.patch;patch=1 \
file://config.sh \
file://config.sh-32 \
file://config.sh-32-le \