aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Lanzendörfer <david.lanzendoerfer@o2s.ch>2009-11-05 12:16:19 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-28 14:21:05 +0100
commit4a6efa52d905669cae63d4b57706143b0d590c78 (patch)
tree46d660f0109920c219f3154fa8aeaf631f03bdfd
parent1149a2f549e91e7344ace8b0ffa7ccd63e87f927 (diff)
downloadopenembedded-4a6efa52d905669cae63d4b57706143b0d590c78.tar.gz
MokoTouch
> Dear David, Hi Mickey > let me encourage you to submit an updated patchset that takes into > account the reviewer's comments. Here is the corrected patch, which will bring the bitbake recipes for MokoTouch into OE. I hope this will be somehow usefull for some of you. > Cheers, dito :) > :M: leviathan commit dff8d20ceb4c304ba3140deefb80310ee92219b1 Author: David Lanzendörfer <david.lanzendoerfer@o2s.ch> Date: Thu Nov 5 23:11:19 2009 +0100 Added MokoTouch recipes (http://th30z.netsons.org/mokotouch/)
-rw-r--r--recipes/mokotouch/mokotouch-apps-customtableview_2.bb24
-rw-r--r--recipes/mokotouch/mokotouch-apps-helloworld_2.bb24
-rw-r--r--recipes/mokotouch/mokotouch-apps-homescreen_2.bb23
-rw-r--r--recipes/mokotouch/mokotouch-apps-testkeyboard_2.bb24
-rw-r--r--recipes/mokotouch/mokotouch-apps-testtableview_2.bb24
-rw-r--r--recipes/mokotouch/mokotouch-apps-webmobile_2.bb24
-rw-r--r--recipes/mokotouch/mokotouch-coreservices-mokotouch_2.bb25
-rw-r--r--recipes/mokotouch/mokotouch-frameworks-uikit_2.bb26
-rw-r--r--recipes/mokotouch/mokotouch.inc16
9 files changed, 210 insertions, 0 deletions
diff --git a/recipes/mokotouch/mokotouch-apps-customtableview_2.bb b/recipes/mokotouch/mokotouch-apps-customtableview_2.bb
new file mode 100644
index 0000000000..da9ff61ba3
--- /dev/null
+++ b/recipes/mokotouch/mokotouch-apps-customtableview_2.bb
@@ -0,0 +1,24 @@
+require mokotouch.inc
+
+DEPENDS = "mokotouch-coreservices-mokotouch"
+
+do_configure(){
+cd ${S}/MokoTouch/Apps/CustomTableView
+rm UIKit.framework
+ln -s "${S}/MokoTouch/Frameworks/UIKit/" UIKit.framework
+${OE_QMAKE_QMAKE} CustomTableView.pro
+}
+
+do_compile(){
+cd ${S}/MokoTouch/Apps/CustomTableView
+oe_runmake
+}
+
+do_install(){
+install -d "${D}/${libdir}"
+install "${S}/MokoTouch/Apps/CustomTableView/BUILD/App/libCustomTableView.so.1.0.0" "${D}/${libdir}/libCustomTableView.so.1.0.0"
+install "${S}/MokoTouch/Apps/CustomTableView/BUILD/App/libCustomTableView.so.1.0.0" "${D}/${libdir}/libCustomTableView.so.1.0"
+install "${S}/MokoTouch/Apps/CustomTableView/BUILD/App/libCustomTableView.so.1.0.0" "${D}/${libdir}/libCustomTableView.so.1"
+install "${S}/MokoTouch/Apps/CustomTableView/BUILD/App/libCustomTableView.so.1.0.0" "${D}/${libdir}/libCustomTableView.so"
+}
+
diff --git a/recipes/mokotouch/mokotouch-apps-helloworld_2.bb b/recipes/mokotouch/mokotouch-apps-helloworld_2.bb
new file mode 100644
index 0000000000..0d42682220
--- /dev/null
+++ b/recipes/mokotouch/mokotouch-apps-helloworld_2.bb
@@ -0,0 +1,24 @@
+require mokotouch.inc
+
+DEPENDS = "mokotouch-coreservices-mokotouch"
+
+do_configure(){
+cd ${S}/MokoTouch/Apps/HelloWorld
+rm UIKit.framework
+ln -s "${S}/MokoTouch/Frameworks/UIKit/" UIKit.framework
+${OE_QMAKE_QMAKE} HelloWorld.pro
+}
+
+do_compile(){
+cd ${S}/MokoTouch/Apps/HelloWorld
+oe_runmake
+}
+
+do_install(){
+install -d "${D}/${libdir}"
+install "${S}/MokoTouch/Apps/HelloWorld/BUILD/App/libHelloWorld.so.1.0.0" "${D}/${libdir}/libHelloWorld.so.1.0.0"
+install "${S}/MokoTouch/Apps/HelloWorld/BUILD/App/libHelloWorld.so.1.0.0" "${D}/${libdir}/libHelloWorld.so.1.0"
+install "${S}/MokoTouch/Apps/HelloWorld/BUILD/App/libHelloWorld.so.1.0.0" "${D}/${libdir}/libHelloWorld.so.1"
+install "${S}/MokoTouch/Apps/HelloWorld/BUILD/App/libHelloWorld.so.1.0.0" "${D}/${libdir}/libHelloWorld.so"
+}
+
diff --git a/recipes/mokotouch/mokotouch-apps-homescreen_2.bb b/recipes/mokotouch/mokotouch-apps-homescreen_2.bb
new file mode 100644
index 0000000000..b58f2785d8
--- /dev/null
+++ b/recipes/mokotouch/mokotouch-apps-homescreen_2.bb
@@ -0,0 +1,23 @@
+require mokotouch.inc
+
+DEPENDS = "mokotouch-coreservices-mokotouch"
+
+do_configure(){
+cd ${S}/MokoTouch/Apps/Homescreen
+rm UIKit.framework
+ln -s "${S}/MokoTouch/Frameworks/UIKit/" UIKit.framework
+${OE_QMAKE_QMAKE} Homescreen.pro
+}
+
+do_compile(){
+cd ${S}/MokoTouch/Apps/Homescreen
+oe_runmake
+}
+
+do_install(){
+install -d "${D}/${libdir}"
+install "${S}/MokoTouch/Apps/Homescreen/BUILD/App/libHomescreen.so.1.0.0" "${D}/${libdir}/libHomescreen.so.1.0.0"
+install "${S}/MokoTouch/Apps/Homescreen/BUILD/App/libHomescreen.so.1.0.0" "${D}/${libdir}/libHomescreen.so.1.0"
+install "${S}/MokoTouch/Apps/Homescreen/BUILD/App/libHomescreen.so.1.0.0" "${D}/${libdir}/libHomescreen.so.1"
+install "${S}/MokoTouch/Apps/Homescreen/BUILD/App/libHomescreen.so.1.0.0" "${D}/${libdir}/libHomescreen.so"
+}
diff --git a/recipes/mokotouch/mokotouch-apps-testkeyboard_2.bb b/recipes/mokotouch/mokotouch-apps-testkeyboard_2.bb
new file mode 100644
index 0000000000..6b6fb259d7
--- /dev/null
+++ b/recipes/mokotouch/mokotouch-apps-testkeyboard_2.bb
@@ -0,0 +1,24 @@
+require mokotouch.inc
+
+DEPENDS = "mokotouch-coreservices-mokotouch"
+
+do_configure(){
+cd ${S}/MokoTouch/Apps/TestKeyboard
+rm UIKit.framework
+ln -s "${S}/MokoTouch/Frameworks/UIKit/" UIKit.framework
+${OE_QMAKE_QMAKE} TestKeyboard.pro
+}
+
+do_compile(){
+cd ${S}/MokoTouch/Apps/TestKeyboard
+oe_runmake
+}
+
+do_install(){
+install -d "${D}/${libdir}"
+install "${S}/MokoTouch/Apps/TestKeyboard/BUILD/App/libTestKeyboard.so.1.0.0" "${D}/${libdir}/libTestKeyboard.so.1.0.0"
+install "${S}/MokoTouch/Apps/TestKeyboard/BUILD/App/libTestKeyboard.so.1.0.0" "${D}/${libdir}/libTestKeyboard.so.1.0"
+install "${S}/MokoTouch/Apps/TestKeyboard/BUILD/App/libTestKeyboard.so.1.0.0" "${D}/${libdir}/libTestKeyboard.so.1"
+install "${S}/MokoTouch/Apps/TestKeyboard/BUILD/App/libTestKeyboard.so.1.0.0" "${D}/${libdir}/libTestKeyboard.so"
+}
+
diff --git a/recipes/mokotouch/mokotouch-apps-testtableview_2.bb b/recipes/mokotouch/mokotouch-apps-testtableview_2.bb
new file mode 100644
index 0000000000..247b051ba1
--- /dev/null
+++ b/recipes/mokotouch/mokotouch-apps-testtableview_2.bb
@@ -0,0 +1,24 @@
+require mokotouch.inc
+
+DEPENDS = "mokotouch-coreservices-mokotouch"
+
+do_configure(){
+cd ${S}/MokoTouch/Apps/TestTableView
+rm UIKit.framework
+ln -s "${S}/MokoTouch/Frameworks/UIKit/" UIKit.framework
+${OE_QMAKE_QMAKE} TestTableView.pro
+}
+
+do_compile(){
+cd ${S}/MokoTouch/Apps/TestTableView
+oe_runmake
+}
+
+do_install(){
+install -d "${D}/${libdir}"
+install "${S}/MokoTouch/Apps/TestTableView/BUILD/App/libTestTableView.so.1.0.0" "${D}/${libdir}/libTestTableView.so.1.0.0"
+install "${S}/MokoTouch/Apps/TestTableView/BUILD/App/libTestTableView.so.1.0.0" "${D}/${libdir}/libTestTableView.so.1.0"
+install "${S}/MokoTouch/Apps/TestTableView/BUILD/App/libTestTableView.so.1.0.0" "${D}/${libdir}/libTestTableView.so.1"
+install "${S}/MokoTouch/Apps/TestTableView/BUILD/App/libTestTableView.so.1.0.0" "${D}/${libdir}/libTestTableView.so"
+}
+
diff --git a/recipes/mokotouch/mokotouch-apps-webmobile_2.bb b/recipes/mokotouch/mokotouch-apps-webmobile_2.bb
new file mode 100644
index 0000000000..ec1b8f2be8
--- /dev/null
+++ b/recipes/mokotouch/mokotouch-apps-webmobile_2.bb
@@ -0,0 +1,24 @@
+require mokotouch.inc
+
+DEPENDS = "mokotouch-coreservices-mokotouch"
+
+do_configure(){
+cd ${S}/MokoTouch/Apps/WebMobile
+rm UIKit.framework
+ln -s "${S}/MokoTouch/Frameworks/UIKit/" UIKit.framework
+${OE_QMAKE_QMAKE} WebMobile.pro
+}
+
+do_compile(){
+cd ${S}/MokoTouch/Apps/WebMobile
+oe_runmake
+}
+
+do_install(){
+install -d "${D}/${libdir}"
+install "${S}/MokoTouch/Apps/WebMobile/BUILD/App/libWebMobile.so.1.0.0" "${D}/${libdir}/libWebMobile.so.1.0.0"
+install "${S}/MokoTouch/Apps/WebMobile/BUILD/App/libWebMobile.so.1.0.0" "${D}/${libdir}/libWebMobile.so.1.0"
+install "${S}/MokoTouch/Apps/WebMobile/BUILD/App/libWebMobile.so.1.0.0" "${D}/${libdir}/libWebMobile.so.1"
+install "${S}/MokoTouch/Apps/WebMobile/BUILD/App/libWebMobile.so.1.0.0" "${D}/${libdir}/libWebMobile.so"
+}
+
diff --git a/recipes/mokotouch/mokotouch-coreservices-mokotouch_2.bb b/recipes/mokotouch/mokotouch-coreservices-mokotouch_2.bb
new file mode 100644
index 0000000000..4796d258f3
--- /dev/null
+++ b/recipes/mokotouch/mokotouch-coreservices-mokotouch_2.bb
@@ -0,0 +1,25 @@
+require mokotouch.inc
+
+DEPENDS = "mokotouch-frameworks-uikit"
+
+do_configure(){
+cd ${S}/MokoTouch/CoreServices/MokoTouch
+rm UIKit.framework
+ln -s "${S}/MokoTouch/Frameworks/UIKit/" UIKit.framework
+${OE_QMAKE_QMAKE} MokoTouch.pro
+}
+
+do_compile(){
+cd ${S}/MokoTouch/CoreServices/MokoTouch
+oe_runmake
+}
+
+do_install(){
+install -d ${D}/${sysconfdir}
+install -d ${D}/${bindir}
+
+install qte.env ${D}/${sysconfdir}/mokotouch.env
+install "${S}/MokoTouch/CoreServices/MokoTouch/BUILD/Service/MokoTouch" "${D}/${bindir}/MokoTouch"
+}
+
+FILES_${PN} = "${bindir}/MokoTouch ${sysconfdir}/mokotouch.env"
diff --git a/recipes/mokotouch/mokotouch-frameworks-uikit_2.bb b/recipes/mokotouch/mokotouch-frameworks-uikit_2.bb
new file mode 100644
index 0000000000..cbb3908a74
--- /dev/null
+++ b/recipes/mokotouch/mokotouch-frameworks-uikit_2.bb
@@ -0,0 +1,26 @@
+require mokotouch.inc
+
+do_configure(){
+cd ${S}/MokoTouch/Frameworks/UIKit/
+${OE_QMAKE_QMAKE} UIKit.pro
+}
+
+do_compile(){
+cd ${S}/MokoTouch/Frameworks/UIKit/
+oe_runmake
+}
+
+do_install(){
+install -d "${D}/${libdir}"
+install "${S}/MokoTouch/Frameworks/UIKit/BUILD/libs/libUIKit.so.1.0.0" "${D}/${libdir}/libUIKit.so.1.0.0"
+install "${S}/MokoTouch/Frameworks/UIKit/BUILD/libs/libUIKit.so.1.0.0" "${D}/${libdir}/libUIKit.so.1.0"
+install "${S}/MokoTouch/Frameworks/UIKit/BUILD/libs/libUIKit.so.1.0.0" "${D}/${libdir}/libUIKit.so.1"
+install "${S}/MokoTouch/Frameworks/UIKit/BUILD/libs/libUIKit.so.1.0.0" "${D}/${libdir}/libUIKit.so"
+}
+
+do_stage() {
+install "${S}/MokoTouch/Frameworks/UIKit/BUILD/libs/libUIKit.so.1.0.0" "${STAGING_LIBDIR}/libUIKit.so.1.0.0"
+install "${S}/MokoTouch/Frameworks/UIKit/BUILD/libs/libUIKit.so.1.0.0" "${STAGING_LIBDIR}/libUIKit.so.1.0"
+install "${S}/MokoTouch/Frameworks/UIKit/BUILD/libs/libUIKit.so.1.0.0" "${STAGING_LIBDIR}/libUIKit.so.1"
+install "${S}/MokoTouch/Frameworks/UIKit/BUILD/libs/libUIKit.so.1.0.0" "${STAGING_LIBDIR}/libUIKit.so"
+}
diff --git a/recipes/mokotouch/mokotouch.inc b/recipes/mokotouch/mokotouch.inc
new file mode 100644
index 0000000000..95cb176b17
--- /dev/null
+++ b/recipes/mokotouch/mokotouch.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "MokoTouch a finger friendly QT4-based iphone like GUI for OpenMoko"
+HOMEPAGE = "http://th30z.netsons.org/mokotouch/"
+SECTION = "openmoko/applications"
+LICENSE = "GPL"
+DEPENDS = "gstreamer qt4-x11-free"
+
+PR = "r1"
+
+SRC_URI = "http://th30z.netsons.org/mokotouch/data/mokotouch-2-aug-2009.tar.bz2"
+
+S = "${WORKDIR}/MokoTouch-Project"
+D = "${WORKDIR}/image"
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${OE_QMAKE_INCDIR_QT}/Qt"
+
+inherit autotools qt4x11 distutils-base pkgconfig lib_package