aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2010-01-28 00:24:52 +0100
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2010-01-28 00:38:51 +0100
commit35211e52f175bb31cf3315689c5da7185362672e (patch)
tree298a05658b0094ad55b5084fce7d8196a8811499
parentcdfded760fe70a7de824afa012b1fe3b3713a283 (diff)
downloadopenembedded-35211e52f175bb31cf3315689c5da7185362672e.tar.gz
hal: if necessary, create $CACHEDIR before starting the daemon. Closes: #3740.
-rw-r--r--recipes/hal/files/20hal5
-rw-r--r--recipes/hal/hal_0.5.14+git.bb2
-rw-r--r--recipes/hal/hal_0.5.9.1.bb2
-rw-r--r--recipes/hal/hal_git.bb2
4 files changed, 8 insertions, 3 deletions
diff --git a/recipes/hal/files/20hal b/recipes/hal/files/20hal
index 926bd893e2..e98cc8ac6e 100644
--- a/recipes/hal/files/20hal
+++ b/recipes/hal/files/20hal
@@ -11,6 +11,7 @@
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/hald
+CACHEDIR=/var/cache/hald
PIDDIR=/var/run/hald
PIDFILE=$PIDDIR/pid
NAME=hald
@@ -26,6 +27,10 @@ do_start() {
mkdir -p $PIDDIR
chown $DAEMONUSER:$DAEMONUSER $PIDDIR
fi
+ if [ ! -d $CACHEDIR ]; then
+ mkdir -p $CACHEDIR
+ chown $DAEMONUSER:$DAEMONUSER $CACHEDIR
+ fi
echo "Starting $DESC" "$NAME"
start-stop-daemon --start --pidfile $PIDFILE \
--exec $DAEMON -- $DAEMON_OPTS
diff --git a/recipes/hal/hal_0.5.14+git.bb b/recipes/hal/hal_0.5.14+git.bb
index 6a842cf047..1e1f10e01a 100644
--- a/recipes/hal/hal_0.5.14+git.bb
+++ b/recipes/hal/hal_0.5.14+git.bb
@@ -11,7 +11,7 @@ SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
SRCREV = "6dccf8e3ad181e8f56b1d2a994ec50a1953a1c2d"
PV = "0.5.14"
-PR = "r1"
+PR = "r2"
PR_append = "+gitr${SRCREV}"
S = "${WORKDIR}/git"
diff --git a/recipes/hal/hal_0.5.9.1.bb b/recipes/hal/hal_0.5.9.1.bb
index b666446cc2..a8ea38b2d5 100644
--- a/recipes/hal/hal_0.5.9.1.bb
+++ b/recipes/hal/hal_0.5.9.1.bb
@@ -6,7 +6,7 @@ LICENSE = "GPL LGPL AFL"
DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat virtual/libusb0"
RDEPENDS_${PN} += "udev-utils hal-info"
-PR = "r9"
+PR = "r10"
SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
file://configure_fix.patch;patch=1 \
diff --git a/recipes/hal/hal_git.bb b/recipes/hal/hal_git.bb
index 8bd8285613..58f534d3e1 100644
--- a/recipes/hal/hal_git.bb
+++ b/recipes/hal/hal_git.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
file://99_hal"
PV = "0.5.9.1+git${SRCDATE}"
-PR = "r7"
+PR = "r8"
S = "${WORKDIR}/git"