aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@openmoko.org>2008-06-11 16:46:21 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-11-16 00:54:56 +0100
commitdf38855c7529a5240926bd35d6c32d10571067b4 (patch)
tree0c466ff529d5fc26edf3e0ba2d609299dd9f6a8e
parent2a8503fe16f72c63d77c25594645f4b2b53c195e (diff)
downloadopenembedded-df38855c7529a5240926bd35d6c32d10571067b4.tar.gz
[om2007.2] Install a package which contains the default config
This is derived from openmoko-session2 and is responsible for setting the default values which settings-daemon will pick up and advertise as xsettings.
-rw-r--r--packages/openmoko2/openmoko-asu-om20072-support.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/openmoko2/openmoko-asu-om20072-support.bb b/packages/openmoko2/openmoko-asu-om20072-support.bb
new file mode 100644
index 0000000000..9b0847f55c
--- /dev/null
+++ b/packages/openmoko2/openmoko-asu-om20072-support.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Theme support and defaults to integrate OM2007.2 in the April Software Update"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "openmoko-common2"
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "all"
+
+pkg_postinst_${PN} () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Moko
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme openmoko-standard
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 5"
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/wallpaper ${datadir}/pixmaps/wallpaper.png
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/digital_clock 1
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/poky/peripherals/mouse/drag_threshold 8
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/openmoko/neod/power_management 2
+# gstreamer audio settings
+#gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosink pulsesink
+#gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosrc pulsesrc
+
+}
+