aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfreyther@openembedded.org <freyther@openembedded.org>2008-04-12 15:33:45 +0000
committerHolger Freyther <ich@tamarin.(none)>2008-10-15 18:53:43 +0200
commite85c6582748c96cfc09dec0e20cdb9b8e7eae86a (patch)
treebb35addae099914a4a23d739ac96dfb82edba660
parent0073154a86bdc83340da4bd5be5d7316b1449927 (diff)
downloadopenembedded-e85c6582748c96cfc09dec0e20cdb9b8e7eae86a.tar.gz
wvstreams: Split wvstreams into smaller packages
-rw-r--r--packages/wvstreams/wvstreams_4.4.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/wvstreams/wvstreams_4.4.1.bb b/packages/wvstreams/wvstreams_4.4.1.bb
index f5f7fcbaa8..285edcfcd7 100644
--- a/packages/wvstreams/wvstreams_4.4.1.bb
+++ b/packages/wvstreams/wvstreams_4.4.1.bb
@@ -3,6 +3,8 @@ LICENSE = "LGPL"
DESCRIPTION = "WvStreams is a network programming library in C++"
DEPENDS = "zlib openssl (>= 0.9.8)"
+PR = "r1"
+
SRC_URI = "http://wvstreams.googlecode.com/files/${PN}-${PV}.tar.gz \
file://build-fixes-and-sanity.patch;patch=1 "
@@ -13,6 +15,23 @@ LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
EXTRA_AUTORECONF += " -I${S}/gnulib/m4"
EXTRA_OECONF = " --without-tcl --without-qt --without-pam"
+PACKAGES_prepend = "libuniconf libuniconf-dbg "
+PACKAGES_prepend = "uniconfd uniconfd-dbg "
+PACKAGES_prepend = "libwvstreams-base libwvstreams-base-dbg "
+PACKAGES_prepend = "libwvstreams-extras libwvstreams-extras-dbg "
+
+FILES_libuniconf = "${libdir}/libuniconf.so.*"
+FILES_libuniconf-dbg = "${libdir}/.debug/libuniconf.so.*"
+
+FILES_uniconfd = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
+FILES_uniconfd-dbg = "${sbindir}/.debug/uniconfd"
+
+FILES_libwvstreams-base = "${libdir}/libwvutils.so.*"
+FILES_libwvstreams-base-dbg = "${libdir}/.debug/libwvutils.so.*"
+
+FILES_libwvstreams-extras = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
+FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debug/libwvstreams.so.*"
+
do_stage() {
autotools_stage_all