aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-10-15 20:29:49 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-10-15 20:32:55 +0200
commit7a4455feaa846794343594376bcedadb008cbd38 (patch)
tree05cc2a31c2410b800fd34a72b159dfb0e7e67e7d
parent76640097cf2f5d7c7cd2677372db32d5cc6db48a (diff)
downloadopenembedded-7a4455feaa846794343594376bcedadb008cbd38.tar.gz
add task-fonts-truetype
-rw-r--r--packages/tasks/task-fonts-truetype.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/tasks/task-fonts-truetype.bb b/packages/tasks/task-fonts-truetype.bb
new file mode 100644
index 0000000000..cd8000316c
--- /dev/null
+++ b/packages/tasks/task-fonts-truetype.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Install one of these tasks to get support for truetype fonts."
+SECTION = "fonts"
+LICENSE = "MIT"
+PV = "1.0"
+PR = "r0"
+
+inherit task
+
+PACKAGES += "\
+ ${PN}-core \
+ ${PN}-chinese \
+ ${PN}-japanese \
+"
+
+RRECOMMENDS_task-fonts-truetype = "\
+ ${PN}-core \
+ ${PN}-chinese \
+ ${PN}-japanese \
+"
+
+RDEPENDS_task-fonts-truetype-core = "\
+ fontconfig-utils \
+ \
+ ttf-dejavu-common \
+ ttf-dejavu-sans \
+# ttf-dejavu-serif \
+ ttf-dejavu-sans-mono \
+"
+
+RDEPENDS_task-fonts-truetype-chinese = "\
+ ${PN}-core \
+ ttf-arphic-uming \
+"
+
+RDEPENDS_task-fonts-truetype-japanese = "\
+ ${PN}-core \
+ ttf-sazanami-gothic \
+ ttf-sazanami-mincho \
+"