aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Lübbe <jluebbe@debian.org>2009-02-23 14:28:39 +0000
committerJan Lübbe <jluebbe@debian.org>2009-02-23 14:44:57 +0000
commita190ef96a493166f6dcad1b0bcc511d56ffa689f (patch)
tree945d1d0a9dd1dc18c0b8ac5dd5c3945061730dcc
parent65d4eac9440b11817e7f2ce0d1031d5e06d23ffd (diff)
downloadopenembedded-a190ef96a493166f6dcad1b0bcc511d56ffa689f.tar.gz
pycd: add recipe
-rw-r--r--conf/distro/include/fso-autorev.inc1
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--packages/freesmartphone/pycd_git.bb31
3 files changed, 33 insertions, 0 deletions
diff --git a/conf/distro/include/fso-autorev.inc b/conf/distro/include/fso-autorev.inc
index a84faf1234..5cde5d98eb 100644
--- a/conf/distro/include/fso-autorev.inc
+++ b/conf/distro/include/fso-autorev.inc
@@ -14,4 +14,5 @@ SRCREV_pn-libframeworkd-glib = "${AUTOREV}"
SRCREV_pn-mickeydbus = "${AUTOREV}"
SRCREV_pn-mickeyterm = "${AUTOREV}"
SRCREV_pn-python-pytrc = "${AUTOREV}"
+SRCREV_pn-pycd = "${AUTOREV}"
SRCREV_pn-zhone = "${AUTOREV}"
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 3fd02c00dd..2f4e913871 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -186,6 +186,7 @@ SRCREV_pn-paroli ?= "7a2fdc16174258e9276e7c2d80f500b4dd624442"
SRCREV_pn-portaudio-v19 ?= "1387"
SRCREV_pn-psplash ?= "249"
SRCREV_pn-pty-forward-native ?= "4214"
+SRCREV_pn-pycd ?= "41bcdfdfa6087797026d1337e927ba2cc4d6763f"
SRCREV_pn-pyefl-sudoku ?= "49"
SRCREV_pn-pygsm ?= "976477f6b403f422b4ea730f71ebf409f6671141"
SRCREV_pn-pylgrim ?= "20"
diff --git a/packages/freesmartphone/pycd_git.bb b/packages/freesmartphone/pycd_git.bb
new file mode 100644
index 0000000000..3ed2b75292
--- /dev/null
+++ b/packages/freesmartphone/pycd_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python Clone Factory"
+AUTHOR = "Jan Luebbe <jluebbe@debian.org>"
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "0.1+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+RDEPENDS_${PN} = "\
+ python-dbus \
+ python-misc \
+ python-pkgutil \
+ python-resource \
+"
+
+do_compile() {
+ ${CC} pyc.c -o pyc
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 pyc ${D}${bindir}/pyc
+ install -d ${D}${sbindir}
+ install -m 755 pycd.py ${D}${sbindir}/pycd
+ install -d ${D}${sysconfdir}/dbus-1
+ install -m 644 pycd.conf ${D}${sysconfdir}/dbus-1
+}
+