aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Stohr <Alexander.Stohr@gmx.de>2010-10-26 02:55:49 +0000
committerKhem Raj <raj.khem@gmail.com>2010-11-06 09:02:33 -0700
commitf8d4a50cc0a19a74baeb51279e829861da04302d (patch)
tree74f1a442f9b9ea663447a9b56a31b2463353ed02
parent80d0f2d59c4162ddd0e68205cc859692e427459c (diff)
downloadopenembedded-f8d4a50cc0a19a74baeb51279e829861da04302d.tar.gz
fix for older glib-2.0 versions to build with recent autotools
the attached patch bundles a single fix for glib-2.0 for recipes built upon glib tarballs 2.6.4 to 2.20.4. later versions have the problem fixed in tarball (e.g. 2.22.1 and newer). the problem happens when you need to update autotools for some other reason (e.g. building some newer package) whilst not wanting to update glib at the very same time. it manifests by a badly clobbered "fi" in configure step and thus a still open nesting level when the script ends. the auto tools generated script exposes "fiAC_..." that originates from a too extensive use of the "dnl" statemnt. that construct is only critical with newer auto tools. the fix removes those problematic extra keyword. regards, Alex. see for reference: http://bugs.gentoo.org/show_bug.cgi?id=307775 http://git.gnome.org/browse/glib/commit/?id=c24f6e55276fac68b08df34b0d350f65afe994d9 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/glib-2.0/files/glib-2.6.4-fix-autotools-fiac.patch12
-rw-r--r--recipes/glib-2.0/glib-2.0_2.12.12.bb3
-rw-r--r--recipes/glib-2.0/glib-2.0_2.20.3.bb1
-rw-r--r--recipes/glib-2.0/glib-2.0_2.20.4.bb1
-rw-r--r--recipes/glib-2.0/glib-2.0_2.6.4.bb3
-rw-r--r--recipes/glib-2.0/glib-2.0_2.8.6.bb3
6 files changed, 20 insertions, 3 deletions
diff --git a/recipes/glib-2.0/files/glib-2.6.4-fix-autotools-fiac.patch b/recipes/glib-2.0/files/glib-2.6.4-fix-autotools-fiac.patch
new file mode 100644
index 0000000000..503704dabf
--- /dev/null
+++ b/recipes/glib-2.0/files/glib-2.6.4-fix-autotools-fiac.patch
@@ -0,0 +1,12 @@
+diff -Nru glib-2.6.4.orig/acglib.m4 glib-2.6.4/acglib.m4
+--- glib-2.6.4.orig/acglib.m4 2004-02-27 01:57:25.000000000 +0100
++++ glib-2.6.4/acglib.m4 2010-10-26 14:06:54.000000000 +0200
+@@ -117,7 +117,7 @@
+ [$2],
+ [echo "$as_me: failed program was:" >&AS_MESSAGE_LOG_FD
+ cat conftest.$ac_ext >&AS_MESSAGE_LOG_FD
+-m4_ifvaln([$3],[$3])dnl])dnl
++m4_ifvaln([$3],[$3])dnl])
+ ac_compile="$glib_ac_compile_save"
+ rm -f conftest.$ac_objext conftest.err m4_ifval([$1], [conftest.$ac_ext])[]dnl
+ ])# GLIB_CHECK_COMPILE_WARNINGS
diff --git a/recipes/glib-2.0/glib-2.0_2.12.12.bb b/recipes/glib-2.0/glib-2.0_2.12.12.bb
index 12b24e2a7f..27fbb94cd6 100644
--- a/recipes/glib-2.0/glib-2.0_2.12.12.bb
+++ b/recipes/glib-2.0/glib-2.0_2.12.12.bb
@@ -3,7 +3,8 @@ PR = "${INC_PR}.0"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glib/2.12/glib-${PV}.tar.bz2 \
file://glibconfig-sysdefs.h \
- file://configure-libtool.patch"
+ file://configure-libtool.patch \
+ file://glib-2.6.4-fix-autotools-fiac.patch"
SRC_URI[md5sum] = "0b3a42098243d054475ff6eb51ed2be1"
diff --git a/recipes/glib-2.0/glib-2.0_2.20.3.bb b/recipes/glib-2.0/glib-2.0_2.20.3.bb
index 157ef8077f..9ee8b81f5e 100644
--- a/recipes/glib-2.0/glib-2.0_2.20.3.bb
+++ b/recipes/glib-2.0/glib-2.0_2.20.3.bb
@@ -5,6 +5,7 @@ SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.20/glib-${PV}.tar.bz2;name=tarball \
file://glibconfig-sysdefs.h \
file://configure-libtool.patch \
+ file://glib-2.6.4-fix-autotools-fiac.patch \
"
SRC_URI_append_arm = " file://atomic-thumb.patch"
diff --git a/recipes/glib-2.0/glib-2.0_2.20.4.bb b/recipes/glib-2.0/glib-2.0_2.20.4.bb
index 3d8bb77cd7..2126395a1e 100644
--- a/recipes/glib-2.0/glib-2.0_2.20.4.bb
+++ b/recipes/glib-2.0/glib-2.0_2.20.4.bb
@@ -5,6 +5,7 @@ SRC_URI = "\
http://ftp.gnome.org/pub/GNOME/sources/glib/2.20/glib-${PV}.tar.bz2 \
file://glibconfig-sysdefs.h \
file://configure-libtool.patch \
+ file://glib-2.6.4-fix-autotools-fiac.patch \
"
SRC_URI_append_arm = " file://atomic-thumb.patch"
diff --git a/recipes/glib-2.0/glib-2.0_2.6.4.bb b/recipes/glib-2.0/glib-2.0_2.6.4.bb
index ca3c133f70..fa2ec257e0 100644
--- a/recipes/glib-2.0/glib-2.0_2.6.4.bb
+++ b/recipes/glib-2.0/glib-2.0_2.6.4.bb
@@ -24,7 +24,8 @@ EXTRA_OECONF = "--disable-debug"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/glib-${PV}.tar.bz2 \
file://glibinclude.patch;striplevel=2 \
file://glibconfig-sysdefs.h \
- file://configure-libtool.patch"
+ file://configure-libtool.patch \
+ file://glib-2.6.4-fix-autotools-fiac.patch"
S = "${WORKDIR}/glib-${PV}"
diff --git a/recipes/glib-2.0/glib-2.0_2.8.6.bb b/recipes/glib-2.0/glib-2.0_2.8.6.bb
index f03072a235..c4fd1ca28f 100644
--- a/recipes/glib-2.0/glib-2.0_2.8.6.bb
+++ b/recipes/glib-2.0/glib-2.0_2.8.6.bb
@@ -20,7 +20,8 @@ EXTRA_OECONF = "--disable-debug"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.8/glib-${PV}.tar.bz2 \
file://glibconfig-sysdefs.h \
- file://configure-libtool.patch"
+ file://configure-libtool.patch \
+ file://glib-2.6.4-fix-autotools-fiac.patch"
S = "${WORKDIR}/glib-${PV}"