aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Dirson <ydirson@free.fr>2010-08-03 13:01:20 +0000
committerEric Bénard <eric@eukrea.com>2010-11-06 22:16:10 +0100
commit1d90315fad93be9fc74194a7d227c9e3c25201b1 (patch)
tree8d2f662fbbfbf3ab361932256d91649862e04536
parentf53dd8f34c98380c8f8f13398b4e074cc79dfdd6 (diff)
downloadopenembedded-1d90315fad93be9fc74194a7d227c9e3c25201b1.tar.gz
python-xdg: prevent infinite recursion in xdg.DesktopEntry.__cmp__().
Delete cmp method which has been dropped from later releases. Signed-off-by: Yann Dirson <ydirson@altern.org> Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--recipes/python/python-pyxdg/desktopentry-cmp.patch15
-rw-r--r--recipes/python/python-pyxdg_0.15.bb4
2 files changed, 18 insertions, 1 deletions
diff --git a/recipes/python/python-pyxdg/desktopentry-cmp.patch b/recipes/python/python-pyxdg/desktopentry-cmp.patch
new file mode 100644
index 0000000000..bb2905ab3d
--- /dev/null
+++ b/recipes/python/python-pyxdg/desktopentry-cmp.patch
@@ -0,0 +1,15 @@
+This method definition causes an infinite recursion, and has been dropped
+from later releases.
+
+--- pyxdg-0.15/xdg/DesktopEntry.py.orig 2010-08-03 03:01:34.000000000 +0200
++++ pyxdg-0.15/xdg/DesktopEntry.py 2010-08-03 03:01:46.000000000 +0200
+@@ -29,9 +29,6 @@
+ def __str__(self):
+ return self.getName()
+
+- def __cmp__(self, other):
+- return cmp(self, other)
+-
+ def parse(self, file):
+ IniFile.parse(self, file, ["Desktop Entry", "KDE Desktop Entry"])
+
diff --git a/recipes/python/python-pyxdg_0.15.bb b/recipes/python/python-pyxdg_0.15.bb
index 018af5029c..67b6c979fc 100644
--- a/recipes/python/python-pyxdg_0.15.bb
+++ b/recipes/python/python-pyxdg_0.15.bb
@@ -1,9 +1,11 @@
DESCRIPTION = "PyXDG is a python library to access freedesktop.org standards"
SECTION = "devel/python"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.freedesktop.org/~lanius/pyxdg-${PV}.tar.gz"
+SRC_URI += "file://desktopentry-cmp.patch"
+
S = "${WORKDIR}/pyxdg-${PV}"
inherit distutils