aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-12-01 13:01:23 +1030
committerKhem Raj <raj.khem@gmail.com>2010-12-11 02:02:00 -0800
commit0fe91160de2d59875f680cd8ad40c43adf5687bb (patch)
tree8acf50c6c3954f448fa0f6a6f14bd7a73741d1bc
parente5a90de1dd99518a31618cabe1307ace9a0d7c9f (diff)
downloadopenembedded-0fe91160de2d59875f680cd8ad40c43adf5687bb.tar.gz
gzip_1.4.bb: Fix do_install for DISTRO=micro.
mv: `/mnt/oe/tmp/work/mipsel-oe-linux-uclibc/gzip-1.4-r3/image/bin/gunzip' and `/mnt/oe/tmp/work/mipsel-oe-linux-uclibc/gzip-1.4-r3/image/bin/gunzip' are the same file Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Michael Smith <msmith@cbnco.com>
-rw-r--r--recipes/gzip/gzip_1.4.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes/gzip/gzip_1.4.bb b/recipes/gzip/gzip_1.4.bb
index eb89f79877..020e31acb9 100644
--- a/recipes/gzip/gzip_1.4.bb
+++ b/recipes/gzip/gzip_1.4.bb
@@ -19,10 +19,12 @@ alternatives = "gunzip gzip zcat"
do_install () {
autotools_do_install
# Move files into /bin (FHS)
- install -d ${D}${base_bindir}
- for file in ${D}${bindir}/*; do
- mv $file ${D}${base_bindir}/
- done
+ if [ "${base_bindir}" != "${bindir}" ]; then
+ install -d ${D}${base_bindir}
+ for file in ${D}${bindir}/*; do
+ mv $file ${D}${base_bindir}/
+ done
+ fi
}
do_install_append_pn-gzip () {