aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2011-03-25 10:47:44 +0100
committerKoen Kooi <koen@openembedded.org>2011-03-25 10:54:37 +0100
commit8f1b80d91883675120dc26950f638639ba4bb87e (patch)
tree19abe0384d8d9c62de8fc93cf99521c554eacdd8
parent181c4ed14b9944c059ec593ba69f9a235048db52 (diff)
downloadopenembedded-8f1b80d91883675120dc26950f638639ba4bb87e.tar.gz
u-boot-git: Add omap4430-panda to u-boot git recipe
* Enable u-boot git to build for pandaboard Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/u-boot/u-boot-git/fix-break-caused-by-new-binutils.patch31
-rw-r--r--recipes/u-boot/u-boot_git.bb10
2 files changed, 40 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-git/fix-break-caused-by-new-binutils.patch b/recipes/u-boot/u-boot-git/fix-break-caused-by-new-binutils.patch
new file mode 100644
index 0000000000..16bc9803bd
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/fix-break-caused-by-new-binutils.patch
@@ -0,0 +1,31 @@
+Index: git/arch/arm/cpu/armv7/omap4/Makefile
+===================================================================
+--- git.orig/arch/arm/cpu/armv7/omap4/Makefile
++++ git/arch/arm/cpu/armv7/omap4/Makefile
+@@ -26,6 +26,8 @@ include $(TOPDIR)/config.mk
+ LIB = $(obj)lib$(SOC).o
+
+ SOBJS += lowlevel_init.o
++plus_sec := $(call as-instr,.arch_extension sec,+sec)
++lowlevel_init.o: AFLAGS += -Wa,-march=armv7-a$(plus_sec)
+
+ COBJS += board.o
+ COBJS += mem.o
+Index: git/config.mk
+===================================================================
+--- git.orig/config.mk
++++ git/config.mk
+@@ -266,3 +266,13 @@ cmd_link_o_target = $(if $(strip $1),\
+ rm -f $@; $(AR) rcs $@ )
+
+ #########################################################################
++
++# Tries to compile an assembly instruction
++as-instr = $(shell if echo -e "$(1)" | \
++ $(CC) $(AFLAGS) -c -xassembler - \
++ -o $(TMPOUT)astest$$$$.out > /dev/null 2>&1; \
++ then rm $(TMPOUT)astest$$$$.out; echo "$(2)"; \
++ else echo "$(3)"; fi)
++
++#########################################################################
++
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index c85f5b6b29..08fd645b85 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR = "r73"
+PR = "r74"
FILESPATHPKG =. "u-boot-git:"
@@ -201,6 +201,14 @@ SRC_URI_overo = "git://www.sakoman.com/git/u-boot.git;branch=omap4-exp;protocol=
SRCREV_overo = "261733408a27d14590cf3ec6b596461808050e32"
PV_overo = "2010.12+${PR}+gitr${SRCREV}"
+FILESDIR_omap4430-panda = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-sakoman/"
+SRC_URI_omap4430-panda = "git://www.sakoman.com/git/u-boot.git;branch=omap4-exp;protocol=git \
+ file://fix-break-caused-by-new-binutils.patch \
+ "
+SRCREV_omap4430-panda = "261733408a27d14590cf3ec6b596461808050e32"
+PV_omap4430-panda = "2010.12+${PR}+git${SRCREV}"
+PE_omap4430-panda = "1"
+
# DaVinci dm355-evm/dm365-evm/dm6446-evm/dm6467-evm/dm6467t-evm - PSP 3.1.0/3.2.0 (build 35)
SRC_URI_dm355-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git;branch=u-boot-davinci-2009.06"