aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2011-03-15 10:58:26 +0100
committerKhem Raj <raj.khem@gmail.com>2011-03-19 17:47:53 -0700
commit4fd09dddd05b4e2f397f2e6603c834480ece9c86 (patch)
treeefb2b373bf1010f7a53ed5df502977e99989e31b
parent08f214deb957944b4354870d4a8969e68e500055 (diff)
downloadopenembedded-4fd09dddd05b4e2f397f2e6603c834480ece9c86.tar.gz
mango-lassi: `touch config.rpath` to fix `configure.ac:127: required file `./config.rpath' not found`
Task configure fails with the following error message. Build Configuration: BB_VERSION = "1.12.0" METADATA_BRANCH = "<unknown>" METADATA_REVISION = "b1fbaf6" TARGET_ARCH = "arm" TARGET_OS = "linux-gnueabi" MACHINE = "beagleboard" DISTRO = "angstrom" DISTRO_VERSION = "v20110315" TARGET_FPU = "hard" […] autoreconf: running: /oe/build-angstrom-next/angstrom-dev/sysroots/i686-linux/usr/bin/autoheader --include=/oe/build-angstrom-next/angstrom-dev/sysroots/armv7a-angstrom-linux-gnueabi/usr/share/aclocal-1.11 --include=/oe/build-angstrom-next/angstrom-dev/sysroots/armv7a-angstrom-linux-gnueabi/usr/share/aclocal --force --warnings=cross autoreconf: running: automake --foreign --add-missing --copy --force-missing --warnings=cross automake: unknown warning category `cross' configure.ac:39: installing `./compile' configure.ac:127: installing `./config.guess' configure.ac:127: required file `./config.rpath' not found configure.ac:127: installing `./config.sub' configure.ac:27: installing `./install-sh' configure.ac:27: installing `./missing' Makefile.am: installing `./depcomp' autoreconf: automake failed with exit status: 1 + oefatal 'autoreconf execution failed.' + echo FATAL: 'autoreconf execution failed.' FATAL: autoreconf execution failed. + exit 1 `touch config.rpath` in `do_configure_perpend() {}` fixes the issues. Mango Lasso includes `bootstrap.sh` [1] which also does the same. Using `bootstrap.sh` [1] for configuring Mango Lassi is not considered because `pulseaudio_git.bb` [2] also uses the proposed fix. [1] http://git.0pointer.de/?p=mango-lassi.git;a=blob;f=bootstrap.sh;h=089d445b3cce3374b48fc083f1f87983c4100052;hb=HEAD [2] http://cgit.openembedded.org/cgit.cgi/openembedded/tree/recipes/pulseaudio/pulseaudio_git.bb?id=fcb12f3a4448621ccc75d37dcad4a01820fdf89d#n27 Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/avahi/mango-lassi_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes/avahi/mango-lassi_git.bb b/recipes/avahi/mango-lassi_git.bb
index 1faee4baef..049ac24b2a 100644
--- a/recipes/avahi/mango-lassi_git.bb
+++ b/recipes/avahi/mango-lassi_git.bb
@@ -11,3 +11,6 @@ S = "${WORKDIR}/git"
inherit autotools
+do_configure_prepend() {
+ touch config.rpath
+}