aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2011-05-04 20:28:24 +0200
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2011-05-04 20:28:24 +0200
commitecee5a41d26efafad5a5f889e280e3bd7016911c (patch)
tree2df2e8b9c7df2e14be5ec08fe28faca6339c4cae
parentcd15fbacb67561a86522e1539037082e42de1801 (diff)
downloadopenembedded-ecee5a41d26efafad5a5f889e280e3bd7016911c.tar.gz
linux: bump version to .5 and fix x86_32 compilation
Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
-rw-r--r--recipes/linux/linux-2.6.38/x86_32-syscall_trace-asmregparm.patch21
-rw-r--r--recipes/linux/linux_2.6.38.bb9
2 files changed, 26 insertions, 4 deletions
diff --git a/recipes/linux/linux-2.6.38/x86_32-syscall_trace-asmregparm.patch b/recipes/linux/linux-2.6.38/x86_32-syscall_trace-asmregparm.patch
new file mode 100644
index 0000000000..2b51e2d7f3
--- /dev/null
+++ b/recipes/linux/linux-2.6.38/x86_32-syscall_trace-asmregparm.patch
@@ -0,0 +1,21 @@
+--- /scratch/obj.x86_64/oe/build/tmp/work/qemux86-oe-linux-uclibc/linux-2.6.38-r4/linux-2.6.38/arch/x86/include/asm/ptrace.h.old 2011-03-15 02:20:32.000000000 +0100
++++ /scratch/obj.x86_64/oe/build/tmp/work/qemux86-oe-linux-uclibc/linux-2.6.38-r4/linux-2.6.38/arch/x86/include/asm/ptrace.h 2011-05-04 20:21:37.755073517 +0200
+@@ -130,6 +130,7 @@ struct pt_regs {
+
+ #ifdef __KERNEL__
+
++#include <asm/linkage.h>
+ #include <linux/init.h>
+
+ struct cpuinfo_x86;
+@@ -143,8 +144,8 @@ extern void send_sigtrap(struct task_str
+ int error_code, int si_code);
+ void signal_fault(struct pt_regs *regs, void __user *frame, char *where);
+
+-extern long syscall_trace_enter(struct pt_regs *);
+-extern void syscall_trace_leave(struct pt_regs *);
++extern asmregparm long syscall_trace_enter(struct pt_regs *);
++extern asmregparm void syscall_trace_leave(struct pt_regs *);
+
+ static inline unsigned long regs_return_value(struct pt_regs *regs)
+ {
diff --git a/recipes/linux/linux_2.6.38.bb b/recipes/linux/linux_2.6.38.bb
index 54ad1d5ea4..a768ab3b20 100644
--- a/recipes/linux/linux_2.6.38.bb
+++ b/recipes/linux/linux_2.6.38.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r3"
+PR = "r4"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
@@ -13,7 +13,8 @@ DEFAULT_PREFERENCE_spitz = "1"
DEFAULT_PREFERENCE_tosa = "1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.4.bz2;apply=yes;name=stablepatch \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.5.bz2;apply=yes;name=stablepatch \
+ file://x86_32-syscall_trace-asmregparm.patch \
file://defconfig "
SRC_URI_append_akita = " file://${LOGO_SIZE}/logo_linux_clut224.ppm.bz2 "
@@ -25,5 +26,5 @@ SRC_URI_append_spitz = " file://${LOGO_SIZE}/logo_linux_clut224.ppm.bz2 "
SRC_URI[kernel.md5sum] = "7d471477bfa67546f902da62227fa976"
SRC_URI[kernel.sha256sum] = "72f0cfaefb8dc86b219d5a742dd0375332627641ecbdf5badd3158e2127b9304"
-SRC_URI[stablepatch.md5sum] = "6ef1279c7bd0078fc0fd50aa83e86203"
-SRC_URI[stablepatch.sha256sum] = "64abfd999ac9416db143293528f73a0b88ac287bf4d075556dc7859017d97687"
+SRC_URI[stablepatch.md5sum] = "c8f233d1d31030eb019ab391071e65c2"
+SRC_URI[stablepatch.sha256sum] = "46213fd83da87a066f4b6462c043149638bcaca423d6a932d8434e9d27c7140b"